Jump to content

Sean Fay

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Sean Fay

  • Rank
    Newbie
  1. Sean Fay

    My Roxio Gamecap Hd Pro Says "select Video Device Failed"

    I unplugged all of the component cables that were connected to the Input and Output sides of the RGC, and replaced it with HDMI for the Input and Output. I opened up GameCap, still a black screen. I'm also still getting "Select video device failed" from the RGC's capture software.
  2. Sean Fay

    My Roxio Gamecap Hd Pro Says "select Video Device Failed"

    I have tried that and still have not found a resolution. I uninstalled the Roxio software and re-installed it (while not checking for updates). I booted up GamerCap and all I get is a black screen. It reads the capture card, but just shows a black screen. I tried another USB cable that has the same shaped end as the one that was provided in the box and the Roxio GameCap does not light up, assuming that indicates that it does not read the USB Cable that I used.
  3. Sean Fay

    My Roxio Gamecap Hd Pro Says "select Video Device Failed"

    No, I have no other applications open when running the capture software.
  4. Sean Fay

    My Roxio Gamecap Hd Pro Says "select Video Device Failed"

    After completing all of the steps you have mentions, it stills says "Select video device failed" upon startup of the ROXIO GameCapture HD Pro's capture software. It did not fix the problem.
  5. Sean Fay

    My Roxio Gamecap Hd Pro Says "select Video Device Failed"

    I'll try that and let you know. Thanks!
  6. Hello community, I have had the ROXIO GameCapture HD Pro for around 2 1/2 months. It was working great and I was capturing some pretty cool footage. However, when I finally started it up after not using it for a long time, it tells me "Select video device failed." when I start up the Capture software. I have all the correct cords plugged into the correct places in the TV and my PS3, and I have plugged in the USB cord into the ROXIO GameCap and the USB Drive on my computer. I am out of possible thoughts as to what could be causing the problem, and I would really like some help so that I can get my YT Channel going! If it's okay, here's a video I posted demonstrating the problem (somewhat): Does anyone have any thoughts on the origin of this problem?
×