Jump to content

shrutpatel

Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About shrutpatel

  • Rank
    Newbie
  1. I know it's been so long since I commented about my issue but I choose to just give up for a few months. Yesterday however, I tried plugging the usb cable into another computer and it also wasn't recognized and nothing popped up in the device manager under "Sound, Video, and Game Controllers". The weird thing is that the main light on my game capture turns on so any advice?
  2. Yes, the main light works, but the 2 smaller ones do not. Also, I have tried all the USB ports on my computer and the same thing happens.
  3. Sorry for these posts but the HDMI and YBbPr lights do not work.
  4. Also, the light on the capture card turns on but nothing shows up in the Device Manager like i've said. Do you think I should just uninstall the whole program and reinstall it?
  5. Here's what shows up. When I plug in and unplug the device, nothing shows up in the Device Manager. Do you think it is a problem with the actual USB since it won't register?
  6. When I plug in the USB device, and under the 2 main categories of "Sound, video, etc" and "Universal Serial Bus", nothing shows up or anything, and I too am wiered out by this as usually it will tell you something, if its recgonized or not.
  7. Just my microphone and "Intel Display Audio".
  8. So here is the story: I got my Roxio Game Capture 2 years ago, and I have a laptop without a CD Drive, so I installed it on my dad's computer with a CD Drive and transfered to files to my laptop. For the past 2 years everything was working fine, and I was using the device perectly fine last night. This morning, I go to plug in the USB into my laptop and it says the "USB was not Recognzied", so I followed the steps on other forums, uninstalled the USB device from the Device Manager, etc. When I got to the part where you had to insert the disc and install it again, I couldn't since my laptop does not have a CD Drive, so I just used the 2.0 update and reinstalled the program. Now when I plug in the USB, nothing even happens, and it does not even tell me that the USB device is recognized or not. I fell like this happened when I uninstalled it from the Device Manager but need help, and would like to get it working again as soon as possible.
×