Jump to content
  • 0
mrzeon99

Black Screen When Trying To Use Roxio Game Capture Hd Pro With My Ps4

Question

So let me tell you the hardware and setup I am using when trying to use my Roxio Game Capture HD Pro, and then I will explain my problem:

 

Hardware:

 

-playstation 4

 

-Roxio Game Capture HD Pro

 

-Roxio Game Capture HD Pro software

 

-ASUS VS228H-P 22-Inch Full-HD 5ms LED-Lit LCD Monitor

 

Link:

http://www.amazon.com/gp/product/B005BZNDOO/ref=oh_aui_detailpage_o09_s00?ie=UTF8&psc=1

 

-2 HDMI cords

 

Setup:

 

-1 hdmi cord connects to the ps4 and goes into the input hdmi slot on the roxio game capture hd pro device.

 

-The 2nd hdmi cord goes into the output hdmi slot on the roxio game capture hd pro device and goes into my hdmi monitor.

 

-The USB cord connects to my pc from the roxio game capture hd pro device.

 

-I disabled HDCP from my ps4 as shown from the roxio youtube channel:

 

 

Problem:

 

-When I turn my ps4 on, my screen is just black.

 

-when I go to the roxio game capture recording software while my ps4 is on and connected, the input is set to hdmi and the status says Ready in green text.

 

-But when i look at the preview screen, its just black.

 

-When i just hook the hdmi cord from the ps4 directly into my monitor, i can see picture from the ps4 and play my games normally.

 

 

So what can I do to actually see picture instead of a black screen so i can finally start recording?

 

Please help as soon as possible! Thanks!

  • Like 1

Share this post


Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 0

The RGC pass through adds HDCP code and it appears your monitor doesn't accept that.

 

Only way around it is to use an HDMI splitter Before the RGC so that HDMI from your PS4 goes directly (through the splinter) to your monitor ;)

Share this post


Link to post
Share on other sites
  • 0

So I am using a OREI HD-102 1x2 1 Port HDMI Powered Splitter Ver 1.3 Certified for Full HD 1080P & 3D Support (One Input To Two Outputs):

 

http://www.amazon.com/gp/product/B005HXFARS/ref=oh_aui_detailpage_o06_s00?ie=UTF8&psc=1

 

The only thing I changed in my setup is adding the splitter.

 

-hdmi cord goes from the ps4 to the input on the splitter

 

-the splitter is powered

 

-one hdmi cord goes from the first output on the splitter into my monitor

 

-second hdmi cord goes from the second output on the splitter into the input on my roxio game capture hd pro device

 

-roxio game capture hd pro button is lit and is plugged into my computer with the usb cord

 

-the ps4 hdcp is still disabled, not that it matters with a splitter now.

 

-the roxio game capture hd pro software says NO SIGNAL in red next to status

 

-however now, i can see video from my ps4 and now can use it, however i still can't record with the roxio game capture hd pro cause it is not sending any singal to the software.

 

Do I need to set some settings in the recording software so it can get a signal? I really want this to work. thanks!

Share this post


Link to post
Share on other sites
  • 0

Just to verify the slitter is working ok, interchange the two outputs from the splitter and see if the problem moves over to the monitor.

Share this post


Link to post
Share on other sites
  • 0

I am getting picture from the ps4 when using output 1 and output 2. it just doesnt send a signal into the roxio game capture hd pro device if i connect a hdmi cord to it

Edited by mrzeon99

Share this post


Link to post
Share on other sites
  • 0

Make absolutely sure you have your PS4 set to a specific output and not left in some 'auto' setting!!!!!!!!!

 

Confirm that if you run the HDMI DIRECTLY to the RGC you get a Green 'Ready' indication?

Share this post


Link to post
Share on other sites
  • 0

I changed my video output settings from my ps4 from automatic to full. here is all my settings now:

 

http://imgur.com/a/O2gJB

 

there is still no video outputing to the RGC with the splitter or just directly a hdmi from the ps4 to RGC

 

If I directly hook up the hdmi from the ps4 to the RGC, the status still says READY in green, but there is no picture in the recording software

 

if i hooked up a hdmi from the splitter to the RGC the status still says NO SIGNAL in red in the recording software.

 

 

it might be worth noting that when using my splitter, it has a 2 small orange light next to both output ports.

 

The light goes on if its sending a signal, for example, the light next to the hdmi por that goes to my monitor is always on because i am receiving video from the ps4.

 

the light blinks 2 times when i try to hook up the hdmi from the splitter to the RGC

Share this post


Link to post
Share on other sites
  • 0

As a test, try hooking up a DVD/BD player instead of the PS4......running out of ideas.

Share this post


Link to post
Share on other sites
  • 0

But if he's got HDCP disabled in the PS4, then I don't suspect it will add it either. So I wouldn't think that's the problem. But he definitely needs HDCP disabled on the PS4.

Share this post


Link to post
Share on other sites
  • 0

Well thanks for informing me that my splitter doesn't bypass Hdcp, but my Hdcp is off on my ps4, like Dewey said and I still am not seeing any video on the recording software. Should I try reinstalling it? Is there a update I am missing?

Share this post


Link to post
Share on other sites
  • 0

Well I do not have a dvd player, but I did try my xbox 360.

 

-hdmi goes from xbox to hdmi splitter

 

-one hdmi cord goes from splitter to monitor

 

-other hdmi cord goes from splitter to the input on the RGC

 

-in the satus screen on the recording software, it says READY in green text, but doesnt show and video in the preview screen, like the exact same problem with my ps4

Share this post


Link to post
Share on other sites
  • 0

Did you change your Xbox settings for HDMI Color Space from Auto to Source, and then select 1080p Auto is only used when you are hooked up to your TV.

Share this post


Link to post
Share on other sites
  • 0

I just tried hooking up my hd component cables through the RGC to my tv and I actually get video on both my tv and recording software preview screen, i just had to change the video output to 1080i. but i still cant get video with my hdmi cord when the video output is 1080p. the status just shows READY in green but the preview screen is black.

Share this post


Link to post
Share on other sites
  • 0

I just tried hooking up my hd component cables through the RGC to my tv and I actually get video on both my tv and recording software preview screen, i just had to change the video output to 1080i. but i still cant get video with my hdmi cord when the video output is 1080p. the status just shows READY in green but the preview screen is black.

d

 

You aren't going to get anything in 1080p as you found out. Put your output to 1080i, and it works. And you wouldn't notice the difference anyway.

Share this post


Link to post
Share on other sites
  • 0

As a person who was having an issue, changing the resolution manually fixed my issue in the PS4 settings.
Thanks for this thread, it was really useful just wish finding it wasn't as hard as it was.

Solution to this problem.
"How to Fix Roxio HD capturing gameplay but not displaying on TV"

Now hopefully that will get added to googles meta data and make finding this easier for everyone.
xD

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×