Jump to content

Question

When I purchased the capture card a couple months ago, I ran into no problems whatsoever. Then about a month ago, I got a good amount of blue screens when I tried recording game play on my PS4. So i decided to refresh my PC, since I imagined it may work. Sure enough, it did! But recently I've been having the same problem again. I tried repairing it, but it didn't work. I refreshed my PC multiple times with no success. The problems I run into are: blue screens, black TV screen, and pop ups stating "Capture Card Lost." I've also noticed that when I record PC games instead of the PS4, i don't run into blue screens. It's probably just luck that I didn't, but can the problem possibly be my PS4? Roxio Game Capture? PC?

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Yes and No...

 

Blue screens are when software fail without any error trapping that works (can be hardware too - which makes it madding)

 

The 'Capture Card Lost' is interesting in that it means what it says! That coudl be the USB ports (RGC or PC) or cable.Change Cable & Ports! Also make sure the connector at the RGC is solid and stable.

 

When you have this issue, reboot and hook up another source to see if it is the PS4.

 

It would be helpful to test it on another PC! If you don't have one, loan it to a friend to try out.

Share this post


Link to post
Share on other sites
  • 0

I tried it on my other PC and it worked just fine. It might actually be my PC. One thing i forgot to mention was before I started getting blue screens, a pop up that said "Update to 2.1 version" appeared. I updated it and that's when problems starred occurring. I checked the website to see what can be the problem might be and I found that the latest version is 2.0 not 2.1. Why did I get that pop up?

Share this post


Link to post
Share on other sites
  • 0

2.1 is the latest version but only through the software and it does not cause any issues...

 

However, if you uninstall it on your main PC then reinstall without the 2.1??? -_-

Share this post


Link to post
Share on other sites
  • 0

"Yes" is a little ambiguous here. "Yes, it works okay without applying 2.1?" Or, "Yes, I still have the same problem even without 2.1?"

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×