Jump to content
  • 0
Sign in to follow this  
Woodsy

Cant Capture Using Roxio Software

Question

Hello! I have a problem with the HD pro software, previously it has been working fine, i have been using the Roxio product for youtube content for the past several years, however few days ago i made a mistake somehow and now the software does NOT work. i re installed it and now i get this, "Critical Registry Keys Needed For This Application Missing" - I successfully installed it but the capture wont open, i went on control panel, double clicked to repair and it says locato Roxio game capture hd pro.msi

Please support

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

That is a tough one for the RGC as the only listing in the Knowledge Base is for Creator 2012 & NXT...

I think your best course is the following:

This is extensive, but it what I suggest...
(Add Nothing! - Skip Nothing!)

Unplug your RGC Device and put it aside until you are completely finished.

Download and install the Revo Uninstaller. Then run it in Moderate Mode to remove any traces of Roxio.

Turn OFF any A/V & Firewall.

Reboot


Copy your entire disc to a new folder on your HDD.

In that new folder, right click on Setup.exe and select Properties.

Under the Compatibility tab, make sure nothing is checked!

Right click Setup.exe and select Open.

Allow it to Check for Updates (this is for Roxio not Windows)

Use the Default Locations!

When the Install competes, turn your AV & Firewall back on and reboot.

Let us know ;)

Share this post


Link to post
Share on other sites
  • 0

Yeh going to try this, when i also installed the Software i first had to install the install disc (digitally) however when i did install it, it wouldn't install all the required files so i had to install the update from the site which then adds everything back on (unusual way of installing) Now i go into the Media import folder to launch MediaCaptureGame1X and i get the error "

Error: The application has failed to start because the side by side configuration is incorrect please see the application event log or use the command line sxstrace.exe tool for more detail"

Share this post


Link to post
Share on other sites
  • 0

Now i did exactly those steps and the setup.exe only installed few files, certificates, common, media import,share and uth5x. Nothing else is installed so i cant even launch the software

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×