Jump to content
  • 0
Mark Lewis

Can't Get Corel Toast Titanium To Work

Question

Hello


I have having serious difficulty getting Corel Toast working.

Indeed it worked for a while in version 14 and then stopped after a reinstall to El Capitan.

Its no better in Sierra.

Its just eats available memory (according to CleanMyMac3)


For a while it took like 3 minutes to bring up like an audio CD window, now it just eats memory and does nothing at the end.


On a 2011 iMac, 16 Gb.

Lots of disk space


Thanks in advance

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I am having the same exact issues on my new Macbook Pro with touch bar, even after updating to Toast 15.1. What ever the fixes were that are noted in the 15.1 update on the website for Sierra, they are incomplete and Roxio has much more work to do.



I can not recommend this product at this time to anyone.


Share this post


Link to post
Share on other sites
  • 0

After contacting Roxio support, I received the following instructions from "Ton", which failed to resolve the issues:

 

Thank you for contacting Corel Customer Support. My name is Ton and I have been assigned to your case.

I understand that you are having issues with the product. Let me go ahead and help you.
Please follow the procedure below to completely remove and reinstall Toast.

Quit Toast, trash the entire Toast 15 Titanium folder (located in Finder > Applications), then do the same for any previous versions of Toast, if you still have any installed. You need to remove all previous versions of Toast to avoid possible conflicts. Next is to check for the files listed below. If you see any of them, trash them:

"Roxio Toast Prefs"
“com.roxio.ScreenCapture.plist”
"com.roxio.toast.plist"
"com.roxio.Toast.LSSharedFileList.plist"
"com.roxio.MyDVD.plist"
"com.roxio.videoplayer.plist"
“com.roxio.videoplayer.LSSharedFileList.plist”
“com.corel.Toast-Audio-Assistant.plist”

You should be able to locate these files in ~/Library/Preferences. On the taskbar at the top, click on "Go", and select "Go To Folder...". Type in "~/Library/Preferences", without the quotes. Locate the above files in the Preferences folder that comes up and delete them. You must use this procedure because this particular Library folder is hidden from view, and this is how to open hidden folders.

Once the procedure is complete, reboot your Mac, then re-install Toast 15.

Please do not hesitate to contact us with any further questions.

Regards,
TON
Corel Technical Support Services

-------------------------

I let Roxio Customer Support know that this failed to resolve the issues. Hopefully they will provide a real solution soon.

Share this post


Link to post
Share on other sites
  • 0

Further back and forth with TON from Corel tech support led to my creating a new admin account on my Mac and installing Toast 15 there, where it ran well. Unfortunately, I can not be creating a new admin account to run each new program I purchase separately. I reminded him that my own user account where I initially installed Toast 15 is also an Admin account, but have not heard back. I have again asked for a solution to the initial issue.

Share this post


Link to post
Share on other sites
  • 0

i just purchased toast 15 pro and can't get it to work on mavericks (10.9.5) either. I had problems even installing it initially when I purchased it a few days ago (the rep sent me the latest version install file, and that installed finally after having to delete all traces of the program on my system). the latest version is now installed, however, it STILL won't work. it just HANGS, while the "busy" beachball spins indefinitely. It is installed on an admin account.

 

I am already working with a support rep, but have yet to resolve the issue, as i am still having problems activating the other included software installations (corel painter essentials 5), which the support rep is addressing first.

 

i am pretty frustrated that everything is so difficult... wish i had just bought an external USB drive instead.

 

I had used this software on a mac many years ago and didn't have one problem. WHY is everything so complicated and problematic now? I really hope I can use it... what happens if the problems can't be fixed I wonder?

Edited by frustratedwithtoast

Share this post


Link to post
Share on other sites
  • 0

I really hope I can use it... what happens if the problems can't be fixed I wonder?

As a last resort, if a product doesn’t work, you should ask a refund from your place of purchase. Online purchases directly from Roxio/Digital River offer a 30-day money back guarantee. So don’t waste those 30 days.

 

But others do get it to work, so there should be some effort in finding out what is different about your setup, and how to make the software play nice on your system.

Share this post


Link to post
Share on other sites
  • 0

I can't get toast 15 to even open. I have spent hours "Chatting" with "technical assistance" and gotten nowhere. I also received the same instructions on how to fix it by deleting and reinstalling. The people you "Chat" with are no help and the supervisors are never available. They say they will call to help but don't. Unfortunately it has been over 30 days since I bought it because I have surgery. Please don't buy this product from this company it is awful and the company is worse.

Share this post


Link to post
Share on other sites
  • 0

I have the same issue as "Critter81" and received the same lame support response. I am not to happy with Toast product these days. I have used Toast for many years and have had several versions of it and have never had any problems before this. This version however (Titanium 15) is terrible. I have spent way to much time troubleshooting as pre tech support requests and it still doesn't work. I feel Roxio needs to main a new "working" update version. It feels kinda of like buying a clone copy of Toast that's doesn't work. Bad business in my opinion.

 

Mac 10.12.3

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×