Jump to content

Roxio Community

Cannot uninstall Roxio Creator DE


  • Please log in to reply
8 replies to this topic

#1 Morty

Morty

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 20 July 2007 - 05:16 PM

Help! I cannot, for the life of me, uninstall Roxio Creator DE off my Vista machine. I tried uninstalling it from Safe Mode, but get an error that my Windows Installer was not installed correctly, or something like that (way to go Microsoft!) and I've tried 3rd party software to uninstall it and nothing. Since this is a new machine, I have no files saved on it, none what's so ever, I'm really close to formatting this thing.

Does anyone have any other ideas, same problems, or an answer, please hit me back!

Morty

More info on box:
Dell Inspiron 1405e (brand spankin' new)
Windows Vista Ultimate

#2 Beerman

Beerman

    Digital Beer Guru

  • Digital Guru
  • -7,000 posts
  • Gender:Male
  • Location:Just outside the Big Easy

Posted 20 July 2007 - 05:25 PM

QUOTE (Morty @ Jul 20 2007, 08:16 PM) <{POST_SNAPBACK}>
Help! I cannot, for the life of me, uninstall Roxio Creator DE off my Vista machine. I tried uninstalling it from Safe Mode, but get an error that my Windows Installer was not installed correctly, or something like that (way to go Microsoft!) and I've tried 3rd party software to uninstall it and nothing. Since this is a new machine, I have no files saved on it, none what's so ever, I'm really close to formatting this thing.

Does anyone have any other ideas, same problems, or an answer, please hit me back!

Morty

More info on box:
Dell Inspiron 1405e (brand spankin' new)
Windows Vista Ultimate

Is there no entry in the Control panel to remove this program?  You might try the MS clean up utility I've not used it in Vista but I'm pretty sure it works there.  
I had a similar problem in XP many years back that the uninstaller of a program was corrupt so I simply reinstalled the program then I was able to uninstall it  normally.
Paul
------
Custom Built ASUS P8Z77 V-Deluxe, Core i7 3770k, 16 GB Memory-ASUS ENGTX560 DCII TOP/2DI/1GD5 GeForce GTX 560, H80i Cooler, 750W Power Supply, COOLER MASTER HAF XM RC-922XM-KKN1 case,Corsair Force Series GS CSSD-F240GBGS-BK 2.5" 240GB SATA III SSD, InfiniTV4 & HDHomerun Tuners- running Windows 8 (and other goodies)
#2-P877WS- Core i7 3770k, 16GB Memory-GeForce GTX 650Ti, SATA III SSD, H100i cooler, 750W PS,

#3 Morty

Morty

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 21 July 2007 - 09:30 AM

It's there, in the Add/Remove Programs. When I attempt to unintall that way, it goes through the motion, but once I close and open up the Add/Remove Programs, they all reappear in the list. I tried searching through the Roxio folder to see if they have their own uninstaller, but nothing there as well.

I tried the clean up program from the link you provided me. It removed it from the Add/Remove list, but that's all it does, right? It's still in the registry.

Should I reinstall and see if I can uninstall correctly?

#4 Beerman

Beerman

    Digital Beer Guru

  • Digital Guru
  • -7,000 posts
  • Gender:Male
  • Location:Just outside the Big Easy

Posted 21 July 2007 - 09:52 AM

QUOTE (Morty @ Jul 21 2007, 12:30 PM) <{POST_SNAPBACK}>
It's there, in the Add/Remove Programs. When I attempt to unintall that way, it goes through the motion, but once I close and open up the Add/Remove Programs, they all reappear in the list. I tried searching through the Roxio folder to see if they have their own uninstaller, but nothing there as well.

I tried the clean up program from the link you provided me. It removed it from the Add/Remove list, but that's all it does, right? It's still in the registry.

Should I reinstall and see if I can uninstall correctly?

If the MS utility did it's job,  you should just need to delete the folders then use a reg cleaner like regseeker to clean up things and you should be go to go.
Paul
------
Custom Built ASUS P8Z77 V-Deluxe, Core i7 3770k, 16 GB Memory-ASUS ENGTX560 DCII TOP/2DI/1GD5 GeForce GTX 560, H80i Cooler, 750W Power Supply, COOLER MASTER HAF XM RC-922XM-KKN1 case,Corsair Force Series GS CSSD-F240GBGS-BK 2.5" 240GB SATA III SSD, InfiniTV4 & HDHomerun Tuners- running Windows 8 (and other goodies)
#2-P877WS- Core i7 3770k, 16GB Memory-GeForce GTX 650Ti, SATA III SSD, H100i cooler, 750W PS,

#5 Resa

Resa

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 26 July 2007 - 07:55 PM

QUOTE (Beerman @ Jul 21 2007, 09:52 AM) <{POST_SNAPBACK}>
If the MS utility did it's job,  you should just need to delete the folders then use a reg cleaner like regseeker to clean up things and you should be go to go.



I'm having the same problem. The problem is that the MS utility did not (or could not ) do it's job. No matter how many times I try to uninstall it, it can't uninstall. I tried deleting the directory and that only made things worse. Windows Installer is now crashing every time that I try to uninstall it.

Also persistant are Roxio Express Labeler and Roxio Update manager. How do i get this crap off of my computer????

#6 Liqvid

Liqvid

    Novice

  • Members
  • PipPipPip
  • 76 posts

Posted 27 July 2007 - 06:49 AM

You can try the clean install instructions, they should apply to any EMC 9 based program/program suite on Windows Vista. Just don't do the last step where it says to install it again.
Clean install instructions

#7 Resa

Resa

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 27 July 2007 - 03:16 PM

QUOTE (Liqvid @ Jul 27 2007, 06:49 AM) <{POST_SNAPBACK}>
You can try the clean install instructions, they should apply to any EMC 9 based program/program suite on Windows Vista. Just don't do the last step where it says to install it again.
Clean install instructions


Ok, I tried that. Much better. I want to install Roxio 9 Premier. When I went to install it, I got the message:

Sonic Activation Module is installed. Roxio install tries to remove it and ...
Windows installer Service crashes.

I hit cancel, restart the Windows Installer Service and hope that everything goes well...it doesn't.

Did a clean uninstall and reinstall again. I had to rename some dlls that I could not delete and reboot. no problems. I finally burned my first cd on my new Pc!

Thank you!

Edited by Resa, 27 July 2007 - 05:30 PM.


#8 tjoho

tjoho

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 06 October 2008 - 02:06 PM

QUOTE (Liqvid @ Jul 27 2007, 04:49 PM) <{POST_SNAPBACK}>
You can try the clean install instructions, they should apply to any EMC 9 based program/program suite on Windows Vista. Just don't do the last step where it says to install it again.
Clean install instructions



I understand this is for Vista. Is there something same for XP? Or dues it just work the same.?
I also have trouble uninstalling Roxio Sonic CREATOR LE from my computer !!

#9 sknis

sknis

    Digital Guru

  • Digital Guru
  • PipPipPipPipPipPip
  • 26,875 posts
  • Gender:Male
  • Location:Hou,Tx

Posted 06 October 2008 - 02:10 PM

QUOTE (tjoho @ Oct 6 2008, 05:06 PM) <{POST_SNAPBACK}>
I understand this is for Vista. Is there something same for XP? Or dues it just work the same.?
I also have trouble uninstalling Roxio Sonic CREATOR LE from my computer !!


If you had looked near the bottom of the linked page, you would have found this.
PC  
Desktop -CPU Solutions (Wisconsin):  Windows 8.1 64 bit, I7 -4790k, 16G memory, MSI GeForce N-760 Video Card, 500G SSD, Creator NXT 2Pro

Laptop - Windows 7 Ultimate 64 bit
Alienware M17XR4.  I-7 third generation @2.4,  8G RAM, 500G SSD, GTX660M, SoundBlaster 3Di,

Apple =OSX 10.5
MacBook Pro; 15.4-inch widescreen display, 2.4GHz Intel Core 2 Duo, 2GB memory, 200GB hard drive, 8x SuperDrive (DVD±R DL/DVD±RW/CD-RW), NVIDIA GeForce 8600M GT with 256MB of GDDR3 memory.  ILife 08, Toast 10, Final Cut Express 4 and Photoshop 4.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users