Jump to content
  • 0
Chappy

Waveform Disappears In Sound Editor

Question

Hi y'all

 

For those here who know me...yes...another weird interface issue, this time in Sound editor.

I'm trying to remove an ugly little "gap" that was left inbetween 2 tracks that should merge seamlessly, that was inserted in the ripping process somehow. I've done this hundreds of times in EMC7's sound editor but now that I run Vista I have EMC10 and find the sound editor to be not as useful as 7's was...at least for me.

Anyway, what happens is that when I load the 2 tracks in EMC10 sound editor, I join the two clips and then highlight the selection I want to edit and click "Zoom to selection". Here is when it gets stupid so I'll have screenshots to help. When the selection is zoomed, part (a big part) of the waveform simply disappears...

First, here's the selected area which shows that a waveform is actually supposed to be there.

 

editor1nr5.jpg

 

As can be seen, there should be full waveform in the "Zoom to selection", but here's what happens...

 

editor2wr9.jpg

 

The waveform is gone from the left side of the selected area, and the really weird thing happens when you pan left....ALL the waveform is missing from the left! It will start to show again after a few full page-backs or if you zoom back out a few times, but as soon as you zoom in again it's gone. Here's what it looks like when it's panned back to the left, and remember the top screenshot which shows there should be full waveform there

 

editor3wp4.jpg

 

 

Does anyone have any explanation for this behavior or any suggestions of what I could try to get this strange behavior to stop?

Thanx

Edited by Chappy

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

I have done what you are trying to do several times and have never seen any of the wave forn disappear. All I do is go to the section I want to cut out and drag the vertical bar to the area I want to start the deletion and then right click on the shaded grayed out area and then click on "delete".

 

I have also done this ame task while in the Videowave program. After adding an audio file to the timeline, right clip and click on EDIT. that takes you to another wave form screen of the audio and you can use the small wheel movements to place the bar at exactlt where you want to begin the deletion and then use the other associated wheel to place the end of where you want to end the deletion. Then delete that potion.

 

Both seem to work for me. I have not tried zooming in on a particular area but that shouildn't matter.

 

Frank...

Share this post


Link to post
Share on other sites
  • 0

Hi Frank

 

Same here. I have literally done this hundreds of times with EMC7 Sound editor and never ever had any problems, in fact I could do seamless edits with ease in that one. I could cut & replace a section so seamlessy that you would never know it was ever edited, but to do it that exacting you have to get zoomed into the 1000th of a second and I can't get there with 10's editor...yet. This behavior happens with any clip, as soon as you zoom in a couple of times the waveform goes bye-bye. I like to edit so that the wave structure is cut/inserted to match the wave it's mating to so the transition is undetectable and I just can't get zoomed in that far without losing ALL of the waveform completely. It will play the music and the timeline moves along the flat wave line, so where the heck did it go...

 

Pisses me off big time, I have no idea what could be causing this. I've uninstalled and reinstalled EMC10 a couple of times and the same thing happens. There is nothing in the installation log that shows any errors during install so it can't be a corrupted install and you can see by my specs in my sig, this isn't a low end machine by any means so it's not a resource issue either. I can't see it being a codec thing either since the clip plays fine...I'm stumped so far.

Share this post


Link to post
Share on other sites
  • 0

After playing around with a particular audio file and doing some "Zooming in", This is what I see. (Reference attachements). Once zoomed in fully, one can edit the file as you like. At first, I was seeing the empty wave form like you suggest. However once I move the horizontal bar along the path I then start seeing the area of the form where I want.

 

Frank...

Share this post


Link to post
Share on other sites
  • 0

Hi Frank

 

Yah, I get full waveform also if I use a single file, I tested that pretty well. It seems that I get the issue after I've joined 2 clips to try and edit out that annoying "burp" that a rip always seems to insert into 2 tracks that should merge one into the other. I also found that on occasion, if I simply click the tracking bar around a few times and then zoom in, it'll work...maybe. But once I've done an edit and want to zoom in again to mabye tweak it a bit, it always seems to disappear then.

This is very odd behavior for sure. I can work as much on a single file as I wish with no odd disappearances but once I do a join & edit, it starts to act up like that. Even reloading doesn't seem to help but what I'll try next is to export the joined clips as a single file and then try opening that in a new project and see what happens.

 

Thanx for trying to duplicate this and help me out here Frank!

 

P.S. - One thing I noticed also...if I do what you do by moving the horizontal bar back and forth some, I can get a waveform back but it seems the timeline gets messed up when this is done, I have to zoom back out full to reset everything and then I'm back to the beginning. It really is annoying bud...I finally just edited it at a zoom I wasn't able to get real precise with and burned a disc for my truck use, but there's an obvious little "burp" still where the tracks should merge seamlessly. That bothers me since I'm used to getting that close to perfection before but now I just can't get in close enough to do that.

Edited by Chappy

Share this post


Link to post
Share on other sites
  • 0

I've opened a Support Ticket on this.

I can reproduce this with almost 100% certainty, so it HAS to be a graphical bug I would say. I've reinstalled EMC10 3 times, once with an absolutely clean removal of any Roxio/Sonic leftovers (which there are a TON of BTW...) from hidden user files and registry changes (all monitored during an install) and this darn issue still happens.

 

Will post any resolutions if found.

Share this post


Link to post
Share on other sites
  • 0
I've opened a Support Ticket on this.

I can reproduce this with almost 100% certainty, so it HAS to be a graphical bug I would say. I've reinstalled EMC10 3 times, once with an absolutely clean removal of any Roxio/Sonic leftovers (which there are a TON of BTW...) from hidden user files and registry changes (all monitored during an install) and this darn issue still happens.

 

Will post any resolutions if found.

Just tossing this out, but have you tried turning down any video acceleration and see if that affects it at all?

Share this post


Link to post
Share on other sites
  • 0

That might be a pretty good test to make Chappy---exporting the two separate files as a single file then doing the editing. That procedure has been suggested many times to others when they are placing several different audio files on the single music track, when making a videowave production. I have done that several times but I usually have to do any editing or fine tuning each file before I join all of them, which has it's problems also.

 

keep us informed of what progress you are making. Other users will certainly benefit from all your testing.

 

Frank...

Share this post


Link to post
Share on other sites
  • 0
Just tossing this out, but have you tried turning down any video acceleration and see if that affects it at all?

Hi Dave

 

I thought of that too, and so did the Roxio tech working on my support ticket, but unfortunately the Nvidia driver I have has the video hardware acceleration settings locked out.

lockoutlo7.jpg

weird...

 

Frank

 

Tried it...no workie...still does it. It's funny, I can load other clips and it won't always do this but with these two clips it's almost 100%...almost like it's the clips themselves that are the cause..(??)

That would definitely be weird if that were the case eh. But it almost seems that way now since I can load and join two other songs randomly and in most cases it works fine, only occasionally does it exhibit this same behaovior, but with these two songs it's 97% always an issue. I'm almost out of ideas for it now and so is the Roxio tech, and since I've already done the needed edit and burned the disk it's not a pressing issue anymore, but I'm definitely still trying to reproduce it with other songs. It almost NEVER happens with a single song loaded and when it does happen in other clips, it's very random and not at all reliably reproduced...I'm stumped...

Share this post


Link to post
Share on other sites
  • 0
Hi Dave

 

I thought of that too, and so did the Roxio tech working on my support ticket, but unfortunately the Nvidia driver I have has the video hardware acceleration settings locked out.

lockoutlo7.jpg

weird...

 

Frank

 

Tried it...no workie...still does it. It's funny, I can load other clips and it won't always do this but with these two clips it's almost 100%...almost like it's the clips themselves that are the cause..(??)

That would definitely be weird if that were the case eh. But it almost seems that way now since I can load and join two other songs randomly and in most cases it works fine, only occasionally does it exhibit this same behaovior, but with these two songs it's 97% always an issue. I'm almost out of ideas for it now and so is the Roxio tech, and since I've already done the needed edit and burned the disk it's not a pressing issue anymore, but I'm definitely still trying to reproduce it with other songs. It almost NEVER happens with a single song loaded and when it does happen in other clips, it's very random and not at all reliably reproduced...I'm stumped...

 

I kept playing around with these two separate audio files (see attached) Chappy and no matter what I did, I kept loosing the graph of the second file, pretty much as you suggested from the beginning. Then for some reason, After I had added the two separate files, I clicked on the "Join Audio files" Icon and then tried editing out the end of the first file and the beginning of the second file so they would join together as smooth as I could get them. That seemed to work great.

 

In all this testing I had never clicked on that "join audio files" icon before. So after I did that it seem to work. Try this and see if you still loose your second file.

 

Frank...

Edited by REDWAGON

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×