Jump to content
  • 0
wussery

All Your Drives Are Set To Disabled

Question

I am getting the "All Your Drives are Set to Disabled. On this Operating System, in order to start Roxio Record Now you must either physically remove your drive(s) or enable at least one drive."

 

I am running XP SP3 and both DVD drives show up under Device Manager without any issues. I am able to read DVD's and CD's from both drives without a problem. I did some research and it was recommended that I try pxengine4_10_28a.exe, but I can't get the exe file to run on my computer. The error that I get is "the installation file needs to be able to read/write to the current directory. Please change the permissions for the directory or move the installer to a location that has the proper read/write permissions".

 

I am able to lauch other exe files from this directory without any issues, so I'm at a lost as to what may be the issue with the pxengine4 file.

 

Please note Record Now was running without any problems, until last week when I got an error on bootup, when the program seemed to be trying to reinstall itself. I was able to remove the program via ADD/REMOVE and have since reinstalled the program three times with the same error message above. Can someone please tell me what might be going on here?

Share this post


Link to post
Share on other sites

25 answers to this question

Recommended Posts

  • 0

Try this and see if it works

 

Go to control panel, system, device manager and delete the entries for the IDE controller on the optical drives. Reboot and let Windows re-detect and re-install

Share this post


Link to post
Share on other sites
  • 0
Try this and see if it works

 

Go to control panel, system, device manager and delete the entries for the IDE controller on the optical drives. Reboot and let Windows re-detect and re-install

 

As a failsafe, if I create a Restore Point before I delete the entries for the IDE controller and then reboot, will XP see my hard drives after the reboot. I don't want to make things worse than they are?

 

Share this post


Link to post
Share on other sites
  • 0

A restore point is nothing to do with this procedure - it's for software and drivers - all you are doing is forcing Windows to do a detect of hardware. Drivers for IDE devices are built in and can't be 'restored' or removed. 'Unininstalling' doesn't take the drivers oput - it just makes Windows reload them

Share this post


Link to post
Share on other sites
  • 0

This one worked for me:

Close the Sonic RecordNow! error message so the application will shut down.

Open Device Manager

Disable your CD/DVD burner

Enable your CD/DVD burner again

Restart Sonic RecordNow!

 

And then it worked.

 

This was after a clean install on Windows XP SP3 with Sonic RecordNow! version 7.22 (Build 720B41P).

Hope it helps you out too, good luck everybody. ;)

Share this post


Link to post
Share on other sites
  • 0

Thank you very much for that. I have been looking for that one.

 

Regards,

Brendon

Share this post


Link to post
Share on other sites
  • 0

I am getting the same error as Wussery did but I am running Windows 7 Ultimate 64 bit. Error is "All Your Drives are Set to Disabled. On this Operating System, in order to start Creator Premier you must either physically remove your drive(s) or enable at least one drive." I have disabled the drive then re-enabled it. I have tried to reinstall Roxio Creator Premier 10. I have uninstalled IE 9 Beta, a good move even without the above problem. I continue to get the same error message. This program worked at one point on this computer and it was purchased with the computer. Any other ideas on how to fix the problem would be appreciated.

Edited by BobW1801

Share this post


Link to post
Share on other sites
  • 0

Try this:

 

Download and run the PX Engine installer from this link. Unzip the file into a folder somewhere on your hard drive and double-click to run it.

-restart Windows, and try your Sonic/Roxio program again.

-please report the result back here.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Okay, working from other solutions which have worked for other people, would you try the next one please:

 

-Open Windows' Device Manager > DVD/CD-ROM drives , right-click on your burner drive and Uninstall it.

-restart Windows and let Windows reinstall that burner drive

-reinstall the PX Engine and then restart Windows again

-check and report back please.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Okay, working from other solutions which have worked for other people, would you try the next one please:

 

-Open Windows' Device Manager > DVD/CD-ROM drives , right-click on your burner drive and Uninstall it.

-restart Windows and let Windows reinstall that burner drive

-reinstall the PX Engine and then restart Windows again

-check and report back please.

 

I've tried everything mentioned in this topic earlier but *sigh* ..

 

Anyway, after following your steps it worked (for me). Thanks a lot!

Edited by honeycomb

Share this post


Link to post
Share on other sites
  • 0

I've tried everything mentioned in this topic earlier but *sigh* ..

 

Anyway, after following your steps it worked (for me). Thanks a lot!

 

hi,

i just tried the same thing but still the same message that the drive is disabled...did you do any other steps beforehand to make it work?

if all else fails, do you know if it is normal that i cannot burn on a DVD even though i have the hardware...meaning with any program...

Thanks,

MichelleC

Share this post


Link to post
Share on other sites
  • 0

hi,

i just tried the same thing but still the same message that the drive is disabled...did you do any other steps beforehand to make it work?

if all else fails, do you know if it is normal that i cannot burn on a DVD even though i have the hardware...meaning with any program...

Thanks,

MichelleC

 

 

Open device manager, expand the DVD/CD-Rom Drives, right click your DVD drive and click uninstall. Close everything out and reboot your PC, the operating system will re-install the drive. Now see if the drive shows in My Computer and other programs including Roxio.

Share this post


Link to post
Share on other sites
  • 0

Try this:

 

Download and run the PX Engine installer from this link. Unzip the file into a folder somewhere on your hard drive and double-click to run it.

-restart Windows, and try your Sonic/Roxio program again.

-please report the result back here.

 

Hi,

 

I am getting the same error as Newbie i have installed windows vista premium and windows XP SP3. I am a beginer in understanding and solving Roxio problems and hence

i have 2 basic questions here.

1) can i download the PX Engine installer and try this step or the PX engine is only for windows 7 ultimate users?

2) "To delete the entries for the IDE controller on the optical drives. Reboot and let Windows re-detect and re-install."

by this step do i need to delete the DVD/CD-ROM drives or the IDE ATA/ATAPI controllers from the device manager?

 

Please advise.

Share this post


Link to post
Share on other sites
  • 0

Hello,

I can't see anyone called Newbie in this thread, but I guess you're finding that the Roxio program doesn't recognize your burner drive?

 

[1] The PX engine is used by all the recent disc-writing Roxio suites under Windows, not just Windows 7.

If the PX Engine version 3_00_58a doesn't work for you try the version 4.18.16a one.

The links for both versions are listed in Cdanteek's signature. Go up to a message from him, and look at #7 in his sig.

 

[2] Honeycomb found the suggestion in post #10 worked.

-Open Windows' Device Manager > DVD/CD-ROM drives , right-click on your burner drive and Uninstall it.

-restart Windows and let Windows reinstall that burner drive

-reinstall the PX Engine and then restart Windows again

-check and report back please.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Hello,

I can't see anyone called Newbie in this thread, but I guess you're finding that the Roxio program doesn't recognize your burner drive?

 

[1] The PX engine is used by all the recent disc-writing Roxio suites under Windows, not just Windows 7.

If the PX Engine version 3_00_58a doesn't work for you try the version 4.18.16a one.

The links for both versions are listed in Cdanteek's signature. Go up to a message from him, and look at #7 in his sig.

 

[2] Honeycomb found the suggestion in post #10 worked.

 

actually i am getting the below error.

"All Your Drives are Set to Disabled. On this Operating System, in order to start Roxio Record Now you must either physically remove your drive(s) or enable at least one drive"

 

Hence as per the earlier discussions one possible step is:

 

Go to control panel, system, device manager and delete the entries for the IDE controller on the optical drives. Reboot and let Windows re-detect and re-install.

 

For this step my question is, do i need to delete the DVD/CD-ROM drives or the IDE ATA/ATAPI controllers from the device manager?

 

Also do i require the original CD to install DVD/CD-ROM if i try the step to uninstall it or will the windows detect the setting automatically?

Edited by Ankitsawla

Share this post


Link to post
Share on other sites
  • 0

actually i am getting the below error.

"All Your Drives are Set to Disabled. On this Operating System, in order to start Roxio Record Now you must either physically remove your drive(s) or enable at least one drive"

 

Hence as per the earlier discussions one possible step is:

 

Go to control panel, system, device manager and delete the entries for the IDE controller on the optical drives. Reboot and let Windows re-detect and re-install.

 

For this step my question is, do i need to delete the DVD/CD-ROM drives or the IDE ATA/ATAPI controllers from the device manager?

 

Also do i require the original CD to install DVD/CD-ROM if i try the step to uninstall it or will the windows detect the setting automatically?

 

Try deleting the optical drives, first. You won't need a CD to install anything. Windows will find your optical drives, once you reboot.

Share this post


Link to post
Share on other sites
  • 0

Try deleting the optical drives, first. You won't need a CD to install anything. Windows will find your optical drives, once you reboot.

 

Hey this solved my problem, Thanks a ton!!

Share this post


Link to post
Share on other sites
  • 0

I had other problems with the install yesterday (error 03F2.80070005) and now this one! Help! :o

(Roxio should include those patches and fixes with their software for the different platforms as these errors are a great diversion to not buy this product :blink: )

 

I use Windows 7 and downloaded the trial for Roxio 9, but get the same message that all my drives are set to disabled.

I followed the various instructions here with uninstalling my Dvd drive, downloading and installing both the px engines...and nothing works, message still pops up, is there anything else I'm missing?

Share this post


Link to post
Share on other sites
  • 0

I had other problems with the install yesterday (error 03F2.80070005) and now this one! Help! :o

(Roxio should include those patches and fixes with their software for the different platforms as these errors are a great diversion to not buy this product :blink: )

 

I use Windows 7 and downloaded the trial for Roxio 9, but get the same message that all my drives are set to disabled.

I followed the various instructions here with uninstalling my Dvd drive, downloading and installing both the px engines...and nothing works, message still pops up, is there anything else I'm missing?

 

You say you downloaded trial for Roxio 9 and use W-7..

 

The Roxio 9 I know of is called Easy Media Creator 9 and it is not W-7 compatible.

 

Would you post a link to the download for this trial for Roxio 9 and we can check?

Share this post


Link to post
Share on other sites
  • 0

Okay, working from other solutions which have worked for other people, would you try the next one please:

 

-Open Windows' Device Manager > DVD/CD-ROM drives , right-click on your burner drive and Uninstall it.

-restart Windows and let Windows reinstall that burner drive

-reinstall the PX Engine and then restart Windows again

-check and report back please.

 

HI Brendon,

 

quite an old post but your solution does still do the job! I applied it and it worked like a charm. Just disabling then re-enabling the optical drive did not work. Many thanks!

 

Here's my context in case those details could help anyone:

- I got Sonic RecordNow! V7.3 in 2005 as part of the software package bundled with a Dell Latitude D510 running Windows XP

- I upgraded to a Dell Latitude D630 that does not include this option :( and I keep on running XP SP3

- As I still own the D510, I did move all my stuff to the D630 using a fantastic software:PC mover Professional

- I had to reactivate Microsoft Office and to register the Sonic license again (likely due to a new hardware footprint coming with the PC change)

- I didn't remember I got this messaqe when I register / run this software for the first time on the new machine, i.e. the D630

- But I got it today (first time) ans Brendon's solution did the trick!

 

Cheers from France

Share this post


Link to post
Share on other sites
  • 0

Cheers from France

 

Thank you for your acknowledgement. I'm very glad it worked for you.

 

Cheers from fractured Christchurch, at the bottom of the world. :)

 

Brendon

Share this post


Link to post
Share on other sites
  • 0

Thank you both - Brendon, PeterPen.

 

It works now!

 

Cheers from Asia)

 

Thank you for your acknowledgement. I'm very glad it worked for you.

 

Cheers from fractured Christchurch, at the bottom of the world. :)

 

Brendon

Share this post


Link to post
Share on other sites
  • 0

mine on windows 7 , same problem. i tried uninstalling cd drive then restarting computer, same problem then tried installing px-engine v3 then restart co0mputer but problem still on ...what to do?

Share this post


Link to post
Share on other sites
  • 0

Which Sonic application are you trying to run in Windows 7, Nurein?

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×