Jump to content

Roxio Community

Easy Program Won't Recognize My Disc Drive


  • Please log in to reply
9 replies to this topic

#1 Ron77

Ron77

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 19 December 2008 - 03:36 PM

unsure.gif I installed Easy CD & DVD Burning software (Red Box) on my Toshiba laptop running Vista but the software won't recognize my DVD burner.  I updated the px engine but that didn't do anything.  Windows recognizes the optical drive and shows the Recorder tab under device properties but the Roxio software can't see it.  Help!

#2 Jim_Hardin

Jim_Hardin

    Digital Guru

  • Digital Guru
  • PipPipPipPipPipPip
  • 35,100 posts
  • Gender:Male

Posted 20 December 2008 - 03:39 AM

Just for giggles make sure you have the latest PX Engine  Here.

Run it and reboot.

Keep in mind, if you would reinstall EMC you would have to run the PX Engine update again.

Posted Image

#3 Ron77

Ron77

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 20 December 2008 - 05:13 AM

QUOTE (Jim_Hardin @ Dec 20 2008, 03:39 AM) <{POST_SNAPBACK}>
Just for giggles make sure you have the latest PX Engine  Here.

Run it and reboot.

Keep in mind, if you would reinstall EMC you would have to run the PX Engine update again.



unsure.gif Okay, so I installed the latest PX engine, rebooted, and it still doesn't recognize my optical drive.  What next?  My optical drive is a Matshita DVD RAM UT850S ATA device.

#4 Jim_Hardin

Jim_Hardin

    Digital Guru

  • Digital Guru
  • PipPipPipPipPipPip
  • 35,100 posts
  • Gender:Male

Posted 20 December 2008 - 07:11 AM

QUOTE (Ron77 @ Dec 20 2008, 08:13 AM) <{POST_SNAPBACK}>
unsure.gif Okay, so I installed the latest PX engine, rebooted, and it still doesn't recognize my optical drive.  What next?  My optical drive is a Matshita DVD RAM UT850S ATA device.

I would go through the Upper/Lower Filters MS routine – MicroSoft


Posted Image

#5 Ron77

Ron77

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 20 December 2008 - 08:47 AM

QUOTE (Jim_Hardin @ Dec 20 2008, 07:11 AM) <{POST_SNAPBACK}>
I would go through the Upper/Lower Filters MS routine – MicroSoft



That filters routine applies to Windows XP.  I'm running Vista.

#6 gi7omy

gi7omy

    Digital Guru

  • Digital Guru
  • PipPipPipPipPipPip
  • 17,033 posts
  • Gender:Male
  • Location:Belfast, Ireland

Posted 20 December 2008 - 09:32 AM

Works there too - MS just didn't update the KB
If it ain't broke, fiddle with it until it breaks, then fiddle with it until you get it fixed

"Rincewind could scream for mercy in nineteen languages and just scream in another forty-four "

"If computers get too powerful, we can organize them into a committee; that will do them in."

“Computers have enabled people to make more mistakes faster than almost any invention in history, with the possible exception of tequila and hand guns.” — Mitch Ratcliffe


Daithi

Home Brew computer
Intel I7 950 on Gigabyte X58A UD3R mobo
12 GB Three Channel DDRAM
Radeon HD4850 512 MB GDR3 graphics
Signalink USB Audio Codec for ham radio connection
1 x 160 GB, 1 x 330 GB, 1 x 400 GB IDE drives
4 x 250 GB SATA 2
LG HL-DT-ST GGW-H20L BD-RE drive
22" Acer P223W monitor


EMC 7.5 on Windows XP 32 SP3
EMC10 on Windows XP64 SP2
Creator 2011 on Windows 7 Ultimate
ECD6 on Gentoo Linux (running under VMWare)

#7 Ron77

Ron77

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 20 December 2008 - 08:06 PM

QUOTE (gi7omy @ Dec 20 2008, 09:32 AM) <{POST_SNAPBACK}>
Works there too - MS just didn't update the KB


I've decided to return your software rather than go through this exercise in futility.  I've reviewed some of the many inquiries on your forums with this problem and if the PX engine update didn't cure the problem, I don't think you have  a clue as to how to fix it.  Thanks.

#8 myguggi

myguggi

    Digital Guru

  • Digital Guru
  • PipPipPipPipPipPip
  • 20,882 posts
  • Gender:Male

Posted 20 December 2008 - 08:26 PM

QUOTE (Ron77 @ Dec 20 2008, 11:06 PM) <{POST_SNAPBACK}>
I've decided to return your software rather than go through this exercise in futility.  I've reviewed some of the many inquiries on your forums with this problem and if the PX engine update didn't cure the problem, I don't think you have  a clue as to how to fix it.  Thanks.


This not Roxio - we are all just users of the software trying to help each other. Insulting people trying to help you is childish. angry.gif

Edited by myguggi, 20 December 2008 - 08:28 PM.


Walt

Dell Dimension 4500S;Windows XP Home Edition  SP3; Intel® Pentium® 4 CPU 2.00GHz, 784MB RAM
(NVIDIA GeForce FX 5200, 128 MB memory disabled because of failure)
Intel® 82845G/GL/GE/PE/GV Graphics Controller; DirectX 9.0c (4.09.0000.0904)
SoundMAX Digital Audio
SamsunG CDR/DVD-ROm SM 332B
HLDS GSA-5120D External LG Super-Multi ReWriter
WDC WD400BB-75DEA0, 40 GB HD; Prolific PL3507 Combo External Hard Drive, 80 GB; Maxtor 6 L200R0 USB Hard Drive, 250GB

HP Pavilion dv6 Notebook; Intel Duo CPU 64 bit, T6400 @ 2.0Ghz; 4.0 GB RAM; Vista Home Premium 64bit
Toshiba MK3252GSX ATA 286GB hard drive; HL-DT-ST DVDRAM GSA-T50L ATA burner
Intel 4Series Express Chipset


#9 Ron77

Ron77

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 21 December 2008 - 05:54 AM

QUOTE (Ron77 @ Dec 20 2008, 08:06 PM) <{POST_SNAPBACK}>
I've decided to return your software rather than go through this exercise in futility.  I've reviewed some of the many inquiries on your forums with this problem and if the PX engine update didn't cure the problem, I don't think you have  a clue as to how to fix it.  Thanks.



rolleyes.gif I apologize, I thought I was dealing with Roxio staff.

#10 kfm

kfm

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 23 December 2008 - 05:14 PM

Just another thought - the app may be having trouble reading the disk (incorrect format) rather than a problem recognizing the drive. I was using dvd-r disks (which the read-me files says is supported), but the app wouldn't recognize the disk (kept telling me that there was no disk in the drive) until i used dvd+r disks. May or may not help...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users