Jump to content
  • 0
ViDav

Comcast Photoshow 4.0 - Frustrations

Question

I am an extremely frustrated user of PhotoShow 4.0 bundled from Comcast. I've spent many hours on the CHAT lines with Comcast and Simple Star. Roxio does not answer their trouble tickets, in my experience, so I can only surmise that they are unable to address the programs problems.

 

My issues:

 

1. I can create a Photo Circle website (via Comcast), but not using my primary email account - only the secondaries. I can, using a secondary account, create any gallery I desire.

2. I CANNOT upload photoshows to PhotoShow Circle under any account. The software connects, I select the PhotoShow, the pictures are generated and then I get a:

 

You've encountered an error. We're sorry you are having server communication issues. We suggest that you restart the applicaton

and try again.

 

For trouble shooting information, please check PhotoShow support: http://support.simplestar.com

 

I've reinstalled several times, cleaned cache until my fingers bled and pleaded with Comcast and Simple Star to help. I've revisited my firewall settings several times and have insured that PhotoShow has the run of my machine.

 

Would appreciate any advice/suggestions.

 

Frustrated Comcast/PhotoShow Deluxe 4.0 wannabe user

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×