Jump to content

Roxio Community

CD Spin Doctor recording truncates upon save


  • Please log in to reply
10 replies to this topic

#1 bearh8r

bearh8r

    Rookie

  • Members
  • PipPip
  • 22 posts

Posted 10 October 2009 - 03:30 PM

I recently updated to Toast 10.0.3 because I had been experiencing many problems with the prior version.  I was pleased with many of the fixes to CD Spin Doctor.  While this updated version seems to be much improved, I still encountered a frustrating problem.

I recorded a double album set (4 sides).  When I successfully completed the recording, all the songs were there after I pressed OK.  I conducted an Auto-Define, and it marked all of the 16 songs.  The next step was to save the file.  I saw the workaround provided by tsantee, so I thought this would do the trick.  When I did click save, I ended up with less than 9 minutes of recorded music, and about 2-1/2 songs.  As you can imagine, after spending over an hour inputting the music from this album, all that work was lost, and I was quite disappointed.

I am running a 3.06GHz iMac (Intel Core 2 Duo), with Snow Leopard 10.6.1, 2GB RAM, and about 500GB free space on my 1TB internal hard drive.

Prior to installing Toast 10.0.3, I went through all the steps recommended by Roxio Support (remove all files related to these applications, repair permissions, secure empty trash, etc.).  The installation went fine, with no error messages.

Any ideas on what I can do to avoid truncated recordings?

Edited by bearh8r, 10 October 2009 - 03:31 PM.


#2 tsantee

tsantee

    Digital Guru

  • Members
  • PipPipPipPipPipPip
  • 13,727 posts
  • Gender:Male
  • Location:Eugene, Oregon

Posted 10 October 2009 - 06:29 PM

Oh my. I wonder what caused that. Choose Save a Copy As instead of choosing Save to see if that works correctly. Another user reported that it helped him regarding a different issue.
I'm just a fellow Toast-user so please don't blame Roxio for any misguidance I may provide. And do let me know if your issue gets solved. Cheers from Eugene, Oregon!

#3 bearh8r

bearh8r

    Rookie

  • Members
  • PipPip
  • 22 posts

Posted 11 October 2009 - 08:47 AM

Thanks for the tip.  I gave that a try (including Auto-Define before saving), but when I did, CDSD saved it, but the file name did not appear in the header of the CDSD screen (giving me the impression that it did not save properly).  I went to the folder where it was supposed to be stored, and there it was!  Just for grins, I saved a copy to the desktop, and it saved both the original and the filtered version (after I applied filters).  Those appeared to save properly, but I still never got the file name to appear in the header until I closed the file and re-opened it.  All this being said, I am not sure that it still is working as it should.  I plan to try another double album, but haven't done so yet for fear of investing all that time for nothing.

The "Recording time left on disk is 24 hrs 44 min," so that should not be an issue.  When I go to save the file, I get a choice of Data Formats: Linear PCM, 8 bit big-endian signed integer, as well as 16 bit, 24 bit, and 32 bit.  The default is 8.  Do I need to change that to another format?

Since I am asking questions, is there anything I can do to get CDSD to export track numbers to iTunes?  Currently, I have to re-type that information into iTunes once all the files have imported.  By the way, it was nice to see that the "double export" issue has been resolved.  When I export tracks to iTunes, I now only get one copy of each track.

#4 tsantee

tsantee

    Digital Guru

  • Members
  • PipPipPipPipPipPip
  • 13,727 posts
  • Gender:Male
  • Location:Eugene, Oregon

Posted 11 October 2009 - 11:49 AM

QUOTE (bearh8r @ Oct 11 2009, 09:47 AM) <{POST_SNAPBACK}>
Thanks for the tip.  I gave that a try (including Auto-Define before saving), but when I did, CDSD saved it, but the file name did not appear in the header of the CDSD screen (giving me the impression that it did not save properly).  I went to the folder where it was supposed to be stored, and there it was!  Just for grins, I saved a copy to the desktop, and it saved both the original and the filtered version (after I applied filters).  Those appeared to save properly, but I still never got the file name to appear in the header until I closed the file and re-opened it.  All this being said, I am not sure that it still is working as it should.  I plan to try another double album, but haven't done so yet for fear of investing all that time for nothing.

The "Recording time left on disk is 24 hrs 44 min," so that should not be an issue.  When I go to save the file, I get a choice of Data Formats: Linear PCM, 8 bit big-endian signed integer, as well as 16 bit, 24 bit, and 32 bit.  The default is 8.  Do I need to change that to another format?

Since I am asking questions, is there anything I can do to get CDSD to export track numbers to iTunes?  Currently, I have to re-type that information into iTunes once all the files have imported.  By the way, it was nice to see that the "double export" issue has been resolved.  When I export tracks to iTunes, I now only get one copy of each track.

When I first choose Save in the latest update the file gets saved and the the Spin Doctor window refreshes with the file name at the top. Unfortunately, there no longer are any tracks marked. (I believe I've already mentioned that choosing Save only works after marking at least one track. After I start working on a file that has its name on top of the window I no longer have any problems. Based on my experience I wouldn't work on a file that doesn't have a saved file name unless I knew I was going to send the tracks to Toast or iTunes before choosing Save (or closing without saving the project file).

Keep the default save setting presuming you used the default setting when recording. Otherwise change the save setting to match the setting you used when recording.

There isn't a way to add track numbers for export. You can enter the track numbers at the start of the track name if you want to force the export to iTunes to keep the alphanumeric order the same and then edit those names in iTunes.
I'm just a fellow Toast-user so please don't blame Roxio for any misguidance I may provide. And do let me know if your issue gets solved. Cheers from Eugene, Oregon!

#5 Paul4Laffs

Paul4Laffs

    Rookie

  • Members
  • PipPip
  • 11 posts

Posted 13 October 2009 - 08:20 AM

I just had a similar problem. I transferred vinyl using CDSD, and when I burned to disc I found I only had half of it. Well, that's Roxio. Always some sort of bug.

#6 bearh8r

bearh8r

    Rookie

  • Members
  • PipPip
  • 22 posts

Posted 17 October 2009 - 05:31 AM

QUOTE (tsantee @ Oct 11 2009, 12:49 PM) <{POST_SNAPBACK}>
When I first choose Save in the latest update the file gets saved and the the Spin Doctor window refreshes with the file name at the top. Unfortunately, there no longer are any tracks marked. (I believe I've already mentioned that choosing Save only works after marking at least one track. After I start working on a file that has its name on top of the window I no longer have any problems. Based on my experience I wouldn't work on a file that doesn't have a saved file name unless I knew I was going to send the tracks to Toast or iTunes before choosing Save (or closing without saving the project file).

Keep the default save setting presuming you used the default setting when recording. Otherwise change the save setting to match the setting you used when recording.

There isn't a way to add track numbers for export. You can enter the track numbers at the start of the track name if you want to force the export to iTunes to keep the alphanumeric order the same and then edit those names in iTunes.


The defaults when I record are sample rate = 44,100 Hz and bits per channel = 16.  Does that mean I need to change the save option to 16 bit?

Thanks for the assistance.

QUOTE (Paul4Laffs @ Oct 13 2009, 09:20 AM) <{POST_SNAPBACK}>
I just had a similar problem. I transferred vinyl using CDSD, and when I burned to disc I found I only had half of it. Well, that's Roxio. Always some sort of bug.


If your problem is like the one I experienced, the full length of the recording shows up right after I hit OK after the capture is complete.  It is when I mark 1 or more tracks, name the file, and save it that I have my problems.  It appears that the file does get saved, but I think it is somehow corrupted.  That is when it gets reduced from 40 minutes to 8 minutes (or something similar).  Once that happens, the "lost" recording is gone forever.  At least it is consistent in that the truncated part of the recording is always the "back half" of the recording.  The first couple of songs is always in tact.

Does anyone have any clues on fixes or workarounds?

#7 tsantee

tsantee

    Digital Guru

  • Members
  • PipPipPipPipPipPip
  • 13,727 posts
  • Gender:Male
  • Location:Eugene, Oregon

Posted 17 October 2009 - 06:46 AM

QUOTE (bearh8r @ Oct 17 2009, 06:31 AM) <{POST_SNAPBACK}>
The defaults when I record are sample rate = 44,100 Hz and bits per channel = 16.  Does that mean I need to change the save option to 16 bit?

Thanks for the assistance.

Yes, but that might not even work. Do not choose Save or choose Save As. Instead choose Save a Copy as... When that is saved go to the File menu and choose Open to open your copied audio file. The window that opens will then have the file name you gave at the top of the window rather than "untitled".

QUOTE
If your problem is like the one I experienced, the full length of the recording shows up right after I hit OK after the capture is complete.  It is when I mark 1 or more tracks, name the file, and save it that I have my problems.  It appears that the file does get saved, but I think it is somehow corrupted.  That is when it gets reduced from 40 minutes to 8 minutes (or something similar).  Once that happens, the "lost" recording is gone forever.  At least it is consistent in that the truncated part of the recording is always the "back half" of the recording.  The first couple of songs is always in tact.

Does anyone have any clues on fixes or workarounds?

This is not a new problem with CDSD. If after choosing Save you don't see the window refresh and the saved name of the file at the top of the window, then the save you did is a corrupted file. This is one of the reasons for my recommendation above.

I'm just a fellow Toast-user so please don't blame Roxio for any misguidance I may provide. And do let me know if your issue gets solved. Cheers from Eugene, Oregon!

#8 bearh8r

bearh8r

    Rookie

  • Members
  • PipPip
  • 22 posts

Posted 17 October 2009 - 03:31 PM

QUOTE (tsantee @ Oct 17 2009, 06:46 AM) <{POST_SNAPBACK}>
Yes, but that might not even work. Do not choose Save or choose Save As. Instead choose Save a Copy as... When that is saved go to the File menu and choose Open to open your copied audio file. The window that opens will then have the file name you gave at the top of the window rather than "untitled".


This is not a new problem with CDSD. If after choosing Save you don't see the window refresh and the saved name of the file at the top of the window, then the save you did is a corrupted file. This is one of the reasons for my recommendation above.


Thanks for the workaround tips.  One last related question.  I noticed that sometimes, CDSD saves a file with an aiff extension, but other times it saves it with a aif extension.  Does that matter?

I lied.  I do have one more question.  With regards to CDSD, what is the difference between "Save As" and "Save A Copy As?"  Isn't every type of save still a save?  I don't think I have any other applications that allow you to "save a copy."

Edited by bearh8r, 17 October 2009 - 03:35 PM.


#9 tsantee

tsantee

    Digital Guru

  • Members
  • PipPipPipPipPipPip
  • 13,727 posts
  • Gender:Male
  • Location:Eugene, Oregon

Posted 18 October 2009 - 06:14 AM

QUOTE (bearh8r @ Oct 17 2009, 04:31 PM) <{POST_SNAPBACK}>
Thanks for the workaround tips.  One last related question.  I noticed that sometimes, CDSD saves a file with an aiff extension, but other times it saves it with a aif extension.  Does that matter?

I lied.  I do have one more question.  With regards to CDSD, what is the difference between "Save As" and "Save A Copy As?"  Isn't every type of save still a save?  I don't think I have any other applications that allow you to "save a copy."

Maybe the developer added Save a Copy As because the others don't work. I'm just joking because I can't explain it. If it was working properly choosing Save or Save As should cause the window to refresh and the saved title to appear, whereas choosing Save a Copy as creates a saved file that is not open in CDSD. It is an extra copy but not the one you're seeing and working on.

I hadn't noticed the saving of the different extensions. They are the same file type but I believe Windows used to only recognize three-character extensions.
I'm just a fellow Toast-user so please don't blame Roxio for any misguidance I may provide. And do let me know if your issue gets solved. Cheers from Eugene, Oregon!

#10 bohalloran

bohalloran

    Digital Master

  • Members
  • PipPipPipPipPip
  • 212 posts

Posted 18 October 2009 - 08:25 AM

QUOTE (tsantee @ Oct 18 2009, 10:14 AM) <{POST_SNAPBACK}>
Maybe the developer added Save a Copy As because the others don't work. I'm just joking because I can't explain it. If it was working properly choosing Save or Save As should cause the window to refresh and the saved title to appear, whereas choosing Save a Copy as creates a saved file that is not open in CDSD. It is an extra copy but not the one you're seeing and working on.

I hadn't noticed the saving of the different extensions. They are the same file type but I believe Windows used to only recognize three-character extensions.


Hmm.

It does seem that the save, save as and save a copy as have different attributes.  The reason/reasons are unknown to me.  I am glad that the save a copy as does work as one would expect.

Here is a difference I have found:

I have Toast installed on my PM G4, PM G5 and my MBP.

If I create one track, do a save as, name the file on either my PM G4 or G5, it will save the file as a CDSD file with the CDSD icon.  Of course the first save as makes the one track disappear and then I must actually create the tracks I want and do whatever editing I need to do.  Then do the save and it works.  But to me that's like opening Word, have to type one sentence, do a save as, name the document, the sentence disappears, then type what I really want and to a save to save the document as its suppose to.  

If I create one track, do a save as, name the file, on my MBP,  it has the standard audio icon and not the CDSD icon.  I don't understand that, but that's what happens. Of course the first save as makes the one track disappear as on the PM's, but the file has the standard audio icon and not the CDSD icon.

Now, if a do a save a copy as on either the PM machines or my MBP, it works as it should.  All icon's are standard audio icons.

So to me there is a bug in the save and save as routines on a PM (PPC) that is not occurring on my MBP.  I do not know why, but it happens each time.  Also, the save a copy as works on both platforms.

So I have gotten to the point that I just do a save a copy as all the time and have given up on messing with the save or save as commands.

For me the issue of save/save as has been in CDSD for a long time.

I am using 10.5.8 on all machines.


#11 bearh8r

bearh8r

    Rookie

  • Members
  • PipPip
  • 22 posts

Posted 07 November 2009 - 02:53 PM

After a little experimenting, I have found that the following workaround works well for me:

1) Record the LP
2) Mark one track
4) File + Save a Copy As...
5) Name file and save it (my system does not show a file name at the top of the CDSD window at this point)
6) Use the Finder to locate the file you just saved
7) Ctrl click the file and select Open With (CD Spin Doctor)
8) It'll ask you if you want to save the original file, but you don't need to
9) The file should open in CDSD, and you should now see the file name at the top of the CDSD window
10) I find that when I do this, it even retains the first track that I marked
11) Everything should function just fine at this point

The only odd thing is that the files carry an .aif extension instead of .aiff.  That doesn't seem to matter.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users