Jump to content

Roxio Community


Disc Copier

  • Please log in to reply
5 replies to this topic

#1 Alan C

Alan C


  • Members
  • Pip
  • 1 posts

Posted 23 March 2011 - 07:34 PM

Hi, I'm Alan Constantine from Philadelphia, Pa. After installing Easy CD & DVD Creator in my CD-RW Drive, why am I getting the following message:
"Disc Copier could not detect any supported recorders. Please ensure your recorder is properly connected. If the problem persists, please re-install Easy CD & DVD Creator". I already tried this, and the problem still persists. How do I go about solving this issue? If anyone out there has a solution for me on how to solve this issue, please feel free to email me a.constantine@verizon.net

#2 Brendon


    Digiital Guru

  • Digital Guru
  • -8,380,055 posts
  • Gender:Male
  • Location:Christchurch, N.Z.

Posted 23 March 2011 - 11:00 PM

Hello Alan,

We normally deal with problems such as this in public on the board rather than by email, since that way everyone gets to see a solution if there's one available.

There are several reasons you might be getting that message
[1] You are trying to copy a DVD and might have a DVD reader, but you only have a CD burner.
[2] Windows can't see your drive. This can be because of a hardware fault or a software fault.
[3] the Roxio program can't see the drive. This is usually because of a software filter problem.

To fix this we need to know which problem you're having.

If it's not [1], please run Windows Device Manager, and click on the 'plus' sign alongside DVD/CD-Rom drives. This should cause the entry to expand and show you something like this for your drives. Only one entry if there's only one drive. [I have two drives, a DW1640 and a GSA-H22N]


If you can see an entry for your burner drive then the Windows end of things is working okay. If there's no entry there for your drive, or if there's a yellow sign with an exclamation '!' associated with it, please come back here and tell us.

If the device Manager entry looks okay, but your Roxio program still can't detect the drive, you might be having trouble with the Roxio PX Engine filter. Best way to fix that is to reinstall Roxio's PX Engine.

-Please go to THIS PAGE and download PX Engine 4.18.16a from the link halfway down the page.
-this should get you a ZIP file called pxengine4_18_16a.zip - please save it somewhere on your hard drive
-UNZIP that file, and dump the contents into your C:\Windows folder. It should be a file called pxengine4_18_16a.exe
-now click the Windows Start button and RUN the following command
pxengine4_18_16a.exe /pxhelponvista and click Enter [you can cut and paste the command from here if it's easier than typing it manually]
-The PX installer box should open. Follow the prompts to install the PX engine, and then restart Windows.

If all has gone well, your Roxio programs should now see your drives. Please come back and tell us how you got on.

Assorted computers in Windows XP, 7, and 10.

[This space unexpectedly left blank]

#3 gevansmd



  • Members
  • Pip
  • 3 posts

Posted 14 January 2012 - 08:09 PM

Ran the px engine program and it still won't see my burner. Windows can however. This was a brand new install, should have worked first time but after 4 times it's still not working. The first time I reboot after the install it says contentmerge10.exe can't find cpscommontools.dll even though the file is in the correct location on my c: drive and in the registry. Pathetic that I have to jump through hoops for 3 hours and still it won't run.

Running Vista Ultimate 64 bit sp2.

#4 gevansmd



  • Members
  • Pip
  • 3 posts

Posted 14 January 2012 - 08:12 PM

I forgot to mention I'm using the red box version of easy cd & dvd burning, purchased today from Best Buy.

#5 Jim_Hardin


    Digital Guru

  • Digital Guru
  • PipPipPipPipPipPip
  • 40,514 posts
  • Gender:Male

Posted 15 January 2012 - 03:33 AM

Re-read post #2...

Brendon posted your solution in that one ;)

'Re-installing 4 times' is changing NOTHING! You have to follow his instructions.

#6 gevansmd



  • Members
  • Pip
  • 3 posts

Posted 15 January 2012 - 07:14 AM

I did follow post 2. As I stated, Windows sees the burner so I went to step 3 and reinstalled the px engine program. That did not fix the problem.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users