Jump to content

Roxio Community

My own personal rant with no information


  • Please log in to reply
3 replies to this topic

#1 twiceupset

twiceupset

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 17 October 2011 - 06:03 AM

I too have had nothing but trouble with Creator 2011. I even purchased a new computer thinking it was my 18 month old computer.  I have tried everthing suggested and still can not use this program.  It is totally wrong for a company to sell you a program that does not work.  I purchased it from Best Buy and they just say there is nothing they can do unless I want to pay them $$$$$ to have their people install it on my computer.  I'm upset and have been going around in circles for over five months with this issue.

#2 gi7omy

gi7omy

    Digital Guru

  • Digital Guru
  • PipPipPipPipPipPip
  • 17,033 posts
  • Gender:Male
  • Location:Belfast, Ireland

Posted 17 October 2011 - 06:51 AM

Please don't just jump into a thread - unless you are receiving exactly the same error on the same operating system and have the same hardware, you can't have the same problem

Start a new thread, say what error messages you are getting and let us know what operating system, whjich program in the suite and also details on CPU, RAM and graphics - your post had no information past 'my car won't start'
If it ain't broke, fiddle with it until it breaks, then fiddle with it until you get it fixed

"Rincewind could scream for mercy in nineteen languages and just scream in another forty-four "

"If computers get too powerful, we can organize them into a committee; that will do them in."

“Computers have enabled people to make more mistakes faster than almost any invention in history, with the possible exception of tequila and hand guns.” — Mitch Ratcliffe


Daithi

Home Brew computer
Intel I7 950 on Gigabyte X58A UD3R mobo
12 GB Three Channel DDRAM
Radeon HD4850 512 MB GDR3 graphics
Signalink USB Audio Codec for ham radio connection
1 x 160 GB, 1 x 330 GB, 1 x 400 GB IDE drives
4 x 250 GB SATA 2
LG HL-DT-ST GGW-H20L BD-RE drive
22" Acer P223W monitor


EMC 7.5 on Windows XP 32 SP3
EMC10 on Windows XP64 SP2
Creator 2011 on Windows 7 Ultimate
ECD6 on Gentoo Linux (running under VMWare)

#3 Blu-Rey

Blu-Rey

    Rookie

  • Members
  • PipPip
  • 46 posts

Posted 24 December 2011 - 06:54 AM

I must admit the OP has a point.  I started with Creator 2009 and it was VERRRRRY error-prone as is 2011.  It is buggy software and causes VERY frustrating issues.  I am very thankful that there are those helping on this message board!  Wish it were the actual Roxio team figuring out the answers instead of us however.    We are all in the same boat, best we can do is explain our problems in detail and hopefully someone smarter will figure it out.  So, to that, thank you all and have a great 2012!

Edited by Blu-Rey, 24 December 2011 - 07:15 AM.


#4 sknis

sknis

    Digital Guru

  • Digital Guru
  • PipPipPipPipPipPip
  • 26,702 posts
  • Gender:Male
  • Location:Hou,Tx

Posted 24 December 2011 - 07:15 AM

View PostBlu-Rey, on 24 December 2011 - 06:54 AM, said:

I must admit the OP has a point.  I started with Creator 2009 and it was VERRRRRY error-prone as is 2011.  It is buggy software and causes VERY frustrating issues.  Glad there are those helping on this message board however.  Wish it were the actual Roxio team figuring out the answers instead of us however.    We are all in the same boat, best we can do is explain our problems in detail and hopefully someone smarter will figure it out.  So, to that, thank you all and have a great 2012!

For the last several versions, there has been a Roxio design engineer -Sonic Boom - reading posts and helping people install the program.  He spends several months doing that.  He is currently active in Creator 2012 Installation part of the forum -- take a look.

He of course can't spend ALL his time answering posts so he focuses on the latest version.

Did you ever create a thread in the Creator 2011 forum while he was spending his time there?   Did you look at the pinned posts at the top of the Installation thread?
PC  
Desktop -CPU Solutions (Wisconsin):  Windows 8.1 64 bit, I7 -4790k, 16G memory, MSI GeForce N-760 Video Card, 500G SSD, Creator NXT 2Pro

Laptop - Windows 7 Ultimate 64 bit
Alienware M17XR4.  I-7 third generation @2.4,  8G RAM, 500G SSD, GTX660M, SoundBlaster 3Di,

Apple =OSX 10.5
MacBook Pro; 15.4-inch widescreen display, 2.4GHz Intel Core 2 Duo, 2GB memory, 200GB hard drive, 8x SuperDrive (DVD±R DL/DVD±RW/CD-RW), NVIDIA GeForce 8600M GT with 256MB of GDDR3 memory.  ILife 08, Toast 10, Final Cut Express 4 and Photoshop 4.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users