Jump to content
  • 0
lleyt

Roxio Game Capture Hd Pro Wont Work Please Help

Question

hey i just brought a roxio game capture hd pro and i pluged it all in with hdmi on my xbox 360 elite and installed everything fine and i pluged the usb into my laptop and the gamecapture lights up but the hdmi light dosnt. the recording software shows nothing and under satus its a green no signal and on my tv no signal i have tryed to restart my laptop and also reinstalled the software but still nothing the roxio aslo isnt show in the devices or sound, video and game controllers.post-113229-0-38485700-1371425485_thumb.pngpost-113229-0-83337100-1371425499_thumb.pngpost-113229-0-16620900-1371425506_thumb.png please help

Edited by lleyt

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

As a general rule NEVER plug in a USB Device until you have installed the software ;)

 

This is the process you need to do to correct it:

 

First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

 

Unplug your RGC Device and put it aside until you are completely finished.

 

Now insert your Roxio Disc.

 

Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)

 

When you reach the screen where
Repair
is offered, choose that!

 

When the Repair competes, turn your AV & Firewall back on and reboot.

Share this post


Link to post
Share on other sites
  • 0

Yes! ~ if successful the Green 'No Signal' will turn to Red and be replaced with a Green "Ready' when it gets a valid signal ;)

 

Should it not work, do again! It has taken up to 3 attempts to get it to work :wacko:

 

(Edited to correct my Red's and Green's)

Edited by Jim_Hardin

Share this post


Link to post
Share on other sites
  • 0

hey i have done it three times and i think its because the drivers of the RGC are not installing onto my laptop and also its a green no signal.. is there like a away for me to install them maunlay?

Share this post


Link to post
Share on other sites
  • 0

I got my Red's & Green's mixed up :wacko: (edited that post now so it reads correctly)

 

If they are not installing, I have no idea why. You will have to contact Roxio for this.

Share this post


Link to post
Share on other sites
  • 0

Hey thanks for trying to help but is there anything that can stop the RGC from installing the drivers?

Share this post


Link to post
Share on other sites
  • 0

Great ~ you have the "Incompatible Suite" error and the usual Repair will never fix that!!!

 

This is extensive, but it what I suggest... And I suggest you Print it and check off items as you go ;)

 

Unplug your RGC Device and put it aside until you are completely finished.

 

Download and install the
Uninstaller. Then run it in
Moderate Mode
to remove any traces of Roxio.

 

Create a New User Account with Administrator Privileges.

 

Turn OFF any A/V & Firewall.

 

Reboot and log on to that new account.

 

Copy your entire disc to a new folder on your HDD.

 

In that new folder, right click on Setup.exe and select Properties.

 

Under the Compatibility tab, make sure
nothing
is checked!

 

Right click Setup.exe and select Open.

 

Allow it to Check for Updates (this is for Roxio not Windows)

 

Use the Default Locations!

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×