Jump to content
  • 0
Stucker

Burning Blu Rays With Dolby 5.1 Surround Sound Tracks

Question

Running Toast 10.2 (the last version that will run on my PowerBook G4 laptop w/Leopard 10.5.8)

and I am starting shooting multitrack performances with Surround Sound micing to achieve Dolby Digital 5.1 tracks for my Blu Rays.

Is ANYONE doing this successfully? Have managed to export from Final Cut Pro 6.0.6, using Compressor 2.2, and have gotten the 5.1 tracks to burn (without video) successfully to Blu Rays, but not able to get the video track to come together with the ac3 tracks in the Toast window - i.e. getting the Toast to ask 'is this the audio for this video?"

Any notes or suggestions folks?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

When you add the .m2v video track Toast will automatically add the .ac3 audio if it is in the same folder and has the same file name except for the extension. Otherwise Toast should ask you to locate the audio. Do not drag the .ac3 file into Toast.

Share this post


Link to post
Share on other sites
  • 0

Noted. Will try this. Now do you have any Compressor Export notes for the m2v file. The orginal format was Sony HDV 1080i, which

I believe is m2v (2 ch stereo only), so if I export with compressor video only, m2v (elementary stream? program stream?) and then

the audio separate as Dolby Digital Pro 5.1, then name the files the same except for the extension and put them in the same folder,

and drag in the video m2v file, it should work?

Thanks for responding so quickly.

Share this post


Link to post
Share on other sites
  • 0

I don't have Compressor but my understanding is it creates mpeg 2 and ac3 elementary streams. After you add the video stream to Toast it will ask you to locate the audio if it doesn't find it automatically. You also should go to the custom encoder settings window and select Never re-encode. Since this is a Blu-ray project I also suggest selecting MPEG 2 instead of MPEG 4 as the encoder just to make sure Toast knows to only multiplex rather than encode the project. When you click the burn button or choose Save as Disc Image the progress window should say Multiplexing and not Encoding. Even if it said encoding Toast does not decode and re-encode ac3 audio streams. It leaves them as they are.

 

If you are uncertain of what settings you want in Compressor I suggest creating a 1-minute sample video and then use Toast to save as disc image. When that is finished you can mount the .toast file using Mount Image File from the Toast Utilities menu or some other ways such as control-clicking on it in the Finder and choosing Mount It from the Contextual menu. Once the Blu-ray disc image is mounted you can preview the video using Roxio Video Player in the Toast Extras menu.

Share this post


Link to post
Share on other sites
  • 0

Thank you, thank you. IT WORKS! I had edited a test video with a surround sound live performance recording,

and each of the 5.1 mics and LFE tracks worked as laid out - PERFECT. And on my old Mac G4 with Power PC chip,

Final Cut Pro 6.0.6, Compressor 2.0.2 and Toast 10.2 and my LaCie d2 Blu Ray burner. Yes, Virginia...

And my Surround Sound system was a Bose with a Harmon Kardon AVR 700 Amp, even tho my M-Audio

ProFire 2626 audio interface could have fed a set of Genelec speakers, too.

Will now experiment with higher quality m2v video streams.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

A MESSAGE TO DIGITAL GURU: I'm using TOAST 11 & 12. Both have the additional BLU RAY PLUGIN. I have looked everywhere....in the menus, sub menus, extensively and did not see the "NEVER RE-ENCODE" option anywhere. Weird. Maybe only on earlier versions as an option. I get the concept. Avoiding any reprocessing of a DOLBY 5.1 AC-3 file would be great. But when I pop the disc in any player, it only shows the DOLBY 2.0 192kHz file as the only stream attached to the video! Sorry, but if there is another way, please advise, if you don't mind. My 5.1 AC3 has been verified by the DOLBY DECODER tool. Check. THE VIDEO OUTPUT IS AN H.264 m4v file, sans audio, directly from Premiere CC, using the "Blu ray" option on the format selection. Check. So all my elements have been verified. I could go as far as using Telestream Episode 6 to do my encoding, but I'm thinking there should be no need for that. But it still encodes the audio as a 2.0 AC3. It's driving me nuts. I just don't think jumping through those additional hoops is going to fix it. I think the problem is somewhere upstream.....my content is 1.5 hours and I just don't wanna keep waiting for the burn.

 

I have a good friend with Toast 12 (w BD plugin) anD HE HAS DONE IT JUST FINE. Do I need a reinstall here? I'm lost here and dumbfounded at this point. Do I use something else to encode the video with? I use the new, full DOLBY SUITE TO TO MY AUDIO ENCODING BIDDING HERE.

Share this post


Link to post
Share on other sites
  • 0

To access the Never Re-encode option click Customize... on the right of the Video window. In the window that appears select Encoding and then Custom. However, Toast will do encoding in any case unless the source video is MPEG 2 and compliant with the Blu-ray specs. All MPEG 4 videos get re-encoded by Toast even when you select MPEG-4 AVC as the Video Format.

 

Since Toast will not decode a 5.1 AC-3 audio stream when it is encoding the video, I expect that it will retain it as the audio rather than create a new 2.0 audio track. You could either add your MPEG 4 video that only has 5.1 AC-3 audio or add the video with no audio at all. In the latter case Toast should alert you that the video is lacking audio and ask you to locate the audio stream which you then match separately.

 

A long way around is to have your video encoded to MPEG 2 as an M2V without audio. Add that to Toast and it will direct you to adding the matching audio.

 

I haven't ever seen Toast re-encode and AC-3 audio file into another AC-3 file.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×