Jump to content
  • 0
louij2

No Signal From Roxio Game Capture

Question

24 answers to this question

Recommended Posts

  • 0

The game capture wont work even if I've tried multiple cables and computers and even consoles it just wont work!

 

Did you ever get your problems, from your other post, solved? You didn't have the decency to come back and let folks know if the suggestion given, helped you.

 

http://forums.support.roxio.com/topic/86819-my-roxio-has-stopped-working/

Share this post


Link to post
Share on other sites
  • 0

Sorry for not replying on that post as I figured it out my self as that was on a virtual machine and that does not work too well on my new PC it wont pick it up at all i believe

Share this post


Link to post
Share on other sites
  • 0

Just checked it realised it fell of the cabinet and the cables came out slightly sorry for any inconvenience caused by my not clear questions/queries

Share this post


Link to post
Share on other sites
  • 0

It didn't fall at all only the cables came out it's hard to explain

In post #4 you said it fell off the cabinet :blink:

Share this post


Link to post
Share on other sites
  • 0

So lets move on.........how do you have everything hooked up ? start from your source (xbox/ps3....) > Component cable to the Game capture card .......

 

post-68-0-12827300-1389910307_thumb.png

 

Assuming you are hooked up correctly, do you see this in you Device Manager

 

post-68-0-96754700-1389910617_thumb.png

Share this post


Link to post
Share on other sites
  • 0

Contact Roxio Support.

 

Looks like that little incident with the books and falling has damaged the unit.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

Thanks for the help guys also when i bought it it came missing one rubber foot new from pc world

 

PC World sells rubber feet? :lol:

Share this post


Link to post
Share on other sites
  • 0

I got the roxio from pc world it was new and it was missing on rubber foot

 

1 - Your getting a shock when you plug in the USB unit.

 

2 - its missing a rubber foot.

 

3 - It would appear it fell of the cabinet (or not).

 

4 - You have had the unit for almost a year.

 

Were just fellow users on here just like you...... what would you like us to do.

Share this post


Link to post
Share on other sites
  • 0

Is Point 1 Normal as I bought it new from PC World UK also what should of I have done about Point 2?

 

Of course Point 1 is not normal :wacko: If you get a shock when you plug the device in then the device is broken/fried (and your computer may be fried soon if you keep plugging it in).

Share this post


Link to post
Share on other sites
  • 0

Purchase a new unit.

Edited by ogdens

Share this post


Link to post
Share on other sites
  • 0

Yeah for the price and these problems and ^#!& quality might as well pay a little extra and get an elgato

 

Your problem, with the Roxio unit is, YOU BROKE IT! Good luck with your new Elgato.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×