Jump to content
  • 0
MiniMartinx98

Roxio Game Capture Hd Pro. Help Please!

Question

Hi, I bought the Roxio Game Capture HD Pro a few months ago and have recently started using it. Yesterday it was working fine and since then I have changed no settings on tv or game capture, or unplugged anything. But when i turned it on today my TV displays nothing, the software says "no signal" in red and I get no audio. I use HDMI cables. I have tried uninstalling and then reinstalling, restarting my computer, unplugging the RGC and then plugging it back in. When I open the software it is just a black screen with 2 blue squares at the side. In my device manager when I open sound, video and game controllers, "Roxio Game CAP HD Pro" is there.

Please help, I've been trying to fix this for hours because i'm desperate to start recording!

Also, I'm don't know that much about computers so please keep the help simple and easy to understand! haha, thanks! post-118458-0-81683700-1400791743_thumb.jpg

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

The RED No Signal indicates that the RGC Device is not receiving a valid signal... Since it does not have a valid signal, nothing is going to reach your TV either ;)

 

Something has changed from your Gamebox to the RGC Device. You need to make sure whatever Gamebox your using, PSx or Xbox, that the output is set to a specific value and not set to auto sense.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0

The RED No Signal indicates that the RGC Device is not receiving a valid signal... Since it does not have a valid signal, nothing is going to reach your TV either ;)

 

Something has changed from your Gamebox to the RGC Device. You need to make sure whatever Gamebox your using, PSx or Xbox, that the output is set to a specific value and not set to auto sense.

Jim you brilliant man! Thank you so much! Yay!

Share this post


Link to post
Share on other sites
  • 0

i am still having probloms like this with my roxio. if i can please have descriptive instructions that would be great :)

did not work :(

 

You have butted into a Topic that is 8 mnths old...

 

You "claim" to have the same problem...

 

Now LOOK at the picture in the first post. Is that exactly what you see?

 

Are you hooked up to an Xbox?

 

How do you know that you even have the same version of software? (it has changed since this Topic started :wacko: )

Share this post


Link to post
Share on other sites
  • 0

Same Problem??? Then Same Answer!

 

Read and comply with all posts in the Topic ;)

 

If it is the same as you insist, the solution will work...

Share this post


Link to post
Share on other sites
  • 0

i have bought a roxio hd pro and it has not been working...i tried a different computer, changing settings on my xbox nothing worked. everything is hooked up correctly. here is what i see when i open my roxio:post-118458-0-81683700-1400791743.jpg

Share this post


Link to post
Share on other sites
  • 0

There isn't any 'fix'...

 

Read and try those things more carefully.

 

Since you changed computers, perhaps your problem really isn't the "same"???

 

Maybe you better start a new topic and list all the details you have not provided.

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×