Jump to content
  • 0
MagikzPro

Roxio Usb Device Not Recognised!

Question

I have had my Roxio for over a year now and I stopped using it about 3-4 months ago and I have now gone back to using it but everytime I try to plug it in it comes up with 'USB Device Not Recognised'. Ive never had this problem before and Ive been trying for 2 days now to get it to work, I have pretty much tried everything, ive tried on both my PC and my laptop and I still get the same problem, is my Roxio just completely broke or is there just something wrong with my drivers/usb lead or what? please help!!:'(

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Open device manager and expand 'sound video and game controllers' and 'other devices' if you have that entry.

 

Now plug in the Roxio USB Game Capture Device and watch what drivers show where.

 

Post that info or post a screen shot of the drivers that show when the RGC Device is plugged in.

Share this post


Link to post
Share on other sites
  • 0

Nothing came up under 'Sound, Videos and Game Controllers' but I did get 'Unknown Device' under 'Universal Serial Bus Controllers' it also has a '!' next to the symbol..

Share this post


Link to post
Share on other sites
  • 0

Nothing came up under 'Sound, Videos and Game Controllers' but I did get 'Unknown Device' under 'Universal Serial Bus Controllers' it also has a '!' next to the symbol..

 

With the RGC Device plugged in open device manager and right click on the 'Unknown Device' under 'Universal Serial Bus Controllers' and click uninstall.

 

Now when that is done unplug the RGC Device and reboot the PC/ When the PC is booted up shut down all software including antivirus/firewall software, place your Roxio Game Capture Software Disc in a drive and run it when repair is offered run it when done reboot the PC.

 

Now open device manager and watch when you plugin your RGC Device, what shows now for drivers and where?

Share this post


Link to post
Share on other sites
  • 0

It's still all the same.. Nothing has changed

 

If you followed my directions it will work!

 

You have to do exactly as I said unplug the device and not plug it back in until the very last step.

Share this post


Link to post
Share on other sites
  • 0

Yeah I have, I've tried like everything, I think it might just be completely broke, it use to work but then it just stopped when I started to use it again, I didn't even uninstall anything it was all plugged into my pc for ages and now it just don't work at all.. I might just upgrade to the HD version anyway

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×