Jump to content

tinacap

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tinacap

  • Rank
    Newbie
  1. tinacap

    Os 10.8.5

    I was about to purchase this product, but first want to know if my iMac 2009 that is running 10.8.5 can run this product when the requirements are an older OS10.6. If so, I am confused by this as to why this isn't listed as the operating system requirement in the info on this website?
×