Jump to content

Magikthise

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Magikthise

  • Rank
    Newbie
  1. Magikthise

    Not At All Impressed W/emc 10

    What the heck happened to this software?! The greatest things about EMC 7 were ease of use and being full-featured, in that a person could literally jump right into the program, start editing video and end up with a pretty reasonable production (I created 16 separate video productions with EMC 7 without any major problems). The only reason why I upgraded to EMC 10 is because I trusted the earlier product's reputation. But with EMC 10 things seem to be a lot more complicated: Slllloooooowwwww performance - 30+ seconds to open or close a component?! 20+ seconds for any production changes to occur?! Choppy video and sound using VideoWave (and no matter what I've tried, I haven't been able to fix it). Adding text (what are 'Internal Tracks'? - with EMC 7 you simply dragged the 'Text' icon over to the particular frame, added and edited the text and clicked 'Done'). What happened to DVDBuilder?! It was so easy to use it was almost idiot-proof! You guys just couldn't leave well enough alone!http://forums.support.roxio.com/style_emoticons/default/angry.gif If I thought I could get a refund on EMC 10 I think I would, and go back to using EMC 7. For the record, I'm not a complainer. Tthis is the absolutely first time I've been so dissatisfied with a software product that I've actually sounded off on a forum. Please, make me a believer again! My custom-built (meaning not a brand name package) computer: Intel m/b with 82801BA/82802/82845 chipsets Intel 1.6gb processor 512mb RAM ATI Radeon 7000 series video card Soundblaster Live! soundcard Three physical HD's - 80gb/200gb/300gb ALL drivers have been updated to the latest available, and yes, I've shut off all background programs. Remember, EMC 7 ran almost flawlessly for the nine years I used it!!
×