Jump to content

Search the Community

Showing results for tags 'does no work'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Roxio General
    • News and Announcements
    • General Chat
  • Easy Media Creator Products
    • Creator NXT 7
    • Creator NXT 6
    • Creator NXT 5
    • Creator NXT 4
    • BackOnTrack
    • Legacy Creator Products
  • Gaming / Capture Products
    • Easy VHS to DVD 3 Plus
    • Roxio Game Capture HD PRO
    • RecordNow Music Lab and Music Lab Premiere
    • Legacy Products
  • Macintosh Applications
    • Toast 17
    • Toast 16
    • Toast 15
    • Toast DVD
    • Easy VHS to DVD for Mac
    • Legacy Mac Products
  • Roxio PhotoShow
    • Roxio PhotoShow
    • Roxio MediaBook
    • PhotoShow Legacy Products

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 1 result

  1. Hi, I recently bought my Roxio Game Capture HD pro, it was delivered to me around Nov 2012. I used it on and off since then, but since yesterday Jan 18th. It has stopped working completely. My usb cable is plugged into my laptop providing the Roxio Game Capture HD pro power the -> lights up which is why I know it is getting power. The led lights indicating hdmi or YPbPr do not light up. I had the Roxio Game Capture HD pro installed on my laptop and whenever I used it would plug it into any usb port. All of a sudden after a reboot of the laptop its not working, I uninstalled the program, reinstalled it, repaired it but still i get No input and No signal. The Roxio Game Capture HD pro is NOT showing up in my device manager like I have seen in a few posts around here. I figured something was wrong with my laptop and it was not recognizing it so I connected it to my desktop (which did not have the device installed before) I installed the software, did the restart, plugged in the device. The ( -->) lights up but the other led indicating input do not light up. So it is not working on my second computer either. Hoping someone can help me out here or show me how to get a possible replacement as it seems that my Roxio Game Capture HD pro has become defective (not working on 2 computers) Also I did the upgrade for the software.
×