Jump to content
  • 0

Roxiocentralfx.exe Displays Only Title Bar, Window Frame, And Ad



Last night I went to launch Roxio Creator 2011 Pro to rip music off of some new CDs and encountered a problem.


I double-clicked on the desktop icon and received an empty window frame except for the title bar at the top of the window and an ad for NXT. I tried moving the mouse over the empty window (completely transparent - you see the desktop through it) but that had no effect, other than at times displaying the "hand" pointer indicating there was something clickable under the pointer. I've attached a copy of the "Roxio Creator 2011 Pro" window displayed (see below). As you can see, the desktop image is visible through the majority of the "Creator" window.


I closed the window, went to the START menu, found "Roxio Creator 2011 Pro" and clicked on it. Same result. I found that clicking on the left end of the title bar let me select placing the window on the various monitors. I tried that option and it moved the windows, but the window still did not populate.


I closed the window and ran a complete virus scan. Nothing found. I went to a system restore point from over a week ago, a point PRIOR to the last time I know that "Creator" worked properly. When the restore was complete I tried "Creator" again with no change in the result.


I uninstalled the video drivers, rebooted, installed the latest video drivers, rebooted, then tried "Creator" again. No change.


I uninstalled "Creator", then rebooted, then uninstalled JAVA, rebooted, then uninstalled FLASH, then rebooted, then uninstalled the video drivers again, rebooted, then installed the video drivers, rebooted, installed "Creator", rebooted, then tried "Creator". Still no luck.


It appears that the individual programs will run and that the problem is limited to the RoxioCentralFx.exe program.


Any suggestions?




Windows 7 Ultimate


9 TB Disc

Asus ATI HD6870 video

Dual Samsung 27" monitors


Link to comment
Share on other sites

12 answers to this question

Recommended Posts

I remember having some trouble like this years ago after I updated video drivers ATI at the time. Reverting to older ones fixed my problem.


Did you update your video drivers since it worked correctly?


This has caused visual problems with Roxio programs too. Caused by corrupted MSXML 4.0 files. Download and install the latest XML 4.0 update from Microsoft from the link below to resolve the issue.



Link to comment
Share on other sites

Nice Work John!!! -_-


Most kids today do not realize that troubleshooting requires WORK and PERSISTENCE and is not simply Click & Smile :lol:

(to be fair, we were just as naive at that age -_-)


Hi Everyone,


I'm now heading off to the local computer store to buy another drive. I'm going to clone the "C:" drive again and start rotating through two clones instead of having just the one clone. BTW, I use Acronis to perform the cloning operation. I've used various versions for years, and have been very happy with it. I used to use software that came with a new drive to make clones, but at work they used Acronis, so I switched to it for home use.




This is what I have been doing for many years with Acronis. I have had too many Fails during the cloning process in which the Source HDD failed to read and the Target HDD became unreadable :huh:

(at the moment, one of my clones is unreadable and there is a file I want from it :wacko:)


While unlikely, it was too much risk for all the time being spent, so I went to having 2 rotating clone HDD's for each PC I backup ;)


I have been using their (acronis) Backup Image on one PC for the last 6 months, rather than a clone... It is faster than cloning but I do need to spread the Images to more HDD's rather than keeping my eggs in the same basket! :D


Again, thanks for the update.

Link to comment
Share on other sites

Hi Everyone,


About the 9T of drive space, I have a 1T C: drive and four 2T additional drives. I make my backups to some 2T drives that I can hot-swap through a SATA dock on the top of my case, a Thermaltake Chaser MK-I tower. I used to back up to DVDs, but found that no matter what the brand of media or brand of burner, discs written at 8X or faster were unreadable with time, and writing at 4X just took way too long. I used to backup to Blu-ray, but as hard drives came down in price, backing up to disc became the more reliable, faster, and cheaper process, and no more being linked to the computer to swap media for hours.


Thanks for the link to the latest XML 4.0 download. I'm going to install it tonight (more on that later).


I tried playing with the monitors - swapped them around, swapped in another monitor, enabled the on MB video and connected up a 32" TV to it, but no improvement.


However, I now have it working!


As I'm always frustrated by posts where there are no details on what the person did to fix the problem, I'm going to describe what I did.


Powering down and wiggling cables and wiggling the video card accomplished nothing.


I replaced the "C:" drive with a clone I had made back in May (I routinely "clone" the "C:" drive in case it fails or becomes corrupt - something I learned while working at AOL a decade ago). Unfortunately, the problem presisted with the clone, so I put the original "C:" drive back in.


I borrowed a diagnostic disc from a friend and ran it. The disc is a proprietary disc his company created and runs several utilities under control of a script. I had to enable the onboard video and connect a monitor to it as it by default didn't output to the video card. The diagnostics take about 90 minutes to run, but I didn't know that, so I spent a lot of time waiting for them to finish.


The diagnostics were showing a video problem with a screen full of "FAILED!" messages. Driver problems, Direct-X problems, a real mess.


I completely uninstalled the drivers and Catalyst software for the 3rd time. I rebooted twice, just to make sure there was a clean boot. Still no luck. Ran the diagnostic disc again. Same problems.


I powered down the system and physically removed the video card from the MB, then re-inserted it, reconnected the power, etc.


I ran the diagnostic disc again (waited another 90 minutes while it ran). Many fewer problems!


I completely uninstalled the video driver and Catalyst software for the 4th time.


This time an odd thing happened. Windows 7 Ultimate decided that it wasn't happy with there being no driver for the HD6870, so it installed a very, very, very old version of the driver. It did not install the Catalyst software, so while a very old driver was installed, there were no utilities and the old driver decided to "scale" the monitor output so that there was about a half inch black margin around the content.


I installed the latest drivers and Catalyst again, disabled the scaling (so that the video output would fill the monitor). All appeared well.


Rebooted twice. Looks good!


I ran the diagnostic disc, and it came up clean! Everything passed!


I crossed my fingers and ran Roxio. Success! The menu utility was running properly!


I ran all sorts of software - video editing, photo editing, video capture, Blu-ray player, DishAnywhere, etc., and everything ran correctly!


So, I'm chalking this up to a bad connection between the video card and the MB, which shouldn't happen with gold contacts, but apparently did. And dust isn't a factor as the inside of the case (a Thermaltake Chaser MK-I with lots of filters, the cleanest case I've ever had).


I'm now heading off to the local computer store to buy another drive. I'm going to clone the "C:" drive again and start rotating through two clones instead of having just the one clone. BTW, I use Acronis to perform the cloning operation. I've used various versions for years, and have been very happy with it. I used to use software that came with a new drive to make clones, but at work they used Acronis, so I switched to it for home use.


After I've made the clone I'm going to download and install the XML 4.0 and install it. I'll run it a few days, and probably make a new clone next weekend - one which includes the XML update.


Thanks for all the responses! I appreciate the help!



Link to comment
Share on other sites

The friend I borrowed the diagnostic disc from read my post and suggested I clarify a couple of points.


First, the system has a modular power supply, so when I disconnected and reconnected the power cables from the video card, I also disconnected and reconnected them at the power supply end. He (my friend) is of the opinion that the problem was that the video card was not receiving adequate power due to a poor connection in one or both of the power cables from the power supply to the video card.


Second, to be clear, after the video card was removed and then reinstalled, the diagnostics still failed. We believe that with the video card not functioning properly, the drivers did not install properly. However, uninstalling them (and deleting the folders under C:\AMD\Support), then Windows installing the old drivers, then installing the new drivers and Catalyst over the top of the drivers installed by Windows, fixed the driver problems.


Should someone else run into a strange problem like this, hopefully the information provided will be of use to you.



Link to comment
Share on other sites

Yes, ATI, the ASUS version of the HD6870. I have two systems with ATI video chipsets and two with NVIDIA video chipsets and I can't decide which drivers are the greater PITA. Last month it was NVIDIA, this month it is ATI.


Are you a gamer?


If not why update if they are working?

Link to comment
Share on other sites

Hi Digital Guru,


LOL, Yes, I do a fair amount of gaming, not as much as my twenty-something children, but I do a fair amount of gaming, a good bit of video editing, and routinely record tutorials that rely on full or partial video screen captures. Still, the majority of the hours I'm sitting in front of this computer I'm running VPN software and running Remote Desktop.


Due to mybackground, I generally take an:


if (it_isnt_broken) {


} else {




... approach, but often new "beta" software requires the latest drivers. Thus, lots of system restore points and a few "C:" drive clones.


As I'm sure you are aware, some of those drivers and some of that software is less than stable, which is one of the reasons I clone my "C:" drive on a regular basis. The cost of a 1T hard drive for a clone and the value of the time it takes to make a clone is far less than the value of the time it takes to rebuild a system from the OS up after a problem.


Oh, and take a close look at the "dark dungeon" in the screen capture. Maybe you will recognize it.



Link to comment
Share on other sites

Thanks for the suggestion. Windows Media Player is installed and running. Overnight and during the day today I've run Windows Defender Offline (Full Scan) which found nothing, and run a chkdsk, which also found nothing.


This evening I'm going to shut it down, reseat all the bords and connectors, and see what happens.


Oh, and the processor is an i7-2600

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...