Jump to content

Easy Cd Creator Version 5 And Xp - No Supported Cd-Recorders Available


Recommended Posts

Firstly, apologies in advance if this is a bit lengthy…


Before I give up on my version I felt I ought to check with the more knowledgeable people on here that my version of Easy CD Creator is unlikely to work again.


Little background: I like Easy CD Creator interface and have used it for many years. Starting with version 3 then 4 under Windows 98 and eventually needing to buy version 5 for an XP machine. The Win98 machine still works but struggles from time to time. The main purpose of both these machines is for recording, editing and mixing my music. So a CD burner is rather useful.


Up to earlier this year Easy CD Creator version 5.1.1 worked fine but completely out of the blue I started getting "there are no supported cd-recorders available". Fortunately I was able to switch to Sonic's RecordNow! - which came with the Dell Dimension 3000 running XP. But I would much rather continue with the 'friendlier' Easy CD Creator.


I have been through all of the Registry changes and uninstalls/reinstalls documented here and elsewhere a number of times. I've search through the Registry list of supported Easy CD Creator devices and can not find an entry for mine. Which is "TSSTcorp CDRW/DVD TSH492B". Which makes me wonder why it worked for 4 or more years before it stopped.


I know for sure that I had been successfully running version 5 alongside Windows Media Player (WMP) version 11 and IE8 for quite some time before it failed. (Although IE has not been my first choice browser for a few years now. It's currently Chrome which appears to use less resources.)

With that in mind I have uninstalled WMP 11 and IE8 and they have been automatically replaced by Windows with WMP 9 and IE6.


I then reinstalled Easy CD Creator version 5 and it runs but still receive the error message when I try to burn a CD. Just to make sure, I have uninstalled it again, rebooted, reinstalled and rebooted.



1) has anyone managed to overcome the "there are no supported cd-recorders available" problem expressed elsewhere in this forum?

2) where can I find the often mentioned "recognition patch: driveup.5.3.5v.exe"? It would be nice to download it and test it out on my version.

3) if, as I suspect, I have to purchase another version of the software is it safe to assume my drive will be recognised?

and, 4) as an aside… do later versions of Easy CD Creator recognize earlier layout files? I have many .cl3, .cl4 & .cl5 files which were useful documentation at one time but potentially useless now. Most software providers consider file compatibility with new versions of their software.


Any advice will be gratefully received - good or bad.


Many thanks


Link to comment
Share on other sites

Hello Rick,


[1] We've got past this problem by several different methods:

-swapping out the recorder for one which is recognized

-updating the drive recognition lookup table

-editing the lookup table to include the ID parameters of the newer drive


[2] Here is a copy of the 5.3.5v updater. This bulletin board won't let me upload an .exe file, so I have renamed it to .txt to upload it. Download it, and rename it to driveup5.3.5v.exe




[2a] You say you have version 5.1.1, but didn't say whether it's Basic or Platinum. I suspect you might need to be up to version 5.3.5 to use that drive updater, and in that case you will need the basic or platinum updaters to version 5.3.5. We'll need to talk further on this.


[3] It is ever so likely that newer software would recognize your drive. Versions 5 and 6 were on the cusp of the new system of "Dynamic Drive Recognition", and it was fully implemented in the software after them.


[4] No, this software has never been guaranteed to be able to handle saved project or layout files from different versions, and compatibility between versions is extremely limited. If you change major versions be prepared to write off all your saved projects/layouts. Any which do work will be a happy but unexpected bonus.




Link to comment
Share on other sites

Hi Brendon


Many thanks for your reply and the driveup5.3.5v file which I've downloaded and run. It is now showing version and as far as I believe it is the Basic version. There are no clues on installation disk which has printed on it Easy CD Creator and DirectCD Nor on any of the files on that disk. I've search all the drop down menus within the product but can not confirm whether it's Basic or Platinum.


What is my next step please? I did try burning a CD to see if anything had changed but it produced the now familiar "no supported cd-recorders available".


How do we go about editing the look-up tables you refer to?




Edited by Baldrick
Link to comment
Share on other sites

Hi cdanteek


I had forgotten about that launch screen. It doesn't appear any more and has not done so for quite a while. I do remember that not all of the options were available and can't remember if it said 'Platinum' in the top left hand corner. I've had a good look through 'Program Files' but can't an .exe for it.




Link to comment
Share on other sites

there is, cdanteek, but it does not help (see attachment as I couldn't use paste)


and the full text in in dialogue box...


Roxio Easy CD Creator.


Copyright ©1995-2001 Roxio Corporation. All Rights reserved. Easy CD Creator is protected by copyright law and international treaties. Unauthorized reproduction or distribution of this program, or any portion of it, may result in severe civil and criminal penalties, and will be prosecuted to the maximum extent possible under law.


MPEG Layer-3 audio compression technology licensed by Fraunhofer IIS and THOMSON multimedia.




Portions based upon Microsoft Windows Media Technologies.

Copyright © 1999-2001 Microsoft Corporation. All Rights Reserved.


Interface Design by XEODesign ® Inc.




Link to comment
Share on other sites

Relax Gents,


Version was only ever Easy CD Creator Basic, so that seems to confirm Rick's thought that he has Basic.


Rick, I don't know if a registry edit will help you since your software was working fine for years using ECDC's rudimentary "Dynamic Drive Recognition" before something broke it - in other words it was recognizing the drive without using the registry table. However it won't hurt to edit the table, and it might help you.


The registry has an entry for the TSH492A drive, and that can be edited to TSH492B to match your drive.


-run the Windows registry editor, REGEDIT.EXE

-go to the top toolbar Edit >Find... and in the Find box type TS-H492A then click Find Next


You should end up in a registry key [HKEY_LOCAL_MACHINE\Software\Adaptec\Adaptec Shared\CDEngine\Devices1]

with a device entry which reads like this. The device number will probably be device068.

"device068"="TSSTcorp CDW/DVD TS-H492A,TSSTcorp,CDW/DVD TS-H492A,MTK4832_Liteon,cdrmmc.drv,155,,9"


What you need to do is edit the contents of that device entry so that the two instances of H492A you see there are changed into H492B. Then click OK and put regedit away. Reboot Windows and restart ECDC, and you'll be using the edited registry key.


If this registry editing is a bit much for you, don't worry. I can write a little registry script file for you which you double-click and it will do the job. I need two pieces of info from you for that:

-confirm what the devicenumber was when you found TS-H492A - was it device068 ?

-Regedit shows at the bottom edge of its window what key it has open.

Is it My Computer\HKEY_LOCAL_MACHINE\Software\Adaptec\Adaptec Shared\CDEngine\Devices1 ?




Link to comment
Share on other sites

Hi Brendon


Alas, no change with my "no supported cd-recorders" condition.


For the record, this is what I carried out...


Located TS-H492A value related to device068 for HKEY_LOCAL_MACHINE\SOFTWARE\Adaptec\Adaptec Shared\CDEngine\Devices1


Amended it to "TSSTcorp CDW/DVD TS-H492B,TSSTcorp,CDW/DVD TS-H492B,MTK4832_Liteon,cdrmmc.drv,155,,9"


Also located TS-H492A against 3 other keys but left them alone for the time being.


Rebooted PC and tried ECDC.


Amended the 3 other keys to read TS-H492B:-


HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\pwd_2K\device742\Parameters PARAM1 = "CDW/DVD TS-H492B"

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\pwd_2K\device742\Parameters PARAM1 = "CDW/DVD TS-H492B"

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\pwd_2K\device742\Parameters PARAM1 = "CDW/DVD TS-H492B"


Rebooted PC and tried ECDC.


Short of trying it with another CD Writer (which I don't currently possess) I think I'll source a later version of the software. Meanwhile I am still able to use Sonic's RecordNow! (Which, just to make sure, I checked was still working after the changes.)


Many thanks for your assistance.



Link to comment
Share on other sites

Okay Rick,


Sorry the usual remedies didn't work, but as you noted the system did work for some long time before it suddenly broke - whatever broke it also prevented the usual remedies from working.


Thanks for trying. It's good to work with someone who is prepared to put in the effort himself as well.




Link to comment
Share on other sites

Thanks Rick.


Just in case you come back to try something more another time, the three references in pwd_2k are for Direct CD, the packet writing application in version 5. Only the reference in CDEngine affects Creator itself.


Given your location, I'd like to talk with you about something off-topic. I've sent you a private message. The PM system is an envelope icon up at the top right of the forum page, alongside your screen name.




Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...