Jump to content
  • Who's Online   0 Members, 0 Anonymous, 9 Guests (See full list)

    • There are no registered users currently online
  • 0

This Product Has Never Worked, Help?



I bought the Roxio GameCap at the end of August while I was working away for the summer. I came home for a week and couldn't get it to work then so I figured I'd give it another crack when I was home for good. It's now November and I still can't get this device to work. I'm sure it's absolutely not the product and probably my own error but I would like to get it figured out and sort the problem out so I can actually use this wonderful device.


Some of the errors I am receiving are the "Unknown Capture Error" and some kind of Script error which I haven't received in a while however I have screen capped this occurrence.




All of my wires and cords are set up, but the Roxio program will always say no signal in all red, like it would if it were not plugged in. I have uninstalled and re-installed several times to no avail. I have also tried all of my usb ports and actually tried a different computer entirely in the beginning way back in August.


If any one can help, anyone at all, I would appreciate any feedback and desperately need it at this point. I know it's stupid but when I get stressed and anxious all I want to do is cry and my brain just stops working. U-U;


ANYWAY, please and thank you in advance to anyone that can help me with this problem/tries to help with this problem.



Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Unknown are the worst kind to fix :lol:


Try this:


Unplug your RGC Device and put it aside until you are completely finished.


Download and install the
Uninstaller. Then run it in
Moderate Mode
to remove any traces of Roxio.


Then turn off your Anti Virus, Firewalls, Registry Cleaners, etc.


Now insert your Roxio Disc.


Be sure you accept the offer to Check for Updates (this is for Roxio, not Windows)


When the Install competes, turn your AV & Firewall back on and reboot.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...