Jump to content
  • 0

New Version Seems Very Buggy. :(


firemapper

Question

I'll have to say, I'm pretty disappointed in this latest update. I think the quality control has gone way down at Roxio. I have spent the day playing around with some of the programs and have had them crash several times.

 

I was writing a data CD using Creator Classic and had it crash 5 or 6 times before I finally got the CD written. Frankly, I was surprised it didn't crash while writing. Before it crashed it would do things like make my whole screen turn white then, if I clicked in the right spot, portions would become visible again. Other times, context menus would pop up in the top left corner of the screen instead of where i clicked.

 

Then I tried opening a 7.5 VideoWave project in the new version. That didn't happen. Made the program crash everytime. I actually have several iterations of the project. It can open the first one, but none of the other ones. This tells me that the newer version must not support all the things you could do in 7.5, I'm guessing.

 

Then I tried creating a Video DVD using MyDVD. I put together the menu with a couple of video, nothing fancy. I started the burn process. It got about 40% done and I discovered that the computer was locked up. Had to hard boot it. Now that's hard to do to XP.

 

I don't know if Roxio's folks monitor this forum. I hope so. They need to know that they're not doing a very good job. I have been using their software since, well since Adaptec owned it. I haven't seen it this buggy in a long time. Maybe the problem is Sonic.

Link to comment
Share on other sites

1 answer to this question

Recommended Posts

I'll have to say, I'm pretty disappointed in this latest update. I think the quality control has gone way down at Roxio. I have spent the day playing around with some of the programs and have had them crash several times.

 

I was writing a data CD using Creator Classic and had it crash 5 or 6 times before I finally got the CD written. Frankly, I was surprised it didn't crash while writing. Before it crashed it would do things like make my whole screen turn white then, if I clicked in the right spot, portions would become visible again. Other times, context menus would pop up in the top left corner of the screen instead of where i clicked.

 

Then I tried opening a 7.5 VideoWave project in the new version. That didn't happen. Made the program crash everytime. I actually have several iterations of the project. It can open the first one, but none of the other ones. This tells me that the newer version must not support all the things you could do in 7.5, I'm guessing.

 

Then I tried creating a Video DVD using MyDVD. I put together the menu with a couple of video, nothing fancy. I started the burn process. It got about 40% done and I discovered that the computer was locked up. Had to hard boot it. Now that's hard to do to XP.

 

I don't know if Roxio's folks monitor this forum. I hope so. They need to know that they're not doing a very good job. I have been using their software since, well since Adaptec owned it. I haven't seen it this buggy in a long time. Maybe the problem is Sonic.

 

 

Several Roxio Officials monitor this forum. But only one of them seems ti do it every day. They are trying their best to help people.

 

 

Try getting the latest driver updates for both your CD/DVD burner and Graphics Card. This may help. :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...