Jump to content
  • 0
music man53

Creator Nxt Pro 3 Lp And Tape Assistant Not Responding

Question

I am running Windows 8.1 and using Creator NXT Pro 3 to digitize cassette tapes. Sound quality on finished projects is excellent, but I often waste my time (and the money I've spent on this boxed software of Creator Pro) because the LP and Tape Assistant often gives me a "Not Responding" after I click on "Next" to finish the project. I have turned off my PC's firewall and anti-virus software and then done a "Repair" with my Creator disks, as well as a complete uninstall and reinstall, but these actions do not prevent the freeze. I have received some relief by not recording over 25 minutes at a time and then editing in the rest of the cassette as a separate add-on, even though the need to do this shows a defect in the software.

 

After registering my Creator software, I did not receive a tech support code, as requested of their product's users for support. There seems no way to contact Roxio for assistance; thus, I'm publicizing my problems and caution about this software. $99 USD is a lot of money to pay for something that does not work most of the time, and no way to get assistance from Roxio technical services.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

When it keeps happening like you describe, it is not the software but rather self inflected ;)

 

You have a Reg Cleaner running (could be in your anti virus program) and it is destroying entries for Roxio.

Share this post


Link to post
Share on other sites
  • 0

I have the same problem running Windows 8.1 Pro with 16gb ram. It ran once and then it started to hang. I uninstalled the software and reinstalled it. It still has the same problem.

 

The repair of he software does not allow for a repair. The path is not found. The software was downloaded. So I do not have physical media.

Share this post


Link to post
Share on other sites
  • 0

I have the same problem running Windows 8.1 Pro with 16gb ram. It ran once and then it started to hang. I uninstalled the software and reinstalled it. It still has the same problem.

 

The repair of he software does not allow for a repair. The path is not found. The software was downloaded. So I do not have physical media.

 

1. Do you run a registry cleaner?

 

2. Your supposed to back up the download by burning it to disc!

 

3. Point the repair to your download saved location and repair should run.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×