Jump to content
  • 0
AlbanianGamer

Roxio Game Capture Hd Pro Not Working Anymore!

Question

I have hooked up my Roxio Game Cap HD Pro, for the PS3, Xbox 360, Xbox One, and PC, and I always get the same capture breaking problem. Note, that I have had this product for a good year now, and I have not had any capture breaking problems until now. And I also know that I am setting it up correctly each time. Once I set everything up and I open the RGC HD Cap Pro software, I always get a blue glitchy preview screen and a red NO SIGNAL, and even a Blue screen on my TV/PC monitor(yes I sometimes use pc monitor to record). I have tried everything, but I am not giving up so easy. If anyone out there knows a solution it would be greatly appreciated, if you could write it down below. If no solution works, I will then get a new capture card.

 

-AlbanianGamer

Edited by AlbanianGamer

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

It worked for a year and now doesn't. That means you changed something in your syste - an update (manual or automatic), hard drive badly defragged, or some other problem with your system

Share this post


Link to post
Share on other sites
  • 0

I don't really have any idea what 'capture breaking' means???

 

Walt is right about your PC free space but your Red 'No Signal' means the RGC Device is being seen but it has NO valid signal.

 

My First Though is that it broke. But then mine is 2+years old and the number broken has been nil...

 

Swap CORDS and devices to see what happens ;)

Share this post


Link to post
Share on other sites
  • 0

I don't really have any idea what 'capture breaking' means???

 

Walt is right about your PC free space but your Red 'No Signal' means the RGC Device is being seen but it has NO valid signal.

 

My First Though is that it broke. But then mine is 2+years old and the number broken has been nil...

 

Swap CORDS and devices to see what happens ;)

 

Ok I just want to ask before I do this, will updating my operating system which is Windows Vista (meaning to the latest updated software), might make it work?

Edited by AlbanianGamer

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×