Jump to content
  • Who's Online   0 Members, 0 Anonymous, 14 Guests (See full list)

    There are no registered users currently online

  • 0
tsp1965

Toast Burns From Eyetv With Wrong Or No Sound

Question

Hi

 

I have been having trouble with burning dvds from recordings made with EyeTV 1.8.4 (and then v2.0) which came with my Terratec DTT product . Basically most recordings burn fine to dvd with Toast, but maybe 10% burn with the wrong or no sound. This problem seems to be related to the second audio channel sometimes used by broadcasters to record descriptive commentary for the visually impaired. The 'no sound' problem seems to occur when Toast takes that channel even though it is empty. Two examples. This weekend I recorded the movie Shaft from UK Channel 4. On burning I get only the second channel with additional commentary (a lady describing what is happening), but no actual film sound at all. EyeTV itself plays whichever channel you select in the audio menu. However, whatever export options I choose I always get the second channel only. I have tried the direct Burn with Toast route and the Export for Toast route - same result. Last night I recorded a documentary on BBC4 - this has no sound on DVD because the second channel is empty.

 

What we really need is a selectable option to choose which audio channel to use, to prevent Toast getting confused about which audio to use.

 

I see on this forum that this is a known issue but the advice there - select the channel you want before export and/or Export rather than direct burn - is not helping.

 

Has anyone else resolved this problem?

 

Regards

 

Tim Pollard

Share this post


Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Tim,

 

I've had similar problems, I use a workaround that is a bit long-winded but it does work. if you get VLC and ffmegx (both free from macupdate) you can find the mpeg transport stream you wish to author in the Eyetv archive folder,(by opening the file with VLC) drag this to ffmegx and convert it to DVDffmpeg. This will create a Video_TS folder that you can play with DVD player to check that it looks right before you burn it with toast. Also you could try dragging the Eyetv archive file directly to Toast but this can produce a mono soundtrack.

 

Eyetv seems inconsistent in the exported files that it creates which is why I find it better to go to the original archive file and start with that. I have found that every episode of "The Professionals" that I have recorded will play perfectly in Eyetv but when it exports it to any format I get jumpy playback. I could also go on about the many problems with Toast7 but that would take to long, maybe later.

 

Hope this helps.

 

Ricky

Share this post


Link to post
Share on other sites
  • 0

Thanks Ricky

 

I'll give these a try.

 

You wouldn't have thought that the ability to choose an audio track to burn would be beyond them, would you!

 

Thanks for your help.

 

Regards

 

Tim

Share this post


Link to post
Share on other sites
  • 0

this has started happening to me - any updates that will fix it? i am not that hot on computers and bought this for the simplicity...

 

so could do with an update rather than a work around

 

as ever - all help appreciated

Share this post


Link to post
Share on other sites
  • 0

Hi,

 

I had the same problem.

I don't know why - but this worked for me.

Don't drag the eyetv file onto the Toast browser - instead go to eyetv - file - export. Choose For Toast. It will then save it on your desktop or documents folder etc. It will also appear in the Toast Browser window.

If you now burn - the video and audio will playback fine.

Odd I know!

 

Regards

 

Rob

Share this post


Link to post
Share on other sites
  • 0

I raised a ticket with Elgato to see if they have a solution and the support team suggested that the following FAQ addresses the issue:

 

http://faq.elgato.com/index.php/faq/more/358/

 

Not being at home I haven't had a chance to try it out, but I thought I'd share the update with the forum hot off the press!

 

UPDATE: It worked! The program stream export is one of the quicker export options so this is relatively painless... until Toast gives the option to select an audio track or Elgato ensures that only the selected audio track is available! It is not clear to me where the fault lies.

Edited by tim_fenton

Share this post


Link to post
Share on other sites
  • 0

Have just written another post with what seems to be the exact same problem - but didn't find this thread in my original search. I will try your suggestion of exporting for Toast and see if it stops me becoming a full time coaster manufacturer. The thing I find strange is that I have burned many films and TV programmes before this week and had absolutely no problem with the sound - so I became convinced that it was my programme or computer.

Share this post


Link to post
Share on other sites
  • 0

Hi,

I'm having the same problem and have tried exporting for Toast and as an MPEG-2 stream six times with the same Nature show, and each attempt results failure. It runs fine in eyetv, is a 55 minute, 5+gb file that is every time exporting as a 33mb file that only shows the brief 45 second intro! Does this mean the only hope is the lengthy (but ingenious) process w/ VLC and ffmpg? (I've not used ffmpg much because I don't know what all the settings mean. . . . any suggestions for a good explanatory faq/glossary?)

 

Thanks in advance for any suggestions!

Gretchen

Share this post


Link to post
Share on other sites
  • 0
. . . if you get VLC and ffmegx (both free from macupdate) you can find the mpeg transport stream you wish to author in the Eyetv archive folder,(by opening the file with VLC) drag this to ffmegx and convert it to DVDffmpeg. This will create a Video_TS folder that you can play with DVD player to check that it looks right before you burn it with toast. Also you could try dragging the Eyetv archive file directly to Toast but this can produce a mono soundtrack. . . .

 

Okay, I got VLC and ffmpegX, but ffmpeg won't recognize the file in the Eyetv archive folder. Are you first exporting it as an mpeg-2 stream?? That IS the long way around!

 

Thanks for any and all help! I've just discovered that quite a few shows I recorded have the wrong sound track, which is very frustrating!

 

Gretchen

Share this post


Link to post
Share on other sites
  • 0
Okay, I got VLC and ffmpegX, but ffmpeg won't recognize the file in the Eyetv archive folder. Are you first exporting it as an mpeg-2 stream??

 

You shouldn't have to export. However, you may need to right click the .eyetv file and choose "show package contents". I don't have ffmpeg installed, but use this trick to go strainght to MPEG StreamCLip.

 

HTH

Share this post


Link to post
Share on other sites
  • 0

I should update my previous post:

 

ffmpegx can be unpredictable and you don't need VLC with v2 of EyeTV.

 

MPEGStreamClip could be a solution but I have never found it solved the problems I have encountered and also I think you need QT "mpeg2 playback component", Apple expects you to pay for this even if you have QT PRO.

 

I can't understand why you are getting a 45sec file on export unless there is a marker at 0 secs and 45 secs on the EyeTV edit window timeline and you are inadvertently exporting just the clip.

 

Is the sound correct in this 45sec clip?

 

With wrong audio I find that the Elgato tip or "export to toast" do normally work.

 

Export to DV is probably the only way to be sure if the file is being really difficult. I only ever have to do this with non-DVD compliant recordings when Toast re-encoding doesn't work. If you do want to try it then start with just a one minute clip and export the clip to DV, play it in Quicktime, if it sounds OK then export the whole thing and then you have the option of using iDVD to make nice menus.

 

I must confess that I now watch most shows by screen-spanning my G5 to an HDTV, it saves a lot of time.

 

Ricky.

Share this post


Link to post
Share on other sites
  • 0
Hi,

 

I had the same problem.

I don't know why - but this worked for me.

Don't drag the eyetv file onto the Toast browser - instead go to eyetv - file - export. Choose For Toast. It will then save it on your desktop or documents folder etc. It will also appear in the Toast Browser window.

If you now burn - the video and audio will playback fine.

Odd I know!

 

Regards

 

Rob

Share this post


Link to post
Share on other sites
  • 0

This problem of no sound / wrong sound when exporting from EyeTV has persisted for ages with Toast, I remember it being around certainly 2 years ago.

 

Why is it so difficult to fix this in updates, they appear regularly and the problem is well known!

 

Although work-arounds are possible (as shown in this forum) they take far longer than the normal way of burning on DVD.

 

My one recommendation to all: check that your DVD has sound before you delete the EyeTV source file...!!

 

My appeal to Roxio is: FIX THIS PROBLEM!!

Share this post


Link to post
Share on other sites
  • 0
Well, it's not a Toast issue. Toast has no way of selecting multiple audio tracks. That is why EyeTV has the options to export different tracks, etc.

 

http://faq.elgato.com/index.php/faq/more/416

http://faq.elgato.com/index.php/faq/more/358

 

 

Thanks for the reponse - the articles you refer to are interesting but don't capture the problem.

 

Whichever way we argue here - in the end the two programs (Toast and Eye TV) have to work together, one claims glory from the other, so whoever we declare as culprit won't matter - both companies have to work out how they make these programs talk to each other. This is not some amateur freeware but commercial software.

 

I don't accept any "work-around" in the long run, all of them are far too time-consuming. It's a well-defined problem and has been around for ages.

Share this post


Link to post
Share on other sites
  • 0

I had the same problem (blind viewers’ commentary the only sound track) when burning a video DVD using EyeTV 2.3 with Toast 7.1. Creating an MPEG export file (“for Toast”) restores the sound tracks, but with sound and vision out of sync.

 

I’ve tried changing the Audio Format from Dolby Digital to PCM, but the sound/vision sync problem persists. My machine is a Mac mini with an Intel Core Solo processor and Mac OS 10.4.8.

 

Any ideas?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×