Jump to content
  • 0

Ps3 Quality Looks Awful


DailyGlitcherHD
 Share

Question

Hi guys.

I've recently bought a PS3 and I've heard that you can't use HDMI to record because of something called HDCP. So I bought the HD component cables for my Roxio Game Capture HD PRO and the quality looks awful.

It used to look absolutely beautiful back when I had my Xbox 360.

Here's a screenshot I took from my PS3 on 1080i:

 

83f4e7dca12d716be2ae17a3cb9ea49f.jpg

 

This is frustrating, please help ASAP, thanks.

Link to comment
Share on other sites

Recommended Posts

  • 0

You need to ensure that the PS/3 output is set to a specific output resolution setting, Make sure you don't let the PS/3 auto-detect the output device.

 

If it worked fine with your Xbox, we know the RGC is ok, so look at your user manual for the PS3.

Edited by ogdens
Link to comment
Share on other sites

  • 0

You need to ensure that the PS/3 output is set to a specific output resolution setting, Make sure you don't let the PS/3 auto-detect the output device.

 

If it worked fine with your Xbox, we know the RGC is ok, so look at your user manual for the PS3.

On Xbox I used an HDMI cable and on PS3 I have to use a component cable. Here's my setup:

3e2806276d0d4e2645ac72c61ac3023d.png

Link to comment
Share on other sites

  • 0

DailyGlitcher, looking at your picture above, showing screen resolutions, I don't see where anything is selected there. Do you know what it is set to? Are you manually setting it to output a particular resolution? That is what you need to do, and NOT let the PS3 auto-detect what it thinks it should be setting.

Link to comment
Share on other sites

  • 0

DailyGlitcher, looking at your picture above, showing screen resolutions, I don't see where anything is selected there. Do you know what it is set to? Are you manually setting it to output a particular resolution? That is what you need to do, and NOT let the PS3 auto-detect what it thinks it should be setting.

I went to Display Settings - Video Output Settings - it asked me "select the type of the connector on your TV" and I selected "Component / D-Terminal" - then it asked me "select all resolutions that are supported by your TV" and I selected 480p, 720p and 1080i and then that's it.

Link to comment
Share on other sites

  • 0

So, you gave it choices. We're telling you not to do that. Tell it either 720p OR 1080i. It's apparently choosing 480p, which looks bad. Tell it what you want and don't let it choose.

 

Let us know if that helps.

I have tried 720p and 1080i and they both look bad. :(

By the way: There's a tick on the top which says "Standard (NTSC)" and I can't un-tick it.

Edited by DailyGlitcherHD
Link to comment
Share on other sites

  • 0

The only 'preview' is in the RGC Software, don't confuse the problem by adding "TV" to it ;)

 

The ONLY way to test at this point is to use a completely different source! You need to hook up a DVD or BD Player, preferably with Component but HDMI will do in a pinch. Anything that has those outputs will suffice.

Link to comment
Share on other sites

  • 0

The only 'preview' is in the RGC Software, don't confuse the problem by adding "TV" to it ;)

 

The ONLY way to test at this point is to use a completely different source! You need to hook up a DVD or BD Player, preferably with Component but HDMI will do in a pinch. Anything that has those outputs will suffice.

Before my component cables arrived I used to use HDMI (of course I couldn't record but I could see the picture on my PS3) and it looked great. The RGC is not the problem.

Edited by DailyGlitcherHD
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...