Jump to content
  • Who's Online   0 Members, 0 Anonymous, 12 Guests (See full list)

    • There are no registered users currently online
  • 0

Upgrading Perhaps



I have Toast Titanium 7 --version 7.1.3 If I want to upgrade for free to a higher, newer version, what should I do?

It works fine for me. I use it only to copy on DVD, movies I downloaded (legally) to my Hard Drive, and once copied on a DVD, I erase the movies since it takes a lot of space.

However, from time to time a DVD will fail and perhaps it might just be something that happens from time to time or perhaps I need a newer version. I had 2 DVD so far (on 10 DVD) that had a problem.

I get this message:


I believe (can't remember) that I can't do anything but throw away the disc.

I also get sometimes this message: (I quote from memory) "Beginning of loop/ end of loop is missing"

However it plays without me seeing any problem.

On the one hand, I have no problem, on the other hand it is from 1997-2007 according to "About Me"

and I see that now they have Toast 14. So this is really an old version.


The longer I wait to upgrade the more difficult it will be. But it has to be free (financial problems right now) and as I said it works fine.


Can I upgrade either incrementally to 8, 9 and 10 or go directly from Toast 7 to 9 or 10.

I don't need the latest one (14).

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

...Also, if these discs previously played okay, but now don't, it's not a problem with the program because (since they played at one time) they worked. (I hope you test your discs before you delete the movies from your hard drive?) So the problem would likely be with the discs you're using, or how they're being stored. Spending a few pennies more on media can be worth it. I've had good luck with Verbatim media, and I've avoided store brands (Staples) and the least expensive brands (Imation, Memorex) which have anecdotaly had more problems.


And, as Brendon said, there are no free upgrades.

Link to comment
Share on other sites

Hi, You said

>..Also, if these discs previously played okay, but now don't,.."

No, I'm talking long before that, before I even put them away: I copy a movie on DVD and when it's finish Toast automatically verify but I still check the disc: I eject the disc and put it again on the tray and check to see if everything is OK. In the past, 95-99% of the time it is OK. (If it isn't I redo it.)

> (I hope you test your discs before you delete the movies from your hard drive?) " Of course! See above.

Once the disk is OK, I put it away. I copy a lot of movies and watch it later. When I do watch everything is fine. They are in a jewel case and are vertically stored in a box to protect from dust. And the boxes are inside my bookcase behind doors.

Over the years I used only brand names. Over the years I used Imation, Memorex, Taiyo Yuden, Verbatim. What I have now, with the problems reported, is Verbatim (the real one; with AZO).

I did some research after the second incident and I find out that the problem might be speed is to slow.

Before I put "best speed" and it was 1x, 2x or 4x (don't remember because it was years ago). And recently I read that it should be at least 8x : again I read that several months ago so I'm not sure about 8x or 4x but the idea was that although too fast is not good, too slow is not good either and you should put it minimum at 4x or 8x (I'm sure it wasn't 16x, either 4 or 8) and so instead of choosing "best speed", I said 8x and no problems.

At the same time, if I record something weeks later, I forgot about that and put "best speed" and it's still OK.

The idea with best speed is that Toast look at the disk and decide what is best.

Anyway I was just concerned that my Toast 7 is old and perhaps I should upgrade. I though it's like Apple when you upgrade for free to another version. And it's not only Apple: Last week I made free upgrades of Snapz Pro X, ClipGrab, iGetter and Flash Player.

So they want me to buy, huh? What will be the best option: Toast 8 ? 9? 10? or go all the way to a much newer version?

Link to comment
Share on other sites

I can't really advise you on that since I'm a "Creator" user. (Windows/PC.) But I do recall seeing something in the Toast forum about one of the newer versions writing slow to disc, and the solution was to go back a couple versions to where it wrote faster. Do a little searching here, and you'll probably find that.


However, I'm also a proponent of, "if it ain't broke, fiddle with it till it is, err... don't fix it." It doesn't sound like there's any problem with your current Toast 7, unless you happen to know of some feature in a newer version that you want...?

Link to comment
Share on other sites

My Toast Titanium 7 (version 7.1.3) is not working

Update: I said previously:

"I also get this message: 'Lead-in and lead-out failed to be written' however it plays without me seeing any problems."

Update: Well no, once or twice it played without a problem, despite the above message, but I just copied a DVD, got this message (Lead-in and lead-out failed to be written), and there is a problem: My computer doesn't recognize the disk. I put the disk in the tray and it doesn't appear on the desktop! And after 3-4 minutes the tray open by itself and wants to eject (as to say to me: "Take it, I don't know what to do with this!"). And this after the disk is verified at the end. I copy it takes 12 minutes then it verifies and then it says something verification successfully done (or something similar), so when i check (taking it out and put it back again on the tray, it is not recognized.

So I DO have a problem. Which I didn't with Snow Leopard. (I now have Mountain Lion).

What does that mean? Each time I will upgrade my OSX I will need to buy a newer version of Toast?

The other day I got an idea and thought it was a great idea: Since Toast worked on Snow Leopard and since I still have Snow Leopard on my external storage, why not boot my computer with the external storage and use Toast 7? I did. It copied, verified the disk, I even saw "writing Lead-out" which I didn't see before (I mean this week; over the years I always saw this; writing lead-in, writing lead-out)

But when I tried to check I got this

Couldn't complete the last command because of a Mac OS error

Result Code = 3

Can't use the disk. I'm surprised because, as I said it worked on Snow Leopard. And suddenly it doesn't?

PS: I wonder how I got Toast in the first place; I do have a disc that says Toast Titanium 7 but I don't think I bought this. Did it comes as an extra with either my first computer G4 in 2000 or perhaps the Intel computer that I have now, bought in February 2010? (I doubt it came with a scanner or printer.)


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...