Jump to content
  • Who's Online   0 Members, 0 Anonymous, 9 Guests (See full list)

    • There are no registered users currently online
  • 0

The Cd Audio Burning Program Crash When I Try To Save The Project



Hi guys.

I am experiencing an issue with Roxio Creator NXT Pro 3

I am using a “Roxio Creator NXT Pro 3” to burn some CD audio. After the burning, I would like to save the project, but the program crashes and close just I tried to save it (see img. attached). By the Event Manager I have found out two error events as shown in the attached file. This is the first time that I do this burning operation.

Furthermore, I would like to inform you if I use the “Roxio Music Disc Creator” it does not crash for project saving.


Is there a solution to this trouble or not? Can you help me to fix it?


Thank you in advance and have a nice day.




S.O.: Windows 8.1



Link to comment
Share on other sites

9 answers to this question

Recommended Posts

Something in the program has gotten corrupted and causing the crash.

You need to do a proper repair:

First thing to do is to turn off your Anti Virus, Firewalls, Registry Cleaners, etc.

Now insert your Roxio Disc. (if download run the EXE)

When you reach the screen where Repair is offered, choose that! (if that doesn't show up, just go ahead and do an install)

When the Repair completes, turn your AV & Firewall back on and reboot.

That should do the trick but try it after reboot with something simple ;)


Let us know how that works for you.

Link to comment
Share on other sites

Thank you for your kind replay.

I have tried to do as you suggested but no result. It is not a big trouble, but I would like to fix it. In the next days I will try to install the program in another computer (windows 7) in order to verify whether the trouble is due to a bug of the program or the DVD contents or the S.O. Windows 8.1.

If you have any other suggestions I will be happy. :)


Have a nice week.



Link to comment
Share on other sites

I can agree with you, but on my PC the problem is present. May be this is only in my PC (hardware or some library of O.S.). I repeated the all repair operations, but not result. Then I uninstall the whole “Roxio Creator NXT Pro 3” program and reinstalled it, but the issue comes out again. I do not know what to do.

By the way thank you for your help and patient.


Have a nice day.



Link to comment
Share on other sites

Sorry for the delay.

Yesterday, I carried out some test on other computer. I installed the “Roxio Creator NXT Pro 3” in the my wife's laptop (win 7) and it has been possible to save the project. The “Roxio Creator NXT Pro 3” program did not crashed.

Furthermore, I tried to do a test on an another my PC (win 7) where the “Roxio Creator 2012 Pro” is installed. The Roxio program did not crashed too.

Then I suppose the cause of issue could be a bug of “Roxio Creator NXT Pro 3” program or some incompatibility with windows 8.1.

At this point I will try to uninstall the "Roxio Creator NXT Pro 3" and install it again.


Have a nice day.


Link to comment
Share on other sites

For persistent problems like this we need to go a little farther.

This is extensive, but it what I suggest...
(Add Nothing! - Skip Nothing!)

Download and install the Revo Uninstaller. Then run it in Moderate Mode to remove any traces of Roxio.

Create a New User Account with Administrator Privileges.

Turn OFF any A/V & Firewall.

Reboot and log on to that new account.

Copy your entire disc to a new folder on your HDD.

In that new folder, right click on Setup.exe and select Properties.

Under the Compatibility tab, make sure nothing is checked!

Right click Setup.exe and select Open.

Allow it to Check for Updates (this is for Roxio not Windows)

Use the Default Locations!

When the Install completes, turn your AV & Firewall back on and reboot.

Link to comment
Share on other sites

May be, I have understood that the RGC device is "Roxio Game Capture" device. If it is that I have not it.






It the Roxio Game Capture, that that text is boiler plate, I thought I had removed those references (it is needed 99% of the time by gamers)


Fixed it now, give it a shot and let us know ;)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...