Jump to content
  • 0

Dragon Engine Initialization Failed


aprasad

Question

I can't launch Creator Classic. I get the engine initialization failed message.

 

This is the downloaded version.

 

I see that an update is available for the CDROM version, but not the downloaded version. Is there anything for me to try (other than re-installing the program)?

 

Aloke

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

I can't launch Creator Classic. I get the engine initialization failed message.

 

This is the downloaded version.

 

I see that an update is available for the CDROM version, but not the downloaded version. Is there anything for me to try (other than re-installing the program)?

 

Aloke

There are a few things you can try. First is to use the MS Installer Cleanup and reinstall.

If that doesn't work, thismight.

Please let me know what happens as others who've had this error and were given suggestions did not post back with their results.

Link to comment
Share on other sites

I'll chime in with my experience. I got that same error after the last update to Napster. The only thing that worked to get rid of it was uninstall Napster and then do a repair on EMC8.

 

While I would like to have Napster, I barely ever use it so I haven't missed it.

 

Regards,

 

Gary

Link to comment
Share on other sites

I'll chime in with my experience. I got that same error after the last update to Napster. The only thing that worked to get rid of it was uninstall Napster and then do a repair on EMC8.

 

While I would like to have Napster, I barely ever use it so I haven't missed it.

 

Regards,

 

Gary

Users of 7 & 7.5 who had this error were able to fix it by installing Napster. You could always uninstall it later but I'm not positive that it will fix this problem in 8. It is worth a try.

Link to comment
Share on other sites

There are a few things you can try. First is to use the MS Installer Cleanup and reinstall.

If that doesn't work, thismight.

Please let me know what happens as others who've had this error and were given suggestions did not post back with their results.

 

I did a repair install. I had to open the downloaded .EXE file in Winzip and extract it to a temporary drive. The repair process wanted access to the .MSI file packaged in it.

 

Youe 2nd link (Roxio KB file on re-registering the DLL's) won't work as that is for EZMedia ver 7. Those DLL's weren't there in the C:\Program Files\Common Files\Roxio Shared\Dragon directory.

 

Anyway, things are working now..

 

Aloke

Link to comment
Share on other sites

I did a repair install. I had to open the downloaded .EXE file in Winzip and extract it to a temporary drive. The repair process wanted access to the .MSI file packaged in it.

 

Youe 2nd link (Roxio KB file on re-registering the DLL's) won't work as that is for EZMedia ver 7. Those DLL's weren't there in the C:\Program Files\Common Files\Roxio Shared\Dragon directory.

 

Anyway, things are working now..

 

Aloke

Great, thanks for letting me know.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...