Jump to content
  • Who's Online   0 Members, 0 Anonymous, 8 Guests (See full list)

    • There are no registered users currently online
  • 0

Cannot Get Any Driver To Work/install For Vhs/dvd 3 Plus Usb Adapter


BCSMITHROCKS
 Share

Question

I have spent hours trying to get a driver to work for the VHS to DVD USB Adapter on Windows 10.

I have downloaded the Win64 driver files, and even tried the Win32 driver files (even though I knew that would be the wrong one), and out of desperation I have even tried the old 2009 usb driver, as well as the uninstalling and re-installing the disc multiple times, hoping that the driver was actually on the disc and would install but it never does.

when I check the device it always says that windows could not install a driver for it, and that it currently has no driver. I can't for any reason seem to be able to get the Roxio software to see the Roxio USB Adapter. any help would be greatly appreciated.

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Common mistake is to plug in the USB Device before the software/drivers are installed... Once that happens, Windows installs the driver it thinks is best AND associates that wrong driver with the device :wacko: It will show with an error

 

Remove the device and hide it in another room (so you won't be tempted)

Uninstall the existing Software (Control Panel - Programs and Features) - if it is present there, otherwise.

Reboot and install the software.

After that, fetch the device and move to the next step.

 

NEXT problem is there are 2 different devices and software. Only the 'newer' one works with Win 10.

 

post-39730-0-46267500-1481542958_thumb.jpg

First plug in the device and check in Device Manager (Win-Pause, list on left)

Should see:

post-39730-0-64500800-1481543109_thumb.jpg

Won't work if you have this:

post-39730-0-22387600-1481543202_thumb.jpg

Give those things a try and let us know how you make out ;)

Link to comment
Share on other sites

  • 0

I uninstalled all software, and removed all of the usb options that now show again with the same indication warning. not sure why so many instances show up.

but it is still not functioning at all. I tried taking a posting a screenshot, but for some reason this forum seems to require me to host the image somewhere externally and to be able to link to it instead of simply posting the image.

 

Edit: I do have the new version of the adapter.

Edited by BCSMITHROCKS
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...