Jump to content
  • Who's Online   0 Members, 0 Anonymous, 9 Guests (See full list)

    • There are no registered users currently online
  • 0

No Video - Device Showing Up As Dazzle In Device Manager



I wanted to post an issue I recently had, and the solution I found, when the Roxie VHS to DVD 3 Plus device kept showing up as a Dazzle Device in my Device Manager.


This all started when I could not receive a video capture after installing the Roxie software and Capture Device. I had just bought a brand new MCI laptop, with Windows 10 x64 bit, Intel i7-7700 processor, a 250gb SSD and 1tb Hard Drive, NVIDIA Graphics Card. My sole intention for the new laptop was to video edit. My only concern at the time was the fact was Windows 10, since I knew some software and devices aren't updated yet for Windows 10.


Long story short, I did update the software after installing, still no signal. I made sure all connections to VCR were correct. I had Customer Support send me a copy of the Windows 10 64 bit program update AND the device driver installer package (you will need these). I still could not get it to work. As Customer Support was walking me through the driver install, I notice that the Capture Device kept coming up as Dazzle....not Roxie. After following a couple of Topics on this forum, I had tried uninstalling the Dazzle drivers with the capture unit attached, disconnected it, and then rebooted the laptop. I reinstalled the drivers several times, including downloading them again after turning off my anti-virus/firewall, and then turning off my Wi-Fi. I spent about a week trying to get this sucker to work!


I noticed that Dazzle Capture Device was coming up under 'Audio', 'Sound, video, and game controllers', both stating that the device was working properly. But it was also coming up under "Other Devices", but with a yellow warning "no driver for this device". I also noticed that when I went to install the Roxie 64 bit drivers, that the Roxie driver selection was coming up with a Red X after I had selected Modify during the installation process. So here is what I did


1. Installed the Windows 10 64 bit driver again, but changed the Red X to Install on Hard Drive. There is a second driver listed, but that one was already selected to install.

2. Rebooted.

3. Attached the Roxie USB Capture Device to my VCR cables (output), and then to a 2.0 USB port on the laptop. I had a tape in the VCR ready to go.

4. Opened Device Driver, selected the Dazzle USB Capture listed under 'Other Devices', right clicked, selected Update Driver.

5. I chose the options: 'Browse my computer for software drivers' > ' Let me pick from a list of device drivers from my computer'.

6. I then selected the Manufacture: Corel, and the Model: Roxie Video Capture USB, and installed the driver.

7. The device item changed the Dazzle Capture to Roxie Capture, and moved from 'Other Devices' to ' Sound, video, and gamming devices' list, now showing that it was working..

8. I left the other two Dazzle Video Capture USB Audio Device items alone. So Device Manager still has Dazzle USB Capture under 'Audio' and 'Sound, video, and game controllers'.

9. I then started to play my VCR tape, and opened the Roxie VHS to DVD 3 Plus software, selected either record option, and TADA!!!....I got video (and audio)!!!! I still needed to tweak the video enhancements...but it works!


I just wanted to say thanks to the Digital Guru's who support the Roxie VHS to DVD 3 Plus forum. Your suggestions on other posts really helped me a lot!







Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Ouch! That is a lot of work for a simple fix...


The problem is created when you plug in the Capture USB device before you install the software. Windows (all versions) will detect it and automatically install the wrong driver :unsure:


Since it thinks it is the "right driver", it will always report it is working OK.


Disable/Uninstall the driver, remove the device and hide it from the PC, then reboot and run a Repair with the software.


Note to self: Never plug in any USB device without checking the instructions! Most are plug-n-play but some are plug-n-weep ;)

Link to comment
Share on other sites

  • 0

Actually, I did run the software first, and the update. The only thing I can think of that I might have done wrong was initially installed the device in a 3.0 USB port instead of the 2.0 USB port. It wasn't until after contacting Support, that I kept seeing the Dazzle Capture listed in Device Manager. All Support suggested was to apply the Windows 10 update and Driver Installation package that they emailed me. It wasn't until I saw the Forum suggestions, that I tried to start over from scratch.....including putting the device in "another room, away from the computer"!! :)


And yes, this was a lot of work.....but I'm just glad I finally got it to work! Thanks, guys, for all the information you had given on the other posts. It really helped!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...