Jump to content
  • Who's Online   0 Members, 0 Anonymous, 15 Guests (See full list)

    There are no registered users currently online

  • 0

Toast Dvd Crashes On Mbp With Usb Superdrive On Sierra


I have just purchased Toast DVD today off the App store and have tried several times to burn some .MOV files to a DVD but once Toast DVD is done encoding the files and is about to start the burn it crashes.


I have a 2014 MBP running Sierra and a USB Superdrive (and have tried several new DVD's).


The little apple dialogue box also pops up again when its about to burn the DVD as it crashes, i.e. select normal action when DVD is inserted despite the blank DVD already being in the drive.


Roxio please advise on how to resolve this issue as i need this working ASAP and have just paid 20 GBP for it an so am currently very disappointed and frustrated.


If you do not have a fix please advise on how i can get my money back.





Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now