Jump to content
  • Who's Online   0 Members, 0 Anonymous, 12 Guests (See full list)

    • There are no registered users currently online
  • 0

Cannot Get Roxio To Connect But Is Lighting Up? Xbox One



So I have followed the diagrams that Roxio has given out but this doesnt seem to lead me to a final solution.


My xbox one is linked by hdmi to my capture card - my capture card is linked up by usb cable to my pc - i have another hdmi coming out to my tv.


My capture card is lighting up so I know that it is powered on/working. I have OBS set up on my pc (I have other similar programs if anyone can point out to an easier one) but OBS/my pc is not recognising the capture card as it does not appear on device manager. After a couple of hours of fiddling around with different ports and connections I am at a loss.



I tried to contact support but they were unable to help. Am i missing something?






(Can provide images if needed)

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

It should not come as a surprise that Roxio does not offer any suggestions or support for software (OBS) they didn't write :wacko:


If you use try it in conjunction with the software that came with it, we should be able to help you with it. From there it should work with OBS -_-

Apologies for the late reply, I have been away.


I didnt originally use OBS, but after some googling saw a lot of other people using it so I thought it could be a fix to my issue.


I am still having the same issue when using the Roxio software.

Link to comment
Share on other sites

Go into your Xbox display settings and manually set it for either 1080i or 720p output (auto-detect doesn't work properly with the RGC HD Pro).

Manually setting the output to 720 or 1080 should override the auto-detect.


The settings in the link below are for when you are connected directly to your your TV, but you are hooked up to the Roxio unit, not the TV.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...