Jump to content
  • Who's Online   0 Members, 0 Anonymous, 13 Guests (See full list)

    • There are no registered users currently online
  • 0

Toast 11 Titanium With Mac Os 10.6.8



I have been using Toast 11 Tit. successfully for many years on my Mac Pro with OS 10.6.8. Several days ago it refused to open at all repeatedly giving the report attached.

After removing the Application as per Roxio's instructions together with all prefs etc. AND Repairing Permissions on my system drive, and then re-installing from scratch from my Toast 11 T disc A NUMBER OF TIMES,

the same thing happens every time. So Toast is unusable for me at present.

I'm prepared to accept that I'm missing something; I've been in the game too long to be proud any more, but is there anyone out there who can help me work out what the problem is?





Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 1

Do check if you have removed both the important Roxio preference files prior to re-installing. Snow Leopard didn’t hide the ~/Library folder by default yet, so this should be fairly easy. (These two files will be re-created freshly on the next launch.)

~/Library/Preferences/Roxio Toast Prefs

There are other files if you want to be thorough in removing any trace, but they shouldn’t interfere with the launch of the main Toast app.
/Library/Application Support/Roxio/ ( ← not sure if either or both Application Support folder was used)
~/Library/Application Support/Roxio/ ( ← not sure if either or both Application Support folder was used)
~/Library/Saved Application State/com.roxio.Toast.savedState/ ( ← only 10.7 Lion and later)
There may be even more caches and temp files, but those shouldn’t be accessed at launch, especially after a reboot.
Do try to launch Toast without any peripherals attached (unplug anything non-Apple).
Did you install/update software with firmware, drivers, kernel extensions, codecs, or something similar that Toast may notice? New devices or PCI-cards present?
Can you create a new user and install Toast under that account? Will it launch then? If so, then the issue HAS TO BE specific to the old account (and not Mac OS X or the Roxio software), so you know where to look/narrow it down.
I won’t claim to be able to read a crash log, but I did notice “EXC_BAD_ACCESS (SIGBUS)”, which I’ll use as a lead.
(From the Apple Support Communities [1]) A SIGBUS exception is typically caused for one of two reasons — either the presence of a bug in the software in which it occurred, or the presence of faulty RAM. Have you tried running your Mac’s Apple Hardware Test, to see if it can detect any problems with its RAM? (Note that the AHT cannot detect all possible RAM defects, so even if it is unable to identify a problem, that isn’t a guarantee that no problem exists.)
RAM modules have no moving parts, so if they go bad, it is probably from an electrical charge. Do you know of a recent power surge? Has the Mac been open, could the RAM modules have been touched by someone with a static charge? Is your Mac very dusty inside? (If the issue is RAM, then I would expect that you would also notice crashes outside of Toast.)
Or suppose your ‘dyld shared cache’ was altered by anything else than an Apple installer or updater. Then a sudo update_dyld_shared_cache -force (+ reboot) may get things right again for this application to launch without crashing.
Link to comment
Share on other sites

  • 1

Hello again the old archiver,

Regarding my problem of MOTU/Digital Performer crashing Toast, I hope I may have found the cause. 

I believe there was a problem with not having the latest MOTU drivers. I had another anomaly independent of Toast. For some while(several months) I had been unable to update Digital Performer to v9.5. The update would simply not open. Whilst trying to correct this I downloaded latest MOTU drivers. This cured the problem and allowed v9.5 to open and run. 

Guess what!? Yes, Toast is not now upset by Digital Performer or its hardware.

So this is just to let you know that one of your suggestions (re drivers) was spot on. Many thanks for your help......


Link to comment
Share on other sites

  • 0

Thanks theoldarchiver.

Ive tried trashing prefs etc as you suggest, and reinstalled Toast from it's disc, but problem still happens.

Also opened another account and same thing happens.

So I have experimented further...

I can now say more accurately what the symtoms are. When launching Toast 11 it refuses to open at all (it does not crash once it's open). That may seem contradictory but I can explain; by switching off my audio periferals (MOTU 2408, MOTU HD 192) before booting up the computer, Toast launches fine. I can then switch on the two interfaces and Toast continues to be fine. But do a Restart and Toast will not run again until I've restarted without  the 2408 and 192. This wasn't like this for many years, but has happened recently. I can live with this situation as long as it doesn't deteriorate further.....

But I would dearly like to know the cause. I should add that I've got two other audio periferals - a MOTU Midi Timepiece amd a Behringer ProGain (lightpiped to the 2408). But these don't seem to effect Toast on power-up in the same way as the 2408 and 192.


Link to comment
Share on other sites

  • 0
9 hours ago, DaveJH said:

This wasn't like this for many years, but has happened recently. […] But I would dearly like to know the cause.

Something must have changed between then and now, to trigger the error now. And some (running) software probably has a bug regarding memory pointers. It might be a reason to look into the installation of the MOTU drivers (have those been updated/are there new updates for your setup to apply/can they be verified?). Perhaps their support staff or forums know better how to isolate this issue?

Link to comment
Share on other sites

  • 0

Hi theoldarchiver,

Appreciate your reply. I'm not sure I'm getting anywhere!

I booted up using a Guest user account and at first all was well, Toast launched few times(maybe 6) then refused to launch completely.

I went back to my main user account, same thing - refused to launch repeatedly. Next I disconnected everything non Apple (3 external USB drives and four audio interfaces using FireWire) and booted up again.

Hey presto! Toast launched ok.

So I remounted each drive(verifying with Disc Utility that each drive was ok), then switched the audio interfaces on again. I did this one device at a time checking that Toast launched ok each time. At the end of this everything was connected again, and Toast was ok. However, a restart with everything connected was followed by repeated refusal of Toast to launch.

At the moment I am finding that my audio interfaces do effect whether Toast will launch or not!

Sometimes, I can switch one of the four interfaces off and Toast will then launch, but it's not always the same one! Sometimes after a successful launch of Toast with one interface off, switching it on again does not cause it to fail to launch. It's all inconsistent; but a restart nearly always causes problems! I should say that once Toast has launched ok, it doesn't seem to crash - it's always on LAUNCH that there's a problem with a failure report generated like the one I sent you. The SIGBUS line is always the same though.

Not sure what's next......



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...