Jump to content
  • Who's Online   0 Members, 0 Anonymous, 17 Guests (See full list)

    There are no registered users currently online


Toast 19 Pro Blu-Ray-Authoring crash Toast

Recommended Posts

Hi folks,

it seems that the support ( engineering ) has found a solution to solve the problem.

I received the following e-mail from support regarding my ticket :


It suddenly worked because engineering fixed the problem 

Due to the recent communication this support ticket will be closed.  



What the engineering has changed, I cannot say, although I had asked to be told what was found out.

Nevertheless, a change seems to have been made by Roxio.

So just try it out, who didn't manage to unlock it by himself.



Share this post

Link to post
Share on other sites

I had been working with Corel support for the last week sending them crash dumps, what other people said to try on the forum (giving credit to those people), etc.  Last night I got this message, but I had not tried it since I was able to get my driver activated using what user Loby suggested.  I post this here for closure.  Thank you all!



Oct 8, 2020, 2:20 EDT 

Mr. / Ms. 

Thank you for contacting Corel Technical Support. 

I'm really sorry, The issue has been reported to our engineering team and they have resolved the issue with the activation, kindly try to activate the plugin in regular method once, If it is not activated yet, let us know how it goes.

Please do not hesitate to contact us with any further questions. 


Corel Customer Support Services 




Oct 7, 2020, 3:25 EDT 

While this is not an acceptable solution, this user below figured out how to activate the Blu-ray Driver. I followed his instructions and was able to active the driver on my computer. Please use this information to help you develop a real fix for this issue. Thanks!

Hi Tom W, 
Loby <https://forums.support.roxio.com/profile/134957-loby/> has posted a comment on a topic, Toast 19 Pro Blu-Ray-Authoring crash Toast <https://forums.support.roxio.com/topic/124701-toast-19-pro-blu-ray-authoring-crash-toast/> 

Loby said:
I figured out what the problem is and hope Roxio looks at this post. 

I will send in the solution to support and hopefully they will take a look to send out an update. After much trouble shooting (they should pay me) and staying up until 2am (I need this to work) the issue is with the actual wi-fi activation. I was able to enable blu-ray authorization by tottering the wi-fi off and on while you activate the blu-ray activation selection.

1. First have your wi-fi on.

2. Then open up Toast 19 Pro

3. Select the Blu-ray Activation in the Help Menu

4. Turn off your wi-fi.

5. Then try to activate

6. Message says that you do not have your wi-fi on, do you want to try again.

7. turn on your wi-fi

8. Then try activating it again and hit "ok" - BUT immediately turn of and on your wi-fi while it is trying to activate. - You may have to do something like this a few times to get it to activate.

Then it will activate eventually. You may have to do this a few times. I did this method on two Macs (Mac Pro 2013 and 15" MacBook Pro 2018) and it worked.

Corel/Roxio: Please find a solution, talk to Apple if you have too. And give us an update with a patch!!!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now