Jump to content
  • Who's Online   0 Members, 0 Anonymous, 13 Guests (See full list)

    There are no registered users currently online

  • 0
rjonesNP

Easy VHS to DVD 3 Plus not installing on Windows 10 PC as a Domain User

Question

I struggled to install Easy VHS to DVD 3 Plus on a Windows 10 PC for a few hours. This was on a Domain connected PC, and i was trying to install it as a Domain Admin. I had an issue where once I got the drivers for the USB device installed, I could not install the application. The .exe would launch, but it would pop up with Checking for updates..., then moved to Downloading updates... really fast then it would go away, then nothing. The installer would immediately stop. I tried to drill down into the install files on the disk and see if I could get the core program installed, and worry about updates after, but it would just direct me to run the Updater first. I originally suspected my ORGs firewall or my AV was the issue, but it does not seem to be. Here are the steps that finally worked for me:

 

1. Log in as your ORG's Local admin account. This is what finally worked, when everything else did not. 

2. Install the Roxio Video Capture USB device drivers. Windows did not find the drivers for me. I found them here: https://support.corel.com/hc/en-us/articles/215877318-Driver-for-Easy-VHS-to-DVD-3-Plus-device

3.  Run the install file (Can be downloaded here: https://www.roxio.com/en/pages/download/)

4. If you still have issues, turn off the Antivirus and try an external network (I used a hotspot to see if my network was blocking it.

 

 

 

Roxio - checking for updates.png

Roxio - downloading updates.png

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Roxio's software is always supposed to be installed to an administrator account.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×