Jump to content
  • Who's Online   0 Members, 0 Anonymous, 10 Guests (See full list)

    There are no registered users currently online

  • 0
Sign in to follow this  
girwin

No Sound on DVD MPEG-1 in Toast 7

Question

Hello,

 

I recorded some TV shows with EyeTV 1.8.5 on Mac OS 10.3.9 and edited the resultant files with Quicktime Pro, giving me muxed MPEG-1 files. Foolishly, I deleted my original EyeTV files. I was getting an error -2009 when I tried to burn a video DVD. I upgraded to Toast 7.0 and the error is gone and the DVD burns, but there's no sound! There is sound playing in Toast when I test the file before burning. What next?

 

Thanks,

Graham

Share this post


Link to post
Share on other sites

24 answers to this question

Recommended Posts

  • 0

It is possible that the audio is on the DVD but the DVD player isn't playing it.

 

Insert the DVD and select DVD with the top button of the Toast Media Browser. When the DVD shows up in the lower window, go down one level with the lower button. Now put the cursor over the video title and wait a couple seconds. Text should appear that describes the title's video and audio format. What does it say?

 

If you don't see the text, drag the title to the video window, select it in the video window and click Edit. The window that opens will describe the video and audio format.

Share this post


Link to post
Share on other sites
  • 0

The popup says:

 

Video: MPEG-1 NTSC 352x240

Audio: MPEG Stereo, 48000 Hz

 

But there's no files in the AUDIO_TS folder

Share this post


Link to post
Share on other sites
  • 0
The popup says:

 

Video: MPEG-1 NTSC 352x240

Audio: MPEG Stereo, 48000 Hz

 

But there's no files in the AUDIO_TS folder

The AUDIO_TS folder is always empty, even on your commercial DVDs. The audio is multiplexed with the video. You have MPEG audio on the DVD. There are many DVD players that need to have their setup adjusted to convert MPEG audio to PCM in order for you to hear the audio. This is in the player's setup. There should be instructions on doing this in the player's manual.

 

If you have MPEG Streamclip I think you can have these MPEGs "demuxed" into separate video and audio streams, and have the audio stream converted to AIFF. If you do that and drag the video stream to Toast (it will automatically add the audio or ask you for it) then you can get a DVD with PCM or AC3 audio which all players will use without making any special set-up settings.

Share this post


Link to post
Share on other sites
  • 0

Aha, thank you!

 

Which format(s) should the file be demuxed to?

 

Also, when I open the .mov file in Streamclip, it loses my edits (the entire original file is there). Is there anything to be done about this, or another approach?

 

Thanks,

Graham

 

PS - You seem quite worthy of your username - nice car too!

Share this post


Link to post
Share on other sites
  • 0
Aha, thank you!

 

Which format(s) should the file be demuxed to?

 

Also, when I open the .mov file in Streamclip, it loses my edits (the entire original file is there). Is there anything to be done about this, or another approach?

 

Thanks,

Graham

 

PS - You seem quite worthy of your username - nice car too!

I wish I had a prize for you. You're the first person to mention the car. I bought the 1958 Healey in 1972 so it's been part of the family longer than my now-adult children.

 

It's been awhile since I fussed with that MPEG format so I'm not certain which steps to follow with those. After you edited in QuickTime Pro you should have saved the video as a full-quality movie instead of as an MPEG 1 file. That way Toast would have encoded the video and audio to the standard DVD spec.

 

You can open in Streamclip a VTS title set directly from the Toast-burned DVD you made. Then choose Demux to m2v and AIFF from the Streamclip File menu. I think this will get you the separate MPEG video and PCM/AIFF audio streams you need. The goal is to convert the MP2 audio to AIFF. As I noted earlier, just drag the video file to Toast.

Share this post


Link to post
Share on other sites
  • 0

I thought that was a Healey - very cool!

 

When you say "After you edited in QuickTime Pro you should have saved the video as a full-quality movie instead of as an MPEG 1 file." I assume you mean exported, since QT Pro only gives the option of saving as a self-contained movie or a referenced movie. I certainly can export it as a number of things (though it takes forever) - which is the best format?

 

I will try to demux the dvd first.

 

Thanks,

Graham

Share this post


Link to post
Share on other sites
  • 0
I thought that was a Healey - very cool!

 

When you say "After you edited in QuickTime Pro you should have saved the video as a full-quality movie instead of as an MPEG 1 file." I assume you mean exported, since QT Pro only gives the option of saving as a self-contained movie or a referenced movie. I certainly can export it as a number of things (though it takes forever) - which is the best format?

 

I will try to demux the dvd first.

 

Thanks,

Graham

You're right, it does take forever so maybe it's best just to stay with your method with the exception of finding a way to convert the MPEG 2 audio to AIFF using Streamclip.

 

The best quality format for QuickTime export would be Full Quality movie, but the additional conversion and re-encoding by Toast will result in lesser quality video than keeping the video stream as is. Sorry for confusing the situation with my earlier bogus suggestion.

Share this post


Link to post
Share on other sites
  • 0

Okay, I ran the "silent" DVD content through MPEG Streamclip and demuxed to m2v and AIFF. I dragged the video file into Toast and was not prompted for the audio, nor does it seem to have automatically included it as this DVD is "silent" too! The audio now says "PCM Stereo, 48000 HZ, 16 bit." Any thoughts? Also, I have quite a few files to burn and it would be a shame to have to burn a DVD each time just to demux it and burn another - any other thoughts on how to do this?

 

Thanks,

Graham

 

PS - The MPEG-1 files came from EyeTV USB, which can only produce those I think.

Share this post


Link to post
Share on other sites
  • 0
Okay, I ran the "silent" DVD content through MPEG Streamclip and demuxed to m2v and AIFF. I dragged the video file into Toast and was not prompted for the audio, nor does it seem to have automatically included it as this DVD is "silent" too! The audio now says "PCM Stereo, 48000 HZ, 16 bit." Any thoughts? Also, I have quite a few files to burn and it would be a shame to have to burn a DVD each time just to demux it and burn another - any other thoughts on how to do this?

 

Thanks,

Graham

 

PS - The MPEG-1 files came from EyeTV USB, which can only produce those I think.

What happens when you play the AIFF file in QuickTime that MPEG Streamclip exported. Is there no audio present in that file?

 

Not prompting for the audio is normal when the audio has the same file name as the video (except for the extension) and is in the same folder. The audio file was added because you say Toast reports that it is present.

 

I don't have an EyeTV but I thought the EyeTV software included an MPEG editor. Maybe it didn't in the USB version.

 

We'll solve this eventually. But I need to go bowling now.

Share this post


Link to post
Share on other sites
  • 0

The AIFF file makes no sound when I play it in Quicktime.

 

EyeTV probably does have an editor and, I think, a hook to Toast, but I was not aware of either before I edited these files and deleted the EyeTV files - back when I was young and my heart was an open book and I believed this video editing stuff was straightforward and "logical." :-)

 

Good luck bowling,

Graham

Share this post


Link to post
Share on other sites
  • 0

Since there is no sound in the AIFF file we need to go back to a version where the audio was still present. Drag that MPEG file in which you still heard audio to the Toast Video window, select it and click the Export button at the bottom. There is an option to save the audio only as AIFF. Choose that. When it is done try playing that AIFF file. Is there sound? If so, I'll explain some next steps.

 

P.S. I've been in a small slump with bowling lately. Last night showed some improvement.

Share this post


Link to post
Share on other sites
  • 0
Since there is no sound in the AIFF file we need to go back to a version where the audio was still present. Drag that MPEG file in which you still heard audio to the Toast Video window, select it and click the Export button at the bottom. There is an option to save the audio only as AIFF. Choose that. When it is done try playing that AIFF file. Is there sound? If so, I'll explain some next steps.

 

P.S. I've been in a small slump with bowling lately. Last night showed some improvement.

 

Good to hear about the bowling upswing. I tried exporting the audio only from Toast by selecting "for Itunes" in the export options. Is this correct? Toast crashed twice...

 

Graham

Share this post


Link to post
Share on other sites
  • 0
Good to hear about the bowling upswing. I tried exporting the audio only from Toast by selecting "for Itunes" in the export options. Is this correct? Toast crashed twice...

 

Graham

That was an ungraceful way for Toast to say "Don't ask me to do this!"

 

In the Formats button in the Export window, scroll all the way to near the end. That's where the AIFF option is. The iTunes option encodes to AAC format, but that can't be done directly from the MP2 format that you have now.

Share this post


Link to post
Share on other sites
  • 0

You are too patient - anyhow, the resultant aiff file is "silent." The original MPEG-1 plays with sound in QT Pro and in Toast's editor...

 

Thanks,

Graham

Share this post


Link to post
Share on other sites
  • 0
You are too patient - anyhow, the resultant aiff file is "silent." The original MPEG-1 plays with sound in QT Pro and in Toast's editor...

 

Thanks,

Graham

Okay, now I'm stumped. I just created a similar MPEG video and exported its audio to AIFF with the sound intact. What if you take the original MPEG-1 into Streamclip and choose Demux to M2v and M1A? Does the resulting M1A play audio in QuickTime?

Share this post


Link to post
Share on other sites
  • 0

Yes, the audio plays in Quicktime, but as I mentioned before, all my edits are gone - the video has reverted to its original form. I am not thrilled by this as it costs me a few hours of deleting commericals. If this is necessary, how would I re-edit the separate audio and video files yet keep them sychronized?

 

Thanks,

Graham

Share this post


Link to post
Share on other sites
  • 0
Yes, the audio plays in Quicktime, but as I mentioned before, all my edits are gone - the video has reverted to its original form. I am not thrilled by this as it costs me a few hours of deleting commericals. If this is necessary, how would I re-edit the separate audio and video files yet keep them sychronized?

 

Thanks,

Graham

Edit the long version (the one with sound) in MPEG Streamclip and then choose Demux to M2V and AIFF to save your edited version. Drag the resulting M2V to Toast. My expectation is it will all work. The problem I think is that you edited in QuickTime Pro and it doesn't cut and save that kind of audio properly.

Share this post


Link to post
Share on other sites
  • 0

OK,

 

I re-edited the file in StreamClip (nice program BTW) and demuxed to m2v and aiff. All seemed well until I dragged the m2v into Toast and tried to burn it. Twice I got "The drive reported an error: Sense Key = ILLEGAL REQUEST Sense Code = 0x21, 0x02 BUFFER UNDERRUN" The unfinished DVD did seem to play properly however. In other curiousities, I think it said "encoding" on the first burn and "multiplexing" on the second.

Share this post


Link to post
Share on other sites
  • 0
OK,

 

I re-edited the file in StreamClip (nice program BTW) and demuxed to m2v and aiff. All seemed well until I dragged the m2v into Toast and tried to burn it. Twice I got "The drive reported an error: Sense Key = ILLEGAL REQUEST Sense Code = 0x21, 0x02 BUFFER UNDERRUN" The unfinished DVD did seem to play properly however. In other curiousities, I think it said "encoding" on the first burn and "multiplexing" on the second.

If Toast says it is encoding your existing MPEG video, then go to the custom encoder settings window and change the setting for Re-encoding to Never. It should only need to multiplex the MPEG.

 

Buffer underrun shouldn't happen because I bet you have buffer underrun prevention turned on in the Recorder Settings window. All I can suggest for that is trying different media or burning at a slower than Best speed.

Share this post


Link to post
Share on other sites
  • 0

Eureka!

 

The buffer underrun protect was not checked - I have a working DVD! Thank you so much for your invaluable advice. It seems that EyeTV's MPEG-1 format is a difficulty (I see that their newer products work in MPEG-2). What is your suggestion for the best way to digitize video (broadcast or videotape) for editing and burning to DVD?

 

Thanks,

Graham

Share this post


Link to post
Share on other sites
  • 0
What is your suggestion for the best way to digitize video (broadcast or videotape) for editing and burning to DVD?

 

Thanks,

Graham

The current models of EyeTV and the other products that use EyeTV's software (such as Miglia) are the easiest way to go. Direct encoding to MPEG 2 is best for video DVD quality and ease as long as you have software for doing basic cutting of unwanted content.

 

ElGato and Roxio closely work at making EyeTV's software work well with Toast.

Share this post


Link to post
Share on other sites
  • 0

Thanks again, and Happy Holidays!

 

Graham

 

PS - One last question, not totally on topic. I have encoded some largish video files on an external hard drive and would like to move them to another larger hard drive but everytime I try to copy them I get an error 36 - do you have any idea how to remedy this?

Share this post


Link to post
Share on other sites
  • 0
Thanks again, and Happy Holidays!

 

Graham

 

PS - One last question, not totally on topic. I have encoded some largish video files on an external hard drive and would like to move them to another larger hard drive but everytime I try to copy them I get an error 36 - do you have any idea how to remedy this?

You're welcome.

 

I don't know about your file transfer problem, but if it is due to one of those quirky Firewire and USB issues that appear after doing an incremental system update, I suggest downloading and applying Apple's Combined System Update because that often fixes those mysterious problems. Won't hurt to give it a try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×