Jump to content
  • 0

Trouble Downloading



8 answers to this question

Recommended Posts

I have exactly the same problem! It finishes downloading at 4 mb, and gives a corrupt zip file. I tried in Safari and Firefox with SpeedDownload disabled and firewall off, no anti-virus. Now when I try, it tells me I have downloaded it to many times, and I am locked out! Infuriating, as I now have to ring the US at my own expense at a stupid time for me due to timezones to request a new download link. Nobody has got back to me from Customer Services either, despite several emails.

Link to comment
Share on other sites

Hi guys,


spoke to the guys at Roxio, and they told me to turn off firewall and and download managers. Same problem. They then told me to call Digital River (and gave me the wrong number) who told me they don't support Safari or Firefox. Bizarre that downloading software for Macs isn't supported on the 2 biggest Mac browsers! I tried to point out that microsoft have pulled all download links for Internet Explorer, which is what they told me I should use. I managed to get hold of a copy, and no difference, still 4mb! In the end I managed to get it by using a download manager (speed download) which forced it past the 4mb mark. The only problem is that it locked out at 50% with the dowmloaded to many times error. I just had to keep ringing digital river and getting them to up the limit - 130 was what finally got it! Now have it working though, so persevere! The download manager let me pick up where the download had stopped, so it took 4 attempts with the number of download limit being upped over the phone each time. Hope this is of help! I was told by Roxio that I should ask Digital River for a new download link which would solve the problem, but they weren't too keen to do this. Phone number for Digital River is 1800-253-8300 or 1800-656-5443, Roxio is +353-6170-2059. If your like me and don't live in the US, it costs a fortune to call.


Good luck, and keep posted on how you get on!



Link to comment
Share on other sites

It says that it can't decompress. Only lets me download 4m. Then it gives me this error. I love Toast. I'd buy it if it cost more. But I do want to download what I buy. And I can't.


On the fifth try it worked like a charm. I purchased to download insurrance. I think that their server might have had a problem.


I stopped, restarted my computer - PowerBook G4 - worked on something else a few hours. It helped. Then it worked.


I'm currently overseas too. Call the guys on Skype.

Link to comment
Share on other sites

Guest ivanatrox

sounds like bandwidth problem with the ISPs since the download stopped at different sizes (4MB, 60MB, 100MB, 120MB)... I have tested the verified the download from an Toast 8 order at home last night as well as in the office just now and did not experience any issues... the download count can be easily increased if you contact our Customer Service department... also, please make sure no download manager or firewall, say NetBarrier, is used...

Link to comment
Share on other sites

Same problem for me, very slow download, then tells me it's a corrupted file and won't decompress. I have tried with both Safari and Firefox, same result. Firefox tells me it's a 140 mb file, is that before or after decompression ? as my file is around 60mb when it finishes downloading.

Link to comment
Share on other sites

:) I am having the same problem with downloading. The server returns an error that I have exceeded my Max download count. My Firefox 2.0 browser folded once. (happened to be the first attempt at the download was about 120mb through the dl and bam - gone)


Now every time that I try to DL I get the error message.



Too many download attempts: 30. You were allowed to download only 20


If you have any questions, please contact Digital River Customer


at CustomerServices@digitalriver.com.


I have tried to contact the digitial river support, via there online forms and direct email to the CustomerServices@digitalriver.com and webhelp@digitalriver.com and have only recieved an automated response telling me to try to reinstall browsers and such.


I have tried Safari as well, same result. Also tried Firefox 1.5 on a seperate machine and network, same result.


I just want to download and start using!


Does anyone know a number that we can physically call and talk to a real person?



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...