Jump to content
  • 0

My DVD anomaly


johnata

Question

Is anyone else having trouble with this scenario?

 

1) Start up My DVD

2) Add a movie

3) Preview movie

4) In preview screen, click play - movie plays

5) Stop movie

6) Click play again or click menu

 

On my system, videowave9 starts using up 100% of the CPU causing problems. Most of the time, killing My DVD gets you back the CPU.

 

-- John

Link to comment
Share on other sites

14 answers to this question

Recommended Posts

You got the explanation

 

I'm missing the logic of your statement - if it was simply that rendering was CPU intensive, why don't I get the hourglass/CPU cycles/hang the first time I play the movie? When I said explanation, I meant something logical. I would be greatful if you could explain why an intensive CPU operation only occurs on the second time I play a movie and not the first and this is not considered a bug. There is a saying that insanity is when someone tries the exact same thing twice and expects different results. Surely, this software is sane! ;-)

 

-- John

Link to comment
Share on other sites

I know it sounds odd, but what video card do you have? Videowave/MyDVD is the only video editor that I know that can take advantage of the GPU on the video card. When it comes to these two apps, you really need a good video card that supports DirectX 9.

 

I have a NVidia Geforce4 TI4200 with 128M of memory from Gateway. I am running DirectX 9c. I was also getting the warning about updating the video driver. Although Gateway did not have a video driver update, I checked the NVidia site which had a recently updated driver so I installed it. This problem appears to have been solved. :) I can now start and restart a preview/play without having to leave the preview screen. It does blow my mind that an older video driver would cause this behavior though. Thanks very much for your help...

 

P.S. I have one more question on a different note but I'll start another thread.

 

-- John

Link to comment
Share on other sites

First of all - are you talking about WATCHING a movie or are you talking about RENDERING it?

 

Watching - that's nothing to do with EMC

 

Rendering is EXTREMELY CPU intensive - you don't get the hourglass simply because the program is NOT locked up or waiting - it's doing what you asked it to do and that WILL take up 100% CPU cycles.

 

It can (and usually does) take at least the full duration of the movie to render - possibly slightly longer and while that is happening, you can't do anything else

Link to comment
Share on other sites

Sounds like from the first post that he is talking about the DVD PREVIEW button. I can't reproduce the problem. I can stop and start the preview as much as I like.

 

John - are you talking about the buttons below? On my machine, the preview must be rendered before I can see it, but that doesn't take long. Once the proxy files are created, Videowave shouldn't be taking a lot of CPU time.

post-49-1169742798.jpg

Link to comment
Share on other sites

Glad this annoying problem was fixed. However at some point, you may want to consider a newer video card. If I remember correctly, the TI4200 (came out abt 2002) was designed for DirectX8 so it can never support the newer DirectX 9 3D commands. Have you ever run the graphics test in Videowave/MyDVD? I would be surprised if it defaulted to hardware.

Link to comment
Share on other sites

Glad this annoying problem was fixed. However at some point, you may want to consider a newer video card. If I remember correctly, the TI4200 (came out abt 2002) was designed for DirectX8 so it can never support the newer DirectX 9 3D commands. Have you ever run the graphics test in Videowave/MyDVD? I would be surprised if it defaulted to hardware.

 

Actually, even with the old driver and the warning, the graphics test defaulted to hardware which is why I didn't think to update it. FWIW. I just tried it with the updated driver and it does indeed also default to hardware after the graphics test finishes. I usually never update just my graphics - probably within the next year I will just buy a new PC which will have a graphics card that will be in the same boat 4 years later! :)

 

-- John

Link to comment
Share on other sites

It does that on all systems

...

This isn't a 'bug' in the Roxio program - all video rendering is the same

 

So the fact it plays the first time without going into a CPU loop but the second time (after stopping and restarting) I get the hourglass while videowave9 loops at 100% is not a bug? I can avoid this problem as long as I don't hit play again but leave the preview screen and reenter. This doesn't seem right to me but if there's an explanation, I'd certainly like to hear it.

 

-- John

Link to comment
Share on other sites

You got the explanation

 

Rendering DOES take up all the CPU cycles - which is why commercial rendering is done on computer farms - banks of multi-processor machines with loads of RAM and even then it's slow

 

You are running, at best, a dual core machine - it will take everything that can give and use it

Link to comment
Share on other sites

As far as Directx 9 compatiblity goes, I get the following when running the DirectX tests (run/start/dxdiag)...

 

---------------

Display Devices

---------------

Card name: NVIDIA GeForce4 Ti 4200

Manufacturer: NVIDIA

Chip type: GeForce4 Ti 4200

DAC type: Integrated RAMDAC

Device Key: Enum\PCI\VEN_10DE&DEV_0253&SUBSYS_87031462&REV_A3

Display Memory: 128.0 MB

Current Mode: 1024 x 768 (32 bit) (85Hz)

Monitor: Gateway VX730

Monitor Max Res: 1280,1024

Driver Name: nv4_disp.dll

Driver Version: 6.14.0010.9371 (English)

DDI Version: 9 (or higher)

Driver Attributes: Final Retail

Driver Date/Size: 10/22/2006 12:22:00, 4527488 bytes

WHQL Logo'd: Yes

WHQL Date Stamp: n/a

VDD: n/a

Mini VDD: nv4_mini.sys

Mini VDD Date: 10/22/2006 12:22:00, 3994624 bytes

Device Identifier: {D7B71E3E-4113-11CF-4953-09A702C2CB35}

Vendor ID: 0x10DE

Device ID: 0x0253

SubSys ID: 0x87031462

Revision ID: 0x00A3

Revision ID: 0x00A3

Video Accel: ModeMPEG2_A ModeMPEG2_B ModeMPEG2_C ModeMPEG2_D

Deinterlace Caps: {212DC722-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(YUY2,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive

{212DC723-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(YUY2,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_MedianFiltering

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(YUY2,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

{212DC722-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_PixelAdaptive

{212DC723-3235-44A4-BD29-E1652BBCC71C}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_MedianFiltering

{335AA36E-7884-43A4-9C91-7F87FAF3E37E}: Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0) Caps=VideoProcess_YUV2RGB VideoProcess_StretchX VideoProcess_StretchY DeinterlaceTech_BOBVerticalStretch

Registry: OK

DDraw Status: Enabled

D3D Status: Enabled

AGP Status: Enabled

DDraw Test Result: All tests were successful.

D3D7 Test Result: All tests were successful.

D3D8 Test Result: All tests were successful.

D3D9 Test Result: All tests were successful.

Link to comment
Share on other sites

It does that on all systems

 

Video rendering is VERY CPU intensive and that just goes with the territory

 

When rendering the best thing to do is shut down ALL running apps, start the render and go watch TV while it does its thing

 

This isn't a 'bug' in the Roxio program - all video rendering is the same

Link to comment
Share on other sites

I'm sure that nVidia has made the drivers DirectX 9 'compatible' so the test would indicate that. I'm just saying that DirectX 9 has extended the commands from V8 and it is those commands the TI4200 probably does not support. One way to test the card, create a short Videowave project with several still images at 10 sec each. Add a 3D transition between them @3 seconds each. Then 'Output to File'. If it renders, then you should be ok.

Link to comment
Share on other sites

John - are you talking about the buttons below? On my machine, the preview must be rendered before I can see it, but that doesn't take long. Once the proxy files are created, Videowave shouldn't be taking a lot of CPU time.

 

That's it exactly! I just click the stop button (arrow on left) and either click play (arror on right) or menu. It then starts to spin. Not sure why. I think some data must be in an inconsistent state but don't know what. Thanks for any help you can give.

 

-- John

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...