Jump to content
Beerman

Quickbooks incompatible with Vista

Recommended Posts

The official answer is that only QB 2007 and later are designed to run on it.

Why are only the newest versions supported on Vista?

It’s not really a support issue – in other words, it’s not Microsoft’s fault that QB doesn’t run on it.

You may know about the “Windows XP certification” that came out in 2001. In a nutshell, Microsoft came up with a list of programming techniques that were considered potentially harmful to computers. These techniques leave the OS open for attack. One of these techniques is something Intuit continued to use, up through QB 2006. This is why we never saw the Windows Certification logo on the side of a QuickBooks box.

At that time, becoming Windows XP certified was just a suggestion from Microsoft – it was not a requirement, and software that was not certified, software that continued to use the harmful techniques, could continue to run on Windows XP.

No more. Microsoft has put it’s foot down with it’s newest OS. In order to run on Vista, the software must not use the dangerous techniques. And this is why older versions of QB cannot run on it, since they use one of those techniques, and Intuit really cannot update them.

Share this post


Link to post
Share on other sites
2 hours ago, Pistle said:

The official answer is that only QB 2007 and later are designed to run on it.

Why are only the newest versions supported on Vista?

It’s not really a support issue – in other words, it’s not Microsoft’s fault that QB doesn’t run on it.

You may know about the “Windows XP certification” that came out in 2001. In a nutshell, Microsoft came up with a list of programming techniques that were considered potentially harmful to computers. These techniques leave the OS open for attack. One of these techniques is something Intuit continued to use, up through QB 2006. This is why we never saw the Windows Certification logo on the side of a QuickBooks box.

At that time, becoming Windows XP certified was just a suggestion from Microsoft – it was not a requirement, and software that was not certified, software that continued to use the harmful techniques, could continue to run on Windows XP.

No more. Microsoft has put it’s foot down with it’s newest OS. In order to run on Vista, the software must not use the dangerous techniques. And this is why older versions of QB cannot run on it, since they use one of those techniques, and Intuit really cannot update them.

Now your posting to a thirteen-year-old thread (Posted January 26, 2007!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×