Jump to content
  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • 0

If you want 8 to work you'll need to buy 9


leecrystal

Question

I noticed that the update for 8 is disabled.

 

They fixed all the bugs and repackaed the program and it's now called Version 9. :)

 

I am so upset. :huh:

 

I was waiting for them to fix this program and now its obvious they just moved on! :D

 

Why do I have to pay twice just to get somthing to work. :D

 

Funny thing is I used the trial version of 9 with very few problems, so you can't blame my system for 8 not working correctly.

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

I noticed that the update for 8 is disabled.

 

They fixed all the bugs and repackaed the program and it's now called Version 9. :)

 

I am so upset. :huh:

 

I was waiting for them to fix this program and now its obvious they just moved on! :D

 

Why do I have to pay twice just to get somthing to work. :D

 

Funny thing is I used the trial version of 9 with very few problems, so you can't blame my system for 8 not working correctly.

 

Try it two times. Go to the link that malatekid posted, select Download, sign in, then try to download it. If you get the page that says something about an error, back out, and try it again.

 

BTW, before you download the patch, make sure your version is the retail (boxed) version, and make sure that you aren't already patched to 8.05.

 

To find out your version, open Creator Classic, click on Help, then click on About.

Link to comment
Share on other sites

Guys thanks I know your just trying to help, but you misunderstand.

 

It's not your fault guys, Its Roxio.

 

My point is there has only been 1 update in a year for a program with lots of problems!

 

If you check your home on the suite and click on update and it says it's disabled. :huh:

 

It's now obvious they don't plan on doing anything about this.

 

I'm re-installing the program once again in order just to get some use out of some parts of it.

 

Program is really acting odd now after install/uninstall of trail version of 9. I'm afraid of get rid of older version (7) because it works.

 

I really don't want to drop more $ into this pit. :)

Link to comment
Share on other sites

I just checked the v8 update section - there seems to be a problem with the server and I'll pass this along to the board admin

 

MyAccount

Welcome, Daithi

PRODUCT_DOWNLOAD_FAILURE

 

Your Roxio member profile enables you to recieve special Roxio promotions, pre-fill shipping and billing information when purchasing within the Roxio store, and participate in Roxio discussion forums.

Link to comment
Share on other sites

Thanks for displaying this tip. I was getting the same error and this did allow me to download the file, but of course then I got an error trying to install the patch. 7.0 was running fine for me but then it tried to update itself and nothing worked after that. Then it gave me this update "Update_Retail_EFGJ_7_5_2_49.exe", which resulted in : the upgrade patch cannot be installed by the windows installer service because the program to be updated may be missing....

 

Looks like I'll have to reinstall from the disk and then try the patch.

 

Imagine if Windows Update were written as poorly as the Roxio updater or this message editor...

Link to comment
Share on other sites

Just been told of a workround (and it does work - I tried it)

 

Once you are on the MyAccount page, go the top and click on Support, then select Software Updates, Voila.

 

There seems to be a bug on the page tho but that will get you the update patch

Link to comment
Share on other sites

Thanks for displaying this tip. I was getting the same error and this did allow me to download the file, but of course then I got an error trying to install the patch. 7.0 was running fine for me but then it tried to update itself and nothing worked after that. Then it gave me this update "Update_Retail_EFGJ_7_5_2_49.exe", which resulted in : the upgrade patch cannot be installed by the windows installer service because the program to be updated may be missing....

 

Looks like I'll have to reinstall from the disk and then try the patch.

 

Imagine if Windows Update were written as poorly as the Roxio updater or this message editor...

 

What version of EMC are you running? If it is EMC 7.0/7.1, that patch isn't going to do anything for you. It won't work, because it is for EMC 7.5.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...