Jump to content
  • Who's Online   0 Members, 0 Anonymous, 13 Guests (See full list)

    • There are no registered users currently online

Classic Creator 6 Can't See DVD/CD Drives


Cold Steel

Recommended Posts

Before updating to the present version, I uninstalled version 6. Now I've uninstalled the problematic version 9 and have reinstalled version 6 again (twice). Both times, after installing the latest updates, Classic CD & DVD Creator does not recognize any of my three drives:

 

SONY DVD RW DRU-720A

 

_NEC DVD_RW ND-3500AG

 

LITE-ON LTR-48125W

 

The last one of these is a CD, and all three used to work with Easy CD & DVD Creator 6, but now they are not recognized by the software. Yes, they are recognized in my Device Manager. I've uninstalled the software, rebooted, reinstalled the software, rebooted again, and ran each of the update programs with the exception of Drag2Dsk, which I don't install. I've done this twice and the software doesn't see the drives.

 

In the Tools's System Tests, the drives all appear but are labeled "Unknown."

 

Since other applications recognize the drives and since the Device Manager shows the drives are working with no problem, it seems to be a Roxio problem. I had this occur once before but don't recall how I fixed it, so any help would be appreciated.

 

Thanks.

 

 

Link to comment
Share on other sites

Larry: Thank you for the pages. I downloaded the Drive Fix_Installed.exe file, ran it, rebooted and got the BSOD. Then I booted into SAFE mode and clicked on Classic Creator and it showed all my drives intact. But since I couldn't boot, that was fairly useless, so I did a System Restore and I went through the same process. Again the drives were not recognized and again I ran the Drive Fix program and BSOD again. One of the Restore Points I used was Roxio 6 Installed (but before the "fix" was applied). But even then I got the BSOD, so I concluded that the "fix" was somehow corrupting files already installed. It couldn't be a registry problem since the recovery point was just after installation and update, but before the fix.

 

Needless to say, all the reboots kind of take it out of me. Fortunately, I'd set a Recovery Point after uninstalling all Roxio products from my system, then going into the registry and manually removing all the remaining references. So far, I'm still unable to fix my system. Again, it used to work great before going with that horrid upgrade to version 9.

 

Roxio used to be such a damned good company I don't know where they lost it. I should have just stayed with version 6. I hope they come out with some significant updates to version 9. In the meantime, if you have any more ideas to get me back up to version 6, please let me know.

 

Cheers.

Link to comment
Share on other sites

The last Roxio Version built by the company called Roxio was EMC 7. At that point they sold the name & software to Sonic, and (having bought the name & software for Napster), renamed themselves Napster.

 

Sonic put out EMC 7.5, combining Roxio's EMC 7 and some Sonic programs.

 

Subsequent decisions have been made by Sonic, which now owns Roxio.

 

Lynn

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...