Jump to content
  • 0

Installation Error 1721


hopper-33@comcast.net

Question

When I tried to install Easy Media Creator Suite 8 (retail version), I got this error message:

 

"Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor."

 

Part or most of the installation was completed so I tried to download the online update but received a message saying it did not apply to my version.

 

I then decided to uninstall the program and start over but whenever I try to uninstall I get the Error 1721 message and the uninstall won't work.

 

Can someone help me get this uninstalled? My first experience with Roxio has not gone well and I'm giving up on their software.

 

Here are some particulars that may help:

 

My computers is a Gateway 400SD4 laptop and I'm running Windows XP Home Edition. I'm connected to a home wireless network and I have Norton Security 2006 installed. I have Suite 8 Build 805B 30B ENU.

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

Hi Hopper-33,

here is a few hints that may help you...

1. make sure service pack 2 for XP is installed (you dont say that below your signiture)

2. update the MS installer version to 3.1 from Microsofts online update.

3. if you have antivirus installed of any version stop the realtime protect side or stop the antivirus service just for the install.

4. if the install will not run now then use a free registry cleaner and delete the install folder under program files.

5. if then it still dosent install , copy the 2x cd's to seporate folders on your harddrive and run from there....

 

hope everything go's well....

Link to comment
Share on other sites

Hi i have the same issue, I keep getting error 1721 on the installation and it won't finish (though the program still seems to be installed) but it asks for the disc on every launch and always gets this error. I also tried uninstalling it and it doesn't work either (same error number). I have tried unregistering the windows installer (from cmd prompt> msiexec /unregister) in safe mode, the clearing the windows core file cache (from cmd prompt> sfc /purgecache) then having windows check for the proper core files (from cmd prompt> sfc /scannow) then registering windows installer (from cmd prompt>msiexec /register) and rebooting back into normal mode but still get the error. I even tried installing windows installer 3.1 v2 over again and that still didn't help. Does roxio have a removal tool that will allow me to start over again or a resolution to this?

 

PS I have also tried copying the files to HDD and disabling the anti-virus but still no go.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...