Jump to content
  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • 0

EMC9,8,8.5 & 7.5 - General Observations


SheerBedlam

Question

About a month ago, I downloaded and ran the Vista upgrade/compatibilty thingy software on my XP Pro driven PC to find out if there would be any problems running any of my software on a new Vista Ultimate PC I was thinking of buying. The Only piece of software it flagged up as been iffy was the Easy CD Creator 7.5 I had.

 

I bought my new Vista PC and also bought EMC9 as it was supposed to be Vista ready. It installed with no problems whatsoever, but I found I couldn't print any CD inserts that I had designed using the Label Creator - the application just froze on me. I made sure all the printer drivers, graphics drivers etc were all up to date and still I couldn't print an insert. I posted the problem elsewhere on this site, but no one was really able to help me.

 

I also noticed that when I tried to burn an audio CD from Mp3 files that the burn process was very slow (22x-24x max speed on my 48x CD 18x +/- DL DVD writer. I also couldn't copy a nearly full (4.4Gb) Data DVD nor a full (non protected) movie DVD faster than 6x - 6.2x. I checked the DMA settings and even switched the DVD ROM Drive & the Re-writer master/slave configuration to no avail.

 

Being so fed up, I uninstalled EMC9 and installed EMC8 to see if things improved - NO! It still froze when trying to print from Label Creator and the copy / burn speeds were still crap. I downloaded and installed a huge update (100Mb+) to upgrade from EMC 8 to EMC 8.5, and still the problems persisted.

 

So I just thought sod it ! - I uninstalled EMC 8.5 and loaded ECDC 7.5 despite Vista warning me it was incompatible and guess what? - It flies !!

That 4.4Gb data disc copied at the full 18x using a 16x DVD-R with no problems. It burns an 80min 52x CD-R faster than the drive should - Using the 'Smart Burn' 48x setting on the Lite-On, it reached 48.5x write speed. AND, I can print my CD inserts.

 

EMC9 Vista ready?? - Not a hope in hell ! Can I get a refund?? - Not a hope in hell !

Link to comment
Share on other sites

7 answers to this question

Recommended Posts

Does your EMC HOME works without a crash?? If so, why mine crashes?? :(

 

 

Talk about an open ended question?, WHY?, there may be lots of reasions, antivirus?, Patch levels on the Vista install?, Driver non-compadability?, you name it....

 

why dont you placew a bit of info here about the hardware ect, and maybe someone here can give you a lead to fix your issue.

Link to comment
Share on other sites

Well well allow me to tell you that Roxio 7, not 7.5, Roxio 7 also works fine on Vista ultimate.

 

However can someone let me know how they did to make Roxio 9 to run smoothly on Vista Ultimate since I can install it, soma apps run but the Easy Media Creator Home crashes, is this normal?

Link to comment
Share on other sites

Well well allow me to tell you that Roxio 7, not 7.5, Roxio 7 also works fine on Vista ultimate.

 

However can someone let me know how they did to make Roxio 9 to run smoothly on Vista Ultimate since I can install it, soma apps run but the Easy Media Creator Home crashes, is this normal?

I'm running EMC9 with Vista Ultimate and have done nothing other than remove Drag to Disc after installation. I did, however, install Vista on a freshly formatted drive and would not recommend upgrading from any version of Windows.

Why it works for some and not for others I don't know. The same can be said of XP and EMC9. Some have troubles and some don't.

Link to comment
Share on other sites

Very strange, because I have formatted my HD several times, 1rst time XP, install Roxio 9 and worked good, next I upgrade to Vista Ultimate and crash saying the my trial had expired, go figure. 2 time fresh instalation for Vista only then roxio 9, and the Media creator home crashes everytime, also for the apps that resemble. 3rd time install XP, upgrade to Vista then Roxio 9, and media home crashes, but some apps run good, the removed the D2D but the same issue. I removed Roxio 9 and install version 7 and runs good, without the patch.

 

What type of info I can give for developers to know my issue so then can work on a patch?

Link to comment
Share on other sites

Have you tried any other parts of 7.5? I doubt they'd all work.

EMC9 is running fine on my Vista system which has Drag to Disc removed. I have read that someone got 8 to run in XP Compatibility mode but am surprised it would work 100%.

I'm still all for waiting a few more months for MS and other vendors to work out all their kinks before I trust Vista for anything.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...