Jump to content
  • Who's Online   0 Members, 0 Anonymous, 7 Guests (See full list)

    • There are no registered users currently online
  • 0

CD Spin Doctor Input levels



Turntable-Amp-Griffin iMic-Mac Mini-OSX 10.4.8


Input levels suddenly too high for recording. The meters read into the red, even with input level at minimum in system preferences and in Spin Doctor control panel.


Any solutions?

Link to comment
Share on other sites

1 answer to this question

Recommended Posts


This topic is now archived and is closed to further replies.

  • Create New...