Jump to content
  • Who's Online   0 Members, 0 Anonymous, 6 Guests (See full list)

    • There are no registered users currently online
  • 0

DVD player doesn't work


FEast

Question

A couple of weeks ago, my tech did a reformat of my computer. I thought I had everything backed up, but, oh no, what a mess! :rolleyes: I've solved most of the problems, but one that remains is the DVD player. I simply have not been able to get it to work. My tech says I need the codecs for it, but thus far, he hasn't had the time to find and send them to me.

 

Therefore, I just now tried doing a search to find them myself, but to no avail. There's nothing under Roxio DVDMax Player, PowerDVD, or CyberLink Corp., not even on the Roxio site itself. Yet those are the titles they're giving when I check under my Roxio programs. Oh, and in case you don't know, the DVDMax Player that comes with EMC 7 is 5.0.

 

I've managed to install two other DVD players, but had become rather fond of capturing photos on my Roxio player, and it took me awhile to figure out how to do it. Therefore, rather than waste time trying to figure out what the other programs have to offer, I was wondering whether anyone here knows where I can find the right codecs? Thank you!~Bountifully, Liz

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

Did you reinstall Easy Media Creator 7 after you reformatted the drive? It should have automatically installed the correct codecs for you.
I did, and it didn't. I was very confused as to why the player wasn't working, so I asked two techs. Both said I needed the codecs. I had the same problem with the Windows Media Player (still can't get it to work) and AVS DVD player which appeared out of nowhere after the reformat (didn't have it before the reformat). I got the latter to work after one of my techs sent me the link to the codecs.
Link to comment
Share on other sites

Sadly, it didn't work. I installed the full pack, and unless I did something wrong, my Roxio DVD player still doesn't work. Oddly enough, however, I noticed that, although the program that's listed in the program folder for the DVD player says it's 5.0, the player that comes up when I try to play a DVD is 2.0. Could this be the problem, and if so, how do I fix that?

Link to comment
Share on other sites

Did you install EMC7 over an older version or perhaps you have a third party DVD player on the computer?

 

Just out of curiosity - try playing the DVD in the bundled 'Creator Player Classic' that came with the codec pack (it looks a bit like the old WMP7 but should handle just about anything).

Link to comment
Share on other sites

I'm sorry, but I'm not sure that I understand the problem.

 

Did you reinstall Easy Media Creator 7 after you reformatted the drive? It should have automatically installed the correct codecs for you.

 

If you cannot find the programs, my guess would be that your tech did not reinstall the programs you mentioned. You would have had to give him the installation disks for every program in order for him to reinstall them on the computer.

 

( They usually don't bother to tell you about needing the disks because it takes a lot of time to reinstall all the programs.)

 

If that's not the problem, please explain again what you're trying to do with EMC 7 and what happens or what error messages you're getting.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...